aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt4-svg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qt4-svg/Makefile')
-rw-r--r--graphics/qt4-svg/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/graphics/qt4-svg/Makefile b/graphics/qt4-svg/Makefile
index 67b4ada6bb66..7dd3a3e403bd 100644
--- a/graphics/qt4-svg/Makefile
+++ b/graphics/qt4-svg/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt SVG library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui xml
+QT_COMPONENTS= qmake_build moc_build corelib gui xml
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -45,15 +45,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
-.include <bsd.port.pre.mk>
-
-.if defined(PKGNAMESUFFIX) && (${PKGNAMESUFFIX} == "-debug" || ${PKGNAMESUFFIX} == "-static-debug")
-CONFIGURE_ARGS+=-debug
-.endif
-.if defined(PKGNAMESUFFIX) && (${PKGNAMESUFFIX} == "-static" || ${PKGNAMESUFFIX} == "-static-debug")
-CONFIGURE_ARGS+=-static
-.endif
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -66,10 +57,10 @@ pre-configure:
post-configure:
${REINPLACE_CMD} -e 's|${PREFIX}/lib/pkgconfig|${PREFIX}/libdata/pkgconfig|g' \
- -e 's|.*$$(QMAKE).*||g' -e 's|(test -z.*||g' ${WRKSRC}/Makefile
+ -e 's|.*$$(QMAKE).*||g' ${WRKSRC}/Makefile
${REINPLACE_CMD} -E -e 's|-L.[^[:space:]]*qt-x11-opensource.[^[:space:]]*lib||g' \
-E -e 's|(.*location=).*moc|\1${PREFIX}/bin/moc-qt4|g' \
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>