aboutsummaryrefslogtreecommitdiff
path: root/graphics/qt5-3d/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qt5-3d/Makefile')
-rw-r--r--graphics/qt5-3d/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/graphics/qt5-3d/Makefile b/graphics/qt5-3d/Makefile
new file mode 100644
index 000000000000..8d502496292e
--- /dev/null
+++ b/graphics/qt5-3d/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTNAME= 3d
+DISTVERSION= ${QT5_VERSION}
+CATEGORIES= graphics
+PKGNAMEPREFIX= qt5-
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Qt3D module
+
+# Base GCC fails to build the code, pull in a more recent compiler.
+USES= compiler:c++0x qmake
+USE_QT5= concurrent core gui qml quick buildtools_build
+QT_DIST= ${PORTNAME}
+
+USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
+
+.include <bsd.port.mk>