aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/quat-gui/Makefile')
-rw-r--r--graphics/quat-gui/Makefile25
1 files changed, 23 insertions, 2 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 5206ffa6cbb6..abad5953cfe4 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= quat
-PORTVERSION= 1.11
+PORTVERSION= 1.20
CATEGORIES= graphics
MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
PKGNAMESUFFIX= -gui
@@ -20,12 +20,33 @@ USE_X_PREFIX= yes
USE_MESA= yes
USE_REINPLACE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -L${X11BASE}/lib" LIBS="-lXext -lGL"
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -L${X11BASE}/lib" \
+ LIBS="-lXext -lGL"
+
+.if defined(WITH_OPTIMIZED_CFLAGS)
+CFLAGS+= -O3 -ffast-math
+.endif
+
+pre-everything::
+.if !defined(WITH_OPTIMIZED_CFLAGS)
+ @${ECHO_MSG} "You can enable additional compilation optimizations"
+ @${ECHO_MSG} "by defining WITH_OPTIMIZED_CFLAGS"
+.endif
post-patch:
@${REINPLACE_CMD} -E -e 's,-(march=pentium|O3|ffast-math),,g' \
${WRKSRC}/configure
@${REINPLACE_CMD} -E -e 's|-I\.[[:space:]]+-I\$$\(srcdir\)[[:space:]]+||' \
${WRKSRC}/gui/Makefile.in
+# disable data file installation since distfile does not do
+# The Right Thing(TM)
+ @${REINPLACE_CMD} -E -e \
+ 's|^(install-data-am:).*$$|\1|' \
+ ${WRKSRC}/Makefile.in
+
+post-configure:
+ @${REINPLACE_CMD} -E -e \
+ 's|^(pkgdatadir).*$$|\1=${PREFIX}/share/${PORTNAME}${PKGNAMESUFFIX}|' \
+ ${WRKSRC}/doc/Makefile
.include <bsd.port.mk>