aboutsummaryrefslogtreecommitdiff
path: root/graphics/quat-gui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/quat-gui/Makefile')
-rw-r--r--graphics/quat-gui/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/graphics/quat-gui/Makefile b/graphics/quat-gui/Makefile
index 4348856c6975..8cfdfe8407b4 100644
--- a/graphics/quat-gui/Makefile
+++ b/graphics/quat-gui/Makefile
@@ -7,7 +7,7 @@
PORTNAME= quat
PORTVERSION= 1.20
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://www.physcip.uni-stuttgart.de/phy11733/download/
PKGNAMESUFFIX= -gui
@@ -16,12 +16,13 @@ DISTNAME= quat-${PORTVERSION:S/.p/pre/}
MAINTAINER= dyeske@gmail.com
COMMENT= A Three-dimensional fractal creator (X11 GUI)
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- glut.4:${PORTSDIR}/graphics/libglut
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+USE_XORG= xext
+USE_GL= gl glut
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include -L${X11BASE}/lib" \
- LIBS="-lXext -lGL" FLUID="${X11BASE}/bin/fluid}"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -L${LOCALBASE}/lib" \
+ LIBS="-lXext -lGL" FLUID="${LOCALBASE}/bin/fluid"
.if defined(WITH_OPTIMIZED_CFLAGS)
CFLAGS+= -O3 -ffast-math