aboutsummaryrefslogtreecommitdiff
path: root/graphics/qxv/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/qxv/Makefile')
-rw-r--r--graphics/qxv/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/graphics/qxv/Makefile b/graphics/qxv/Makefile
index 8f0b805ba46c..d843379b18eb 100644
--- a/graphics/qxv/Makefile
+++ b/graphics/qxv/Makefile
@@ -8,7 +8,7 @@ CATEGORIES+= graphics
MASTER_SITES= http://labs.freehackers.org/attachments/download/422/
MAINTAINER= cy@FreeBSD.org
-COMMENT= A QT4 program that displays images of various formats
+COMMENT= Qt 4 program that displays images of various formats
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
@@ -24,22 +24,15 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
expat.6:${PORTSDIR}/textproc/expat2 \
xcb.2:${PORTSDIR}/x11/xcb
-USES= iconv
+USES= iconv qmake
USE_BZIP2= yes
USE_XORG= sm xrender xext x11 xau xdmcp ice
-USE_QT4= corelib gui qmake_build moc_build uic_build rcc_build
+USE_QT4= corelib gui moc_build uic_build rcc_build
MAKE_JOBS_UNSAFE= yes
-HAS_CONFIGURE= yes
PLIST_FILES= bin/${PORTNAME}
-NO_STAGE= yes
-do-configure:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${QMAKE} PREFIX=${PREFIX} ${PORTNAME}.pro
-
do-install:
- @cd ${WRKSRC} && ${SETENV} ${CONFIGURE_ENV} \
- ${INSTALL_PROGRAM} ${PORTNAME} ${LOCALBASE}/bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/
.include <bsd.port.mk>