aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-gd
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ruby-gd')
-rw-r--r--graphics/ruby-gd/Makefile9
-rw-r--r--graphics/ruby-gd/files/patch-extconf.rb11
2 files changed, 18 insertions, 2 deletions
diff --git a/graphics/ruby-gd/Makefile b/graphics/ruby-gd/Makefile
index 1be620a4bb36..6201076116e2 100644
--- a/graphics/ruby-gd/Makefile
+++ b/graphics/ruby-gd/Makefile
@@ -7,7 +7,7 @@
PORTNAME= GD
PORTVERSION= 0.7.4
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics ruby
MASTER_SITES= http://www.acc.ne.jp/~tam/GD/
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
@@ -36,7 +36,7 @@ CONFIGURE_ARGS+= ----enable-gd2_0 \
LIB_DEPENDS+= gd.4:${PORTSDIR}/graphics/gd
.else
CONFIGURE_ARGS+= --with-gd-include="${LOCALBASE}/include/gd"
-LIB_DEPENDS+= gd.2:${PORTSDIR}/graphics/gd
+LIB_DEPENDS+= gd1.2:${PORTSDIR}/graphics/gd
.endif
.include <bsd.port.pre.mk>
@@ -70,6 +70,11 @@ DOCS_JA= readme.ja \
post-patch:
${RUBY} -i -pe 'sub %r:/win98/windows/FONTS:, "${X11BASE}/lib/X11/fonts/TrueType"' ${WRKSRC}/sample/gdtestttf.rb
+.if defined(WITH_GD2)
+ ${RUBY} -i -pe 'sub %r:%%GD%%:, "gd"' ${WRKSRC}/extconf.rb
+.else
+ ${RUBY} -i -pe 'sub %r:%%GD%%:, "gd1"' ${WRKSRC}/extconf.rb
+.endif
post-install:
.if !defined(NOPORTDOCS)
diff --git a/graphics/ruby-gd/files/patch-extconf.rb b/graphics/ruby-gd/files/patch-extconf.rb
new file mode 100644
index 000000000000..f87e00b5c9a0
--- /dev/null
+++ b/graphics/ruby-gd/files/patch-extconf.rb
@@ -0,0 +1,11 @@
+--- extconf.rb.orig Wed May 30 23:14:17 2001
++++ extconf.rb Sun Jul 6 00:14:20 2003
+@@ -48,7 +48,7 @@
+ end
+
+ if have_library('z') and have_library('png') and
+- have_library('gd', 'gdImagePng') and have_library('m')
++ have_library('%%GD%%', 'gdImagePng') and have_library('m')
+
+ if with_config('ttf') and not have_func('gdImageStringTTF')
+ delete_link('ttf')