aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-libart2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ruby-libart2/Makefile')
-rw-r--r--graphics/ruby-libart2/Makefile41
1 files changed, 41 insertions, 0 deletions
diff --git a/graphics/ruby-libart2/Makefile b/graphics/ruby-libart2/Makefile
new file mode 100644
index 000000000000..e6bd2d5d3917
--- /dev/null
+++ b/graphics/ruby-libart2/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: ruby-libart
+# Date created: 1 September 2002
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libart
+PORTVERSION= ${RUBY_GNOME_PORTVERSION}
+CATEGORIES= graphics ruby
+MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DISTNAME= ${RUBY_GNOME_DISTNAME}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+LIB_DEPENDS= art_lgpl.5:${PORTSDIR}/graphics/libart
+
+USE_RUBY= yes
+USE_RUBY_EXTCONF= yes
+
+.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
+
+WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
+INSTALL_TARGET= site-install
+
+DOCS_EN= ChangeLog README
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_EXAMPLESDIR}/${PORTNAME}
+ ${CP} -R ${WRKSRC}/sample/* ${RUBY_EXAMPLESDIR}/${PORTNAME}/
+ ${MKDIR} ${RUBY_DOCDIR}/${PORTNAME}
+.for f in ${DOCS_EN}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_DOCDIR}/${PORTNAME}/
+.endfor
+.endif
+
+.include <bsd.port.mk>