aboutsummaryrefslogtreecommitdiff
path: root/graphics/ruby-ming/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/ruby-ming/Makefile')
-rw-r--r--graphics/ruby-ming/Makefile18
1 files changed, 7 insertions, 11 deletions
diff --git a/graphics/ruby-ming/Makefile b/graphics/ruby-ming/Makefile
index d33bd5cb7fed..5f7cc0a56515 100644
--- a/graphics/ruby-ming/Makefile
+++ b/graphics/ruby-ming/Makefile
@@ -5,9 +5,9 @@
# $FreeBSD$
PORTNAME= ming
-PORTVERSION= 0.2a.${RUBY_MING_VERSION}
+PORTVERSION= 0.3.0.${RUBY_MING_VERSION}
CATEGORIES+= graphics ruby
-MASTER_SITES= http://rubyforge.org/frs/download.php/1765/
+MASTER_SITES= http://rubyforge.org/frs/download.php/1841/
PKGNAMEPREFIX?= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}-ruby-${RUBY_MING_VERSION}
DIST_SUBDIR= ruby
@@ -15,28 +15,24 @@ DIST_SUBDIR= ruby
MAINTAINER= don@na.rim.or.jp
COMMENT= Yet another Ming module for Ruby
-LIB_DEPENDS?= ming.3:${PORTSDIR}/graphics/ming
+LIB_DEPENDS?= ming.4:${PORTSDIR}/graphics/ming
-RUBY_MING_VERSION= 0.1.6
+RUBY_MING_VERSION= 0.1.7
USE_RUBY= yes
USE_RUBY_SETUP= yes
CONFIGURE_ARGS= -- --with-ming-include=${PREFIX}/include/ming --with-ming-lib=${PREFIX}/lib
-DOCS_EN= ChangeLog README.en Usage_en.txt fonts.en
-DOCS_JA= README.ja Usage_ja.txt fonts.ja progress.rd
+DOCS= ChangeLog ChangeLog.0 INSTALL LGPL NEWS README TODO
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${RUBY_MODEXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/examples/* ${RUBY_MODEXAMPLESDIR}/
- ${MKDIR} ${RUBY_MODDOCDIR}/ja
-.for f in ${DOCS_EN}
+ ${MKDIR} ${RUBY_MODDOCDIR}
+.for f in ${DOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/
.endfor
-.for f in ${DOCS_JA}
- ${INSTALL_DATA} ${WRKSRC}/${f} ${RUBY_MODDOCDIR}/ja/
-.endfor
.endif
.include <bsd.port.mk>