aboutsummaryrefslogtreecommitdiff
path: root/graphics/scale2x/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/scale2x/Makefile')
-rw-r--r--graphics/scale2x/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/graphics/scale2x/Makefile b/graphics/scale2x/Makefile
index c47d9cd92939..58e59e544f33 100644
--- a/graphics/scale2x/Makefile
+++ b/graphics/scale2x/Makefile
@@ -7,22 +7,22 @@
PORTNAME= scale2x
PORTVERSION= 2.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Real-time graphics effect able to increase the size of small bitmaps
-LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
MAN1= scalex.1 scalerx.1
PLIST_FILES= bin/scalex bin/scalerx
-CPPFLAGS+= `libpng14-config --I_opts`
-LDFLAGS+= `libpng14-config --L_opts`
+CPPFLAGS+= `libpng15-config --I_opts`
+LDFLAGS+= `libpng15-config --L_opts`
post-patch:
${REINPLACE_CMD} -e 's|png_set_gray_1_2_4_to_8|png_set_expand_gray_1_2_4_to_8|' \