aboutsummaryrefslogtreecommitdiff
path: root/graphics/smoke/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/smoke/Makefile')
-rw-r--r--graphics/smoke/Makefile65
1 files changed, 65 insertions, 0 deletions
diff --git a/graphics/smoke/Makefile b/graphics/smoke/Makefile
new file mode 100644
index 000000000000..6097797dd52b
--- /dev/null
+++ b/graphics/smoke/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: smoke
+# Date created: 05 Feb 2004
+# Whom: Igor Pokrovsky <tiamat@comset.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= smoke
+PORTVERSION= 0.5.1
+CATEGORIES= graphics
+MASTER_SITES= http://www.chem.pwf.cam.ac.uk/~jdh30/programming/opengl/smoke/code/
+
+MAINTAINER= tiamat@comset.net
+COMMENT= Vector graphics OpenGL renderer
+
+BUILD_DEPENDS= ${LOCALBASE}/bin/tmake:${PORTSDIR}/devel/tmake
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+USE_REINPLACE= yes
+USE_SDL= yes
+USE_GL= yes
+USE_X_PREFIX= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+FREETYPE_CONFIG?= ${LOCALBASE}/bin/freetype-config
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+TMAKE?= ${LOCALBASE}/bin/tmake
+TMAKEPATH?= ${LOCALBASE}/share/tmake/freebsd-g++
+
+PORTDOCS= README
+
+.include <bsd.port.pre.mk>
+
+.if exists(${FREETYPE_CONFIG})
+FREETYPE_INCLUDEPATH!= ${FREETYPE_CONFIG} --cflags | ${SED} -e 's|-I||g'
+.endif
+.if exists(${SDL_CONFIG})
+SDL_INCLUDEPATH!= ${SDL_CONFIG} --cflags | ${SED} -e 's|-I||g; s|-D[[:graph:]]*||g'
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|%%FREETYPE_CONFIG%%|${FREETYPE_CONFIG}|g; \
+ s|%%SDL_CONFIG%%|${SDL_CONFIG}|g; \
+ s|%%FREETYPE_INCLUDEPATH%%|${FREETYPE_INCLUDEPATH}|g; \
+ s|%%SDL_INCLUDEPATH%%|${SDL_INCLUDEPATH}|g; \
+ s|%%PTHREAD_LIBS%%|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/project
+
+pre-build:
+ ${SETENV} TMAKEPATH=${TMAKEPATH} \
+ ${TMAKE} ${WRKSRC}/project >${WRKSRC}/Makefile
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/smoke ${PREFIX}/bin
+ @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}/tests
+ ${INSTALL_DATA} ${WRKSRC}/tests/tiger.* ${EXAMPLESDIR}/tests
+.ifndef (NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+.endif
+
+.include <bsd.port.post.mk>