aboutsummaryrefslogtreecommitdiff
path: root/graphics/synaesthesia/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/synaesthesia/Makefile')
-rw-r--r--graphics/synaesthesia/Makefile27
1 files changed, 16 insertions, 11 deletions
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
index c8675fed32d5..028e2de460cd 100644
--- a/graphics/synaesthesia/Makefile
+++ b/graphics/synaesthesia/Makefile
@@ -1,19 +1,17 @@
-# New ports collection makefile for: synaesthesia
-# Date created: 25 May 2001
-# Whom: petef@FreeBSD.org
-#
+# Created by: petef@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= synaesthesia
PORTVERSION= 2.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics audio
-MASTER_SITES= http://www.logarithmic.net/pfh-files/synaesthesia/ CENKES
+MASTER_SITES= http://www.logarithmic.net/pfh-files/synaesthesia/
MAINTAINER= ports@FreeBSD.org
COMMENT= Graphically represents sound in real time
+LICENSE= GPLv2
+
USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -21,15 +19,22 @@ CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
PORTDOCS= README
PLIST_FILES= bin/${PORTNAME}
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's,stdint.h,inttypes.h,' ${WRKSRC}/*.c?
@${REINPLACE_CMD} -e 's,int16_t,u_int16_t,' ${WRKSRC}/sound.cc
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/synaesthesia ${PREFIX}/bin/
-.if !defined(NOPORTDOCS)
- @${INSTALL} -d ${DOCSDIR}/
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
+PLIST_FILES+= %%DOCSDIR%%/README
+PLIST_DIRS+= %%DOCSDIR%%
.endif
.include <bsd.port.mk>