aboutsummaryrefslogtreecommitdiff
path: root/graphics/wings-devel/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/wings-devel/Makefile')
-rw-r--r--graphics/wings-devel/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/wings-devel/Makefile b/graphics/wings-devel/Makefile
index 36cbefd486b5..9143b33c4dc1 100644
--- a/graphics/wings-devel/Makefile
+++ b/graphics/wings-devel/Makefile
@@ -27,6 +27,12 @@ USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 504001
+BROKEN= "Does not compile on FreeBSD >= 5.x"
+.endif
+
post-patch:
@${CP} ${FILESDIR}/wings.sh ${WRKSRC}/wings.sh
@${REINPLACE_CMD} -e 's|!!PREFIX!!|${PREFIX}|g' ${WRKSRC}/wings.sh
@@ -44,4 +50,4 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/wings.sh ${PREFIX}/bin/wings
@${LN} -sf ${DISTNAME} ${PREFIX}/lib/erlang/lib/${PORTNAME}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>