aboutsummaryrefslogtreecommitdiff
path: root/graphics/wxsvg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/wxsvg/Makefile')
-rw-r--r--graphics/wxsvg/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
new file mode 100644
index 000000000000..75cdadd119bb
--- /dev/null
+++ b/graphics/wxsvg/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: wxsvg
+# Date created: 2006-01-08
+# Whom: Michael Johnson <ahze@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= wxsvg
+DISTVERSION= 1.0b4
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ahze@FreeBSD.org
+COMMENT= C++ library to create, manipulate, and render SVG files
+
+BUILD_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
+RUN_DEPENDS= ${WX_CONFIG}:${PORTSDIR}/x11-toolkits/wxgtk26
+
+INSTALLS_SHLIB= yes
+WX_CONFIG= wxgtk2-2.6-config
+USE_REINPLACE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GNOME= libartlgpl2
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|wx-config|${WX_CONFIG}|' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>