aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xaos/Makefile')
-rw-r--r--graphics/xaos/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index aa176d2f2857..2991f176c41c 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -30,6 +30,12 @@ CONFIGURE_ENV= LDFLAGS=-L${LOCALBASE}/lib
CONFIGURE_ARGS= --with-svga-driver=no
.endif
+.if defined(WITH_PTHREAD)
+CONFIGURE_ARGS+= --with-pthread=yes
+CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
+ CFLAGS="${PTHREAD_CFLAGS} ${CFLAGS}"
+.endif
+
CFLAGS= -DHAVE_SYS_PARAM_H \
-I${PREFIX}/include \
-pipe -O6 -fstrength-reduce -ffast-math -fomit-frame-pointer\