aboutsummaryrefslogtreecommitdiff
path: root/graphics/xmms-gforce/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xmms-gforce/Makefile')
-rw-r--r--graphics/xmms-gforce/Makefile14
1 files changed, 14 insertions, 0 deletions
diff --git a/graphics/xmms-gforce/Makefile b/graphics/xmms-gforce/Makefile
index 0ab8485c9e19..87c347051921 100644
--- a/graphics/xmms-gforce/Makefile
+++ b/graphics/xmms-gforce/Makefile
@@ -22,4 +22,18 @@ USE_X_PREFIX= yes
RESTRICTED= "Non-commercial use only"
+.if defined(WANT_DGA)
+PATCH_SITES= ${MASTER_SITES}
+PATCHFILES= gforce-1.1.6xp3.dga.patch.gz
+PATCH_WRKSRC= ${WRKDIR}
+.else
+pre-fetch:
+ @${ECHO_MSG} "******************************************************"
+ @${ECHO_MSG} "* To compile this port with DGA support (faster), *"
+ @${ECHO_MSG} "* use the WANT_DGA switch. Be aware that if XMMS *"
+ @${ECHO_MSG} "* or the plugin crashes, your whole X-session will *"
+ @${ECHO_MSG} "* be affected. DGA can't switched off once enabled. *"
+ @${ECHO_MSG} "******************************************************"
+.endif
+
.include <bsd.port.mk>