aboutsummaryrefslogtreecommitdiff
path: root/graphics/xsane/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/xsane/Makefile')
-rw-r--r--graphics/xsane/Makefile44
1 files changed, 25 insertions, 19 deletions
diff --git a/graphics/xsane/Makefile b/graphics/xsane/Makefile
index d6570e4fd5c8..443d59ed61c3 100644
--- a/graphics/xsane/Makefile
+++ b/graphics/xsane/Makefile
@@ -24,44 +24,50 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
USE_GMAKE= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
+WANT_GNOME= yes
+USE_GETTEXT= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib -lintl"
MAN1= xsane.1
-.if defined(WITH_GIMP)
-LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp1
-CONFIGURE_ARGS+= --enable-gimp
-.else
-CONFIGURE_ARGS+= --disable-gimp
-.endif
+#SUB_FILES+= pkg-message
-.if defined(WITH_GTK2)
-USE_GNOME= gtk20
-.else
+OPTIONS= GTK2 "Enable GTK2 support (use GTK1 if turned off)" on \
+ GIMP "Enable GIMP plugin support" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_GTK2)
USE_GNOME= gtk12
CONFIGURE_ARGS+= --disable-gtk2
+.else
+USE_GNOME= gtk20
.endif
-.include <bsd.port.pre.mk>
+.if defined(WITH_GIMP)
+SUB_FILES+= pkg-message
+.if defined(WITHOUT_GTK2)
+LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp1
+CONFIGURE_ARGS+= --disable-gimp2
+.else
+LIB_DEPENDS+= gimp:${PORTSDIR}/graphics/gimp
+.endif # WITHOUT_GTK2
+.else
+CONFIGURE_ARGS+= --disable-gimp
+.endif
.if ${OSVERSION} < 500035
CONFIGURE_ENV+= CFLAGS="${CFLAGS:C/-O[0-9]*//g}"
.endif
-pre-everything::
-.if !defined(WITH_GIMP)
- @${ECHO_MSG} "*** Note: XSane can be built with a standalone"
- @${ECHO_MSG} "*** X scanner interface as well as a GIMP plug-in."
- @${ECHO_MSG} "*** If you wish to do this, hit Ctrl-C now and use"
- @${ECHO_MSG} "*** \"WITH_GIMP=yes\""
-.endif
-
pre-patch:
@${FIND} ${WRKSRC} -name 'Makefile.in' | ${XARGS} ${REINPLACE_CMD} \
-i "" -e 's|\$$(sbindir)||g'
post-install:
- @${SED} 's:/usr/X11R6:${PREFIX}:' ${PKGMESSAGE}
+.if defined(WITH_GIMP)
+ @${CAT} ${PKGMESSAGE}
+.endif
.include <bsd.port.post.mk>