aboutsummaryrefslogtreecommitdiff
path: root/graphics/zphoto
diff options
context:
space:
mode:
Diffstat (limited to 'graphics/zphoto')
-rw-r--r--graphics/zphoto/Makefile2
-rw-r--r--graphics/zphoto/distinfo2
-rw-r--r--graphics/zphoto/files/patch-templates::all::Makefile.in11
-rw-r--r--graphics/zphoto/files/patch-util.c11
-rw-r--r--graphics/zphoto/files/patch-zphoto.c19
5 files changed, 2 insertions, 43 deletions
diff --git a/graphics/zphoto/Makefile b/graphics/zphoto/Makefile
index b8414d6d6d7e..bf0a850dd65c 100644
--- a/graphics/zphoto/Makefile
+++ b/graphics/zphoto/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= zphoto
-PORTVERSION= 0.4
+PORTVERSION= 0.5
CATEGORIES= graphics www
MASTER_SITES= http://namazu.org/~satoru/zphoto/
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/zphoto/distinfo b/graphics/zphoto/distinfo
index ef899ec282db..69b94a630dac 100644
--- a/graphics/zphoto/distinfo
+++ b/graphics/zphoto/distinfo
@@ -1 +1 @@
-MD5 (zphoto-0.4.tar.gz) = 585faf9925ec65c33a599feb014147df
+MD5 (zphoto-0.5.tar.gz) = 8ad7d216d0e4aa0d37546cf2de087ed3
diff --git a/graphics/zphoto/files/patch-templates::all::Makefile.in b/graphics/zphoto/files/patch-templates::all::Makefile.in
deleted file mode 100644
index 257c4ec43d01..000000000000
--- a/graphics/zphoto/files/patch-templates::all::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- templates/all/Makefile.in.orig Tue Jan 28 22:56:04 2003
-+++ templates/all/Makefile.in Fri Jan 31 01:51:27 2003
-@@ -70,7 +70,7 @@
- ZPHOTO_URL = @ZPHOTO_URL@
-
- templatesdir = $(pkgdatadir)/templates/all
--templates_DATA = zphoto.css
-+templates_DATA = zphoto.css .photo.html
- mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
- CONFIG_HEADER = ../../config.h
- CONFIG_CLEAN_FILES =
diff --git a/graphics/zphoto/files/patch-util.c b/graphics/zphoto/files/patch-util.c
deleted file mode 100644
index b217d23c5014..000000000000
--- a/graphics/zphoto/files/patch-util.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- util.c.orig Tue Jan 28 19:18:20 2003
-+++ util.c Wed Jan 29 00:55:26 2003
-@@ -57,7 +57,7 @@
- exit(2);
- }
-
--extern int vasprintf (char **ptr, const char *fmt, ...);
-+/* extern int vasprintf (char **ptr, const char *fmt, ...); */
-
- char *
- zphoto_asprintf (const char *fmt, ...)
diff --git a/graphics/zphoto/files/patch-zphoto.c b/graphics/zphoto/files/patch-zphoto.c
deleted file mode 100644
index b7e6fe1eb57f..000000000000
--- a/graphics/zphoto/files/patch-zphoto.c
+++ /dev/null
@@ -1,19 +0,0 @@
---- zphoto.c.orig Tue Jan 28 19:18:20 2003
-+++ zphoto.c Fri Jan 31 01:34:57 2003
-@@ -248,7 +248,7 @@
- int width, height;
- char *photo_width, *photo_height;
-
-- photo_file_name = basename(options->input_photos[id]);
-+ photo_file_name = zphoto_strdup(basename(options->input_photos[id]));
- if (id > 0)
- prev_file_name =
- zphoto_modify_suffix(basename(options->input_photos[id - 1]),
-@@ -283,6 +283,7 @@
- zphoto_create_date_string(date_string, BUFSIZ,
- zphoto_get_mtime(options->input_photos[id]));
- zphoto_template_add_subst(template, "photo_date", date_string);
-+ free(photo_file_name);
- free(prev_file_name);
- free(next_file_name);
- free(photo_width);