aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/pixmap/Makefile28
-rw-r--r--graphics/pixmap/files/patch-PixEdit.c25
-rw-r--r--graphics/pixmap/files/patch-Pixmap.c10
-rw-r--r--graphics/pixmap/files/patch-SelFile__Draw.c11
-rw-r--r--graphics/pixmap/files/patch-SelFile__Path.c10
5 files changed, 70 insertions, 14 deletions
diff --git a/graphics/pixmap/Makefile b/graphics/pixmap/Makefile
index 67676901169a..bc27ea69f302 100644
--- a/graphics/pixmap/Makefile
+++ b/graphics/pixmap/Makefile
@@ -1,31 +1,31 @@
-# New ports collection makefile for: pixmap
-# Date created: 19 February 1995
-# Whom: jmz
-#
+# Created by: jmz
# $FreeBSD$
-#
PORTNAME= pixmap
PORTVERSION= 2.6
PORTREVISION= 3
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_XCONTRIB}
-MASTER_SITE_SUBDIR= applications/pixmap
+MASTER_SITES= XCONTRIB/applications/pixmap
DISTNAME= ${PORTNAME}${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A pixmap editor based on XPM library
+COMMENT= Pixmap editor based on XPM library
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT
# requires rgb.txt
-BUILD_DEPENDS= xrdb:${PORTSDIR}/x11/xrdb \
- showrgb:${PORTSDIR}/x11/rgb
+BUILD_DEPENDS= showrgb:${PORTSDIR}/x11/rgb \
+ xrdb:${PORTSDIR}/x11/xrdb
+WRKSRC= ${WRKDIR}/${PORTNAME}
-WRKSRC= ${WRKDIR}/pixmap
-USE_IMAKE= yes
USE_XORG= xpm xbitmaps x11 xaw xmu xt sm ice xext
-MAN1= pixmap.1
+USE_IMAKE= yes
+
+CFLAGS+= -D_X_SENTINEL\(x\)= -D_X_ATTRIBUTE_PRINTF\(x,y\)= \
+ -D_X_DEPRECATED= -DUSG
-CFLAGS+= -D_X_SENTINEL\(x\)= -D_X_ATTRIBUTE_PRINTF\(x,y\)=
+MAN1= pixmap.1
.include <bsd.port.mk>
diff --git a/graphics/pixmap/files/patch-PixEdit.c b/graphics/pixmap/files/patch-PixEdit.c
new file mode 100644
index 000000000000..1c75fb8ae956
--- /dev/null
+++ b/graphics/pixmap/files/patch-PixEdit.c
@@ -0,0 +1,25 @@
+--- PixEdit.c.orig
++++ PixEdit.c
+@@ -59,6 +59,7 @@
+
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <X11/Intrinsic.h>
+ #include <X11/Xos.h>
+ #include <X11/Xfuncs.h>
+@@ -1938,7 +1939,7 @@
+
+
+
+-void main(argc, argv)
++int main(argc, argv)
+ int argc;
+ char *argv[];
+ {
+@@ -2281,4 +2282,5 @@
+
+ XtRealizeWidget(top_widget);
+ XtAppMainLoop(pixmap_context);
++ return 0;
+ }
diff --git a/graphics/pixmap/files/patch-Pixmap.c b/graphics/pixmap/files/patch-Pixmap.c
new file mode 100644
index 000000000000..19f06f57afa5
--- /dev/null
+++ b/graphics/pixmap/files/patch-Pixmap.c
@@ -0,0 +1,10 @@
+--- Pixmap.c.orig
++++ Pixmap.c
+@@ -67,6 +67,7 @@
+ #include "PixmapP.h"
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <math.h>
+
+ #define XtStrlen(s) ((s) ? strlen(s) : 0)
diff --git a/graphics/pixmap/files/patch-SelFile__Draw.c b/graphics/pixmap/files/patch-SelFile__Draw.c
new file mode 100644
index 000000000000..e3304b191679
--- /dev/null
+++ b/graphics/pixmap/files/patch-SelFile__Draw.c
@@ -0,0 +1,11 @@
+--- SelFile/Draw.c.orig
++++ SelFile/Draw.c
+@@ -189,7 +189,7 @@
+ }
+ }
+
+-static
++static void
+ SFdeleteEntry(dir, entry)
+ SFDir *dir;
+ SFEntry *entry;
diff --git a/graphics/pixmap/files/patch-SelFile__Path.c b/graphics/pixmap/files/patch-SelFile__Path.c
new file mode 100644
index 000000000000..265d89f52ca5
--- /dev/null
+++ b/graphics/pixmap/files/patch-SelFile__Path.c
@@ -0,0 +1,10 @@
+--- SelFile/Path.c.orig
++++ SelFile/Path.c
+@@ -529,6 +529,7 @@
+ return 0;
+ }
+
++void
+ SFupdatePath()
+ {
+ static int alloc;