aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/linux-divxplayer/Makefile59
-rw-r--r--graphics/linux-divxplayer/distinfo1
-rw-r--r--graphics/linux-divxplayer/files/wrapper.sh14
-rw-r--r--graphics/linux-divxplayer/pkg-comment1
-rw-r--r--graphics/linux-divxplayer/pkg-descr8
-rw-r--r--graphics/linux-divxplayer/pkg-message11
-rw-r--r--graphics/linux-divxplayer/pkg-plist7
8 files changed, 102 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index cf93aa01b2ee..3a872d5c263b 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -179,6 +179,7 @@
SUBDIR += libxine
SUBDIR += linplasma
SUBDIR += linux-bmrt
+ SUBDIR += linux-divxplayer
SUBDIR += linux-imlib
SUBDIR += linux-jpeg
SUBDIR += linux-png
diff --git a/graphics/linux-divxplayer/Makefile b/graphics/linux-divxplayer/Makefile
new file mode 100644
index 000000000000..617783a28643
--- /dev/null
+++ b/graphics/linux-divxplayer/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: divx.com player
+# Date created: Sun May 19 22:17:41 BRT 2002
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= divxplayer
+PORTVERSION= 0.2.0
+CATEGORIES= graphics linux
+MASTER_SITES= http://download.divx.com/player/
+PKGNAMEPREFIX= linux-
+DISTNAME= divx-player-installer
+
+MAINTAINER= lioux@FreeBSD.org
+
+RUN_DEPENDS= \
+ ${LINUXBASE}/etc/redhat-release:${PORTSDIR}/emulators/linux_base-7
+
+ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
+NO_BUILD= yes
+STRIP=
+
+WRKSRC= ${WRKDIR}/divx-player-installer
+
+STRIP_CMD= ${LINUXBASE}/usr/bin/strip
+
+.if exists(/usr/bin/brandelf)
+BRANDELF?= /usr/bin/brandelf
+.else
+BRANDELF?= brandelf
+.endif
+
+BINARY_NAME= divxPlayer.bin
+
+post-patch:
+ @${SED} -e "s|%%DATADIR%%|${DATADIR}|" ${FILESDIR}/wrapper.sh \
+ > ${WRKDIR}/wrapper.sh
+
+pre-install:
+.if exists(${STRIP_CMD})
+ @${STRIP_CMD} ${WRKSRC}/${BINARY_NAME}
+.endif
+ @${BRANDELF} -t Linux ${WRKSRC}/${BINARY_NAME}
+
+do-install:
+# skin files
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/Skins
+ @${INSTALL_DATA} ${WRKSRC}/Skins/* ${DATADIR}/Skins
+# player
+ @${INSTALL_PROGRAM} ${WRKSRC}/${BINARY_NAME} ${PREFIX}/bin
+ @${INSTALL_SCRIPT} ${WRKDIR}/wrapper.sh \
+ ${PREFIX}/bin/${BINARY_NAME:S/.bin$//}
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/linux-divxplayer/distinfo b/graphics/linux-divxplayer/distinfo
new file mode 100644
index 000000000000..32ac7691dc08
--- /dev/null
+++ b/graphics/linux-divxplayer/distinfo
@@ -0,0 +1 @@
+MD5 (divx-player-installer.tar.gz) = d0c5188e0a70427f69ade79f6e780031
diff --git a/graphics/linux-divxplayer/files/wrapper.sh b/graphics/linux-divxplayer/files/wrapper.sh
new file mode 100644
index 000000000000..5b56eef46a6b
--- /dev/null
+++ b/graphics/linux-divxplayer/files/wrapper.sh
@@ -0,0 +1,14 @@
+#!/bin/sh
+
+PROGRAM="${0}"
+DATADIR="%%DATADIR%%"
+DIVX_SKIN_DIR=${DATADIR}/Skins
+
+export DIVX_SKIN_DIR
+
+if [ -f ~/.divxPlayer/DivXPlayer.dbf ]
+then
+ rm -f ~/.divxPlayer/DivXPlayer.dbf
+fi
+
+exec ${PROGRAM}.bin ${*}
diff --git a/graphics/linux-divxplayer/pkg-comment b/graphics/linux-divxplayer/pkg-comment
new file mode 100644
index 000000000000..6c27acf380b7
--- /dev/null
+++ b/graphics/linux-divxplayer/pkg-comment
@@ -0,0 +1 @@
+DivX(TM) Video Player for Linux from DivX.com
diff --git a/graphics/linux-divxplayer/pkg-descr b/graphics/linux-divxplayer/pkg-descr
new file mode 100644
index 000000000000..fcb842d75b17
--- /dev/null
+++ b/graphics/linux-divxplayer/pkg-descr
@@ -0,0 +1,8 @@
+[ from developer's site ]
+
+The DivX(TM) Player for Linux from DivX.com is built from the same
+codebase as the Windows version. It performs exactly like its Windows
+cousin in all respects, and can even use the same skin files. Behold
+the wonders of cross-platform development.
+
+WWW: http://www.divx.com/
diff --git a/graphics/linux-divxplayer/pkg-message b/graphics/linux-divxplayer/pkg-message
new file mode 100644
index 000000000000..c2d67fdcfd6e
--- /dev/null
+++ b/graphics/linux-divxplayer/pkg-message
@@ -0,0 +1,11 @@
+ ATTENTIONATTENTION:
+
+This port requires linux_base-7. linux_base-6 or earlier
+will not do. Please, make sure you have linux_base-7
+installed.
+
+Moreover, this is an an alpha release, so there are some bugs.
+Do not be surprised if the player does not work at all for
+you.
+
+Report all bugs to http://www.divx.com/
diff --git a/graphics/linux-divxplayer/pkg-plist b/graphics/linux-divxplayer/pkg-plist
new file mode 100644
index 000000000000..3bbe720386b3
--- /dev/null
+++ b/graphics/linux-divxplayer/pkg-plist
@@ -0,0 +1,7 @@
+bin/divxPlayer
+bin/divxPlayer.bin
+share/divxplayer/Skins/Corner.zip
+share/divxplayer/Skins/Default.dps
+share/divxplayer/Skins/divxexplorer.dps
+@dirrm share/divxplayer/Skins
+@dirrm share/divxplayer