aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fracplanet/Makefile8
-rw-r--r--graphics/freeglut/Makefile7
-rw-r--r--graphics/icoutils/Makefile8
-rw-r--r--graphics/ipe/Makefile6
-rw-r--r--graphics/kbarcode/Makefile11
-rw-r--r--graphics/pixie/Makefile8
-rw-r--r--graphics/quesa/Makefile4
-rw-r--r--graphics/renderpark/Makefile7
-rw-r--r--graphics/xrml/Makefile11
9 files changed, 9 insertions, 61 deletions
diff --git a/graphics/fracplanet/Makefile b/graphics/fracplanet/Makefile
index 6a331779cd9d..c2c2e3dc1151 100644
--- a/graphics/fracplanet/Makefile
+++ b/graphics/fracplanet/Makefile
@@ -35,12 +35,6 @@ BASH?= ${LOCALBASE}/bin/bash
QMAKE?= ${LOCALBASE}/bin/qmake
QMAKESPEC?= ${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= Does not build on FreeBSD 4.x
-.endif
-
post-patch:
.for file in VERSION configure
@${REINPLACE_CMD} -e 's|#!/bin/bash|#!${BASH}|g' ${WRKSRC}/${file}
@@ -58,4 +52,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/freeglut/Makefile b/graphics/freeglut/Makefile
index 64de29418338..2d6b57037a6a 100644
--- a/graphics/freeglut/Makefile
+++ b/graphics/freeglut/Makefile
@@ -35,12 +35,7 @@ DOCS= download.html freeglut.html freeglut_logo.png \
progress.html structure.html
BINS= CallbackMaker Fractals Fractals_random Lorenz One shapes
-.include <bsd.port.pre.mk>
-
pre-configure:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e "s|-Werror||" ${WRKSRC}/configure
-.endif
.for fract in /fractals.c _random/fractals_random.c
@${REINPLACE_CMD} -e "s|/usr/local|${PREFIX}|g" \
${WRKSRC}/progs/demos/Fractals${fract}
@@ -72,4 +67,4 @@ post-install:
-e "s|/usr/X11R6|${X11BASE}|"
@${ECHO_MSG}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/icoutils/Makefile b/graphics/icoutils/Makefile
index bc1d5c84c617..f53bea33615b 100644
--- a/graphics/icoutils/Makefile
+++ b/graphics/icoutils/Makefile
@@ -39,10 +39,4 @@ post-patch:
-e 's|stdint\.h|inttypes\.h|g' \
-e 's|/usr/bin/perl|${PERL5}|'
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-USE_GCC=3.4
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/ipe/Makefile b/graphics/ipe/Makefile
index 9a548064f43f..5eb9b6ff3f96 100644
--- a/graphics/ipe/Makefile
+++ b/graphics/ipe/Makefile
@@ -31,12 +31,6 @@ MAN1= figtoipe.1 ipe.1 ipe5toxml.1 ipetoipe.1 ipetopng.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 500000
-# the problem is a little more subtle, really. It requires gcc 3
-USE_GCC= 3.4
-BROKEN= Does not compile on 4.x
-.endif
-
QTDIR?= ${QT_PREFIX}
QMAKE?= ${LOCALBASE}/bin/qmake
diff --git a/graphics/kbarcode/Makefile b/graphics/kbarcode/Makefile
index dac60771070a..c59f1bf24c8a 100644
--- a/graphics/kbarcode/Makefile
+++ b/graphics/kbarcode/Makefile
@@ -22,13 +22,4 @@ USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
INSTALLS_ICONS= yes
-.include <bsd.port.pre.mk>
-
-post-patch:
-.if ${OSVERSION} < 500000
- @${REINPLACE_CMD} -e 's/return false/return QString::null/g ; \
- s/ or / || /g ; \
- s/ and / \&\& /g' ${WRKSRC}/kbarcode/tec.cpp
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/pixie/Makefile b/graphics/pixie/Makefile
index ab25564b6d53..f13bd3d0cb1b 100644
--- a/graphics/pixie/Makefile
+++ b/graphics/pixie/Makefile
@@ -37,12 +37,6 @@ PIXIE_SHLIBS= file framebuffer rgbe
SUB_LIST+= PORTNAME=${PORTNAME}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-NOT_FOR_ARCHS= alpha
-.endif
-
post-patch:
@${FIND} -X ${WRKSRC} -name '*.cpp' -or -name '*.h' | \
${XARGS} ${REINPLACE_CMD} -i '' -e 's|malloc\.h|stdlib\.h|g'
@@ -100,4 +94,4 @@ do-install:
.endfor
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/quesa/Makefile b/graphics/quesa/Makefile
index f3d954e76264..4e9cad26b297 100644
--- a/graphics/quesa/Makefile
+++ b/graphics/quesa/Makefile
@@ -37,10 +37,6 @@ PLIST_SUB= WITH_EXAMPLES="@comment "
PLIST_SUB= WITH_EXAMPLES=""
.endif
-.if ${OSVERSION} < 500000
-BROKEN= Does not compile on 4.x
-.endif
-
.ifndef (WITH_EXAMPLES)
pre-everything::
@${ECHO_CMD} ""
diff --git a/graphics/renderpark/Makefile b/graphics/renderpark/Makefile
index 17a508648c80..f423e0ab879d 100644
--- a/graphics/renderpark/Makefile
+++ b/graphics/renderpark/Makefile
@@ -31,13 +31,8 @@ WRKSRC2= ${WRKDIR}/Scenes
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_MOTIF= yes
-
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
USE_GCC= 2.95
NOT_FOR_ARCHS= amd64 sparc64 ia64
-.endif
.if !defined(WITH_SCENES)
PLIST_SUB= WITH_SCENES="@comment "
@@ -100,4 +95,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/DOC/UserGuide/* ${DOCSDIR}/UserGuide
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/xrml/Makefile b/graphics/xrml/Makefile
index 06e014cb49cd..dd0037bd1372 100644
--- a/graphics/xrml/Makefile
+++ b/graphics/xrml/Makefile
@@ -23,6 +23,8 @@ USE_X_PREFIX= yes
USE_GL= yes
USE_MOTIF= yes
USE_LDCONFIG= yes
+USE_GCC= 2.95
+NOT_FOR_ARCHS= amd64 sparc64 ia64
.if !defined(WITH_EXAMPLES)
PLIST_SUB= WITH_EXAMPLES="@comment "
@@ -30,13 +32,6 @@ PLIST_SUB= WITH_EXAMPLES="@comment "
PLIST_SUB= WITH_EXAMPLES=""
.endif
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 500000
-USE_GCC= 2.95
-NOT_FOR_ARCHS= amd64 sparc64 ia64
-.endif
-
.ifndef (WITH_EXAMPLES)
pre-everything::
@${ECHO_MSG} "You can define WITH_EXAMPLES=yes to install example VRML files"
@@ -102,4 +97,4 @@ do-install:
${LN} -sf VRML97 ${DOCSDIR}/VRML
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>