aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Mesa3/Makefile2
-rw-r--r--graphics/dia/Makefile2
-rw-r--r--graphics/electriceyes/Makefile2
-rw-r--r--graphics/eog/Makefile2
-rw-r--r--graphics/eog2/Makefile2
-rw-r--r--graphics/gcolor/Makefile2
-rw-r--r--graphics/giram/Makefile2
-rw-r--r--graphics/gnofract4d/Makefile2
-rw-r--r--graphics/gnomeiconedit/Makefile2
-rw-r--r--graphics/gpaint/Makefile2
-rw-r--r--graphics/gqview/Makefile2
-rw-r--r--graphics/gtkgraph/Makefile2
-rw-r--r--graphics/gview/Makefile2
-rw-r--r--graphics/mesagl/Makefile2
-rw-r--r--graphics/morpheus/Makefile2
-rw-r--r--graphics/smpeg-xmms/Makefile2
-rw-r--r--graphics/sodipodi/Makefile2
-rw-r--r--graphics/xmps/Makefile4
18 files changed, 19 insertions, 19 deletions
diff --git a/graphics/Mesa3/Makefile b/graphics/Mesa3/Makefile
index 0c1e8142ab4a..657ef8b8657e 100644
--- a/graphics/Mesa3/Makefile
+++ b/graphics/Mesa3/Makefile
@@ -51,7 +51,7 @@ MAKE_ENV+= SUB_GL=${SUB_GL} \
INCLUDE_GL=${INCLUDE_GL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/config.c
diff --git a/graphics/dia/Makefile b/graphics/dia/Makefile
index 69fd0575d9cb..9bc220594bb9 100644
--- a/graphics/dia/Makefile
+++ b/graphics/dia/Makefile
@@ -34,7 +34,7 @@ CONFIGURE_ARGS= --enable-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/electriceyes/Makefile b/graphics/electriceyes/Makefile
index 46b83229e5af..58b9b5c6fe4b 100644
--- a/graphics/electriceyes/Makefile
+++ b/graphics/electriceyes/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
index 7ea2b1219ca7..4ca742492b49 100644
--- a/graphics/eog/Makefile
+++ b/graphics/eog/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/eog2/Makefile b/graphics/eog2/Makefile
index 7ea2b1219ca7..4ca742492b49 100644
--- a/graphics/eog2/Makefile
+++ b/graphics/eog2/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/gcolor/Makefile b/graphics/gcolor/Makefile
index ae28b6392d22..f1a52fe1e9b7 100644
--- a/graphics/gcolor/Makefile
+++ b/graphics/gcolor/Makefile
@@ -20,7 +20,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/giram/Makefile b/graphics/giram/Makefile
index 8d4b08e6d5e2..c95f1bc1c025 100644
--- a/graphics/giram/Makefile
+++ b/graphics/giram/Makefile
@@ -35,7 +35,7 @@ CONFIGURE_ARGS+=--disable-gnome
.endif
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/graphics/gnofract4d/Makefile b/graphics/gnofract4d/Makefile
index 23e2c594ee5d..45582c00a9a5 100644
--- a/graphics/gnofract4d/Makefile
+++ b/graphics/gnofract4d/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g'
diff --git a/graphics/gnomeiconedit/Makefile b/graphics/gnomeiconedit/Makefile
index c6da584f6f5a..efe0cdd3b052 100644
--- a/graphics/gnomeiconedit/Makefile
+++ b/graphics/gnomeiconedit/Makefile
@@ -31,7 +31,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/gpaint/Makefile b/graphics/gpaint/Makefile
index 41c20b193be9..e3d851cc106d 100644
--- a/graphics/gpaint/Makefile
+++ b/graphics/gpaint/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index d8394d99c377..88e908ad674d 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= gqview.1
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|GNOME_DATADIR\)/gnome/|GNOME_DATADIR\)/|g'
diff --git a/graphics/gtkgraph/Makefile b/graphics/gtkgraph/Makefile
index 713f81a31417..eeab113ea676 100644
--- a/graphics/gtkgraph/Makefile
+++ b/graphics/gtkgraph/Makefile
@@ -22,7 +22,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; s|-O2|${CFLAGS}| ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; s|-O2|${CFLAGS}| ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
.include <bsd.port.mk>
diff --git a/graphics/gview/Makefile b/graphics/gview/Makefile
index 3bd835aa3255..3887947ae027 100644
--- a/graphics/gview/Makefile
+++ b/graphics/gview/Makefile
@@ -21,7 +21,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g ; \
s|USE_INCLUDED_LIBINTL=yes|#USE_INCLUDED_LIBINTL=yes|g ; \
s|\$$\(top_builddir\)/intl/libintl.a|-lintl|g' ${WRKSRC}/configure
diff --git a/graphics/mesagl/Makefile b/graphics/mesagl/Makefile
index 0c1e8142ab4a..657ef8b8657e 100644
--- a/graphics/mesagl/Makefile
+++ b/graphics/mesagl/Makefile
@@ -51,7 +51,7 @@ MAKE_ENV+= SUB_GL=${SUB_GL} \
INCLUDE_GL=${INCLUDE_GL}
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
post-configure:
@${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|' ${WRKSRC}/src/config.c
diff --git a/graphics/morpheus/Makefile b/graphics/morpheus/Makefile
index 29a924482756..809abe40650f 100644
--- a/graphics/morpheus/Makefile
+++ b/graphics/morpheus/Makefile
@@ -24,7 +24,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/smpeg-xmms/Makefile b/graphics/smpeg-xmms/Makefile
index 0fb7cf9a9a66..52b98275fe17 100644
--- a/graphics/smpeg-xmms/Makefile
+++ b/graphics/smpeg-xmms/Makefile
@@ -25,7 +25,7 @@ CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
post-configure:
diff --git a/graphics/sodipodi/Makefile b/graphics/sodipodi/Makefile
index e01cb6e94abe..261f313371de 100644
--- a/graphics/sodipodi/Makefile
+++ b/graphics/sodipodi/Makefile
@@ -26,7 +26,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
diff --git a/graphics/xmps/Makefile b/graphics/xmps/Makefile
index 36b9123f82d5..8c4339620bb7 100644
--- a/graphics/xmps/Makefile
+++ b/graphics/xmps/Makefile
@@ -25,12 +25,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e "s|-lpthread|-pthread|g" ${WRKSRC}/configure
+ @${PERL} -pi -e "s|-lpthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
@find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
's|\$$\(datadir\)/gnome/|\$$\(datadir\)/|g ; \
s|\$$\(datadir\)/aclocal|\$$\(prefix\)/share/aclocal|g ; \
s|\$$\(datadir\)/locale|\$$\(prefix\)/share/locale|g ; \
- s|-lpthread|-pthread|g'
+ s|-lpthread|${PTHREAD_LIBS}|g'
post-configure:
@${PERL} -pi -e 's|^deplibs_check_method=.*|deplibs_check_method=pass_all|' \