aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/pornview/Makefile31
-rw-r--r--graphics/pornview/distinfo1
-rw-r--r--graphics/pornview/pkg-comment1
-rw-r--r--graphics/pornview/pkg-descr10
-rw-r--r--graphics/pornview/pkg-plist5
6 files changed, 49 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index d422b0780846..635d1548b324 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -299,6 +299,7 @@
SUBDIR += pngcheck
SUBDIR += pngcrush
SUBDIR += pngquant
+ SUBDIR += pornview
SUBDIR += povray
SUBDIR += povray31
SUBDIR += ppm2fli
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
new file mode 100644
index 000000000000..070eef0ce926
--- /dev/null
+++ b/graphics/pornview/Makefile
@@ -0,0 +1,31 @@
+# New ports collection Makefile for: pornview
+# Date created: 24 Nov 2002
+# Whom: Tilman Linneweh <arved@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pornview
+PORTVERSION= 0.1.2.b
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:S/.b/b/}
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png \
+# xine.2:${PORTSDIR}/graphics/libxine
+
+GNU_CONFIGURE= yes
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include/" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+#CONFIGURE_ARGS+= --with-xine
+USE_GNOMENG= yes
+USE_GNOME= gtk12 gdkpixbuf gnomehier gnomeprefix
+USE_REINPLACE= yes
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,$(datadir)/gnome/apps/,$(datadir)/apps/,' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/graphics/pornview/distinfo b/graphics/pornview/distinfo
new file mode 100644
index 000000000000..0edfd4c7bdcb
--- /dev/null
+++ b/graphics/pornview/distinfo
@@ -0,0 +1 @@
+MD5 (pornview-0.1.2b.tar.gz) = a432afd58234e78c8d17cef8a129782d
diff --git a/graphics/pornview/pkg-comment b/graphics/pornview/pkg-comment
new file mode 100644
index 000000000000..2877c3d33e31
--- /dev/null
+++ b/graphics/pornview/pkg-comment
@@ -0,0 +1 @@
+PornView is an image viewer/manager
diff --git a/graphics/pornview/pkg-descr b/graphics/pornview/pkg-descr
new file mode 100644
index 000000000000..c46fe36299cd
--- /dev/null
+++ b/graphics/pornview/pkg-descr
@@ -0,0 +1,10 @@
+PornView is an image viewer/manager
+
+Features:
+- Thumbnail list display.
+- Thumbnails can be cached to disk for faster subsequent loads.
+- Zoom in, out, and fit to window.
+- Slideshow.
+- Full screen viewing.
+
+WWW: http://pornview.sourceforge.net
diff --git a/graphics/pornview/pkg-plist b/graphics/pornview/pkg-plist
new file mode 100644
index 000000000000..6a85a2e0e5ca
--- /dev/null
+++ b/graphics/pornview/pkg-plist
@@ -0,0 +1,5 @@
+bin/pornview
+share/gnome/pornview/logo.png
+share/gnome/pixmaps/pornview.png
+share/gnome/apps/Graphics/pornview.desktop
+@dirrm share/gnome/pornview