aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-Chart/Makefile9
-rw-r--r--graphics/p5-GD-Graph3d/Makefile7
-rw-r--r--graphics/p5-GD/Makefile5
-rw-r--r--graphics/p5-GD1/Makefile5
-rw-r--r--graphics/p5-GD2/Makefile5
-rw-r--r--graphics/p5-chart/Makefile9
6 files changed, 19 insertions, 21 deletions
diff --git a/graphics/p5-Chart/Makefile b/graphics/p5-Chart/Makefile
index 48252f3556bb..2b97b6b9636c 100644
--- a/graphics/p5-Chart/Makefile
+++ b/graphics/p5-Chart/Makefile
@@ -5,26 +5,23 @@
# $FreeBSD$
#
-PORTNAME= chart
+PORTNAME= Chart
PORTVERSION= 0.99b
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Chart
PKGNAMEPREFIX= p5-
-DISTNAME= Chart-${PORTVERSION}
MAINTAINER= dan@trinsec.com
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/GD.pm:${PORTSDIR}/graphics/p5-GD
-WRKSRC= ${WRKDIR}/Chart-0.99b
-
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= Chart.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Graph3d/Makefile b/graphics/p5-GD-Graph3d/Makefile
index a8391fbc9682..955d497bec8f 100644
--- a/graphics/p5-GD-Graph3d/Makefile
+++ b/graphics/p5-GD-Graph3d/Makefile
@@ -5,23 +5,24 @@
# $FreeBSD$
#
-PORTNAME= p5-GD-Graph3d
+PORTNAME= GD-Graph3d
PORTVERSION= 0.40
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= GD
DISTNAME= GDGraph3d-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= dima@Chg.RU
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= GD::Graph::Graph3d.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>
diff --git a/graphics/p5-GD/Makefile b/graphics/p5-GD/Makefile
index c6c8e13bb974..f60efa1aafa7 100644
--- a/graphics/p5-GD/Makefile
+++ b/graphics/p5-GD/Makefile
@@ -16,12 +16,13 @@ MAINTAINER= jfitz@FreeBSD.org
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= GD.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/graphics/p5-GD1/Makefile b/graphics/p5-GD1/Makefile
index c6c8e13bb974..f60efa1aafa7 100644
--- a/graphics/p5-GD1/Makefile
+++ b/graphics/p5-GD1/Makefile
@@ -16,12 +16,13 @@ MAINTAINER= jfitz@FreeBSD.org
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= GD.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/graphics/p5-GD2/Makefile b/graphics/p5-GD2/Makefile
index c6c8e13bb974..f60efa1aafa7 100644
--- a/graphics/p5-GD2/Makefile
+++ b/graphics/p5-GD2/Makefile
@@ -16,12 +16,13 @@ MAINTAINER= jfitz@FreeBSD.org
LIB_DEPENDS= gd.1:${PORTSDIR}/graphics/gd
-USE_PERL5= YES
+USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= GD.3
do-configure:
- @cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>
diff --git a/graphics/p5-chart/Makefile b/graphics/p5-chart/Makefile
index 48252f3556bb..2b97b6b9636c 100644
--- a/graphics/p5-chart/Makefile
+++ b/graphics/p5-chart/Makefile
@@ -5,26 +5,23 @@
# $FreeBSD$
#
-PORTNAME= chart
+PORTNAME= Chart
PORTVERSION= 0.99b
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Chart
PKGNAMEPREFIX= p5-
-DISTNAME= Chart-${PORTVERSION}
MAINTAINER= dan@trinsec.com
BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/i386-freebsd/GD.pm:${PORTSDIR}/graphics/p5-GD
-WRKSRC= ${WRKDIR}/Chart-0.99b
-
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= Chart.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
.include <bsd.port.mk>