aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xpaint/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/graphics/xpaint/Makefile b/graphics/xpaint/Makefile
index 0740896b515f..393f2f5b558c 100644
--- a/graphics/xpaint/Makefile
+++ b/graphics/xpaint/Makefile
@@ -30,7 +30,8 @@ GNU_CONFIGURE= yes
USES= shebangfix
SHEBANG_FILES= share/bin/imgmerge share/bin/xpaint_ocr
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2
+CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/freetype2 \
+ -I${LOCALBASE}/include/freetype2/freetype
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV+= RM="${RM} -f"
@@ -39,6 +40,7 @@ post-extract:
post-patch:
@${REINPLACE_CMD} -e 's/-ldl //' \
+ -e 's|freetype/||g' \
${WRKSRC}/configure ${WRKSRC}/rw/configure
@${REINPLACE_CMD} -e '/^LIBTOOL/d' \
-e '/^install-exec-am:/s/install-libLTLIBRARIES//' \