aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/ruby-gdk_imlib/Makefile4
-rw-r--r--graphics/ruby-gdk_pixbuf/Makefile3
-rw-r--r--graphics/ruby-gdk_pixbuf/files/patch-extconf.rb6
-rw-r--r--graphics/ruby-gdk_pixbuf2/Makefile3
-rw-r--r--graphics/ruby-gdk_pixbuf2/files/patch-extconf.rb6
5 files changed, 13 insertions, 9 deletions
diff --git a/graphics/ruby-gdk_imlib/Makefile b/graphics/ruby-gdk_imlib/Makefile
index e0410da65d3f..5b47ad1dbff9 100644
--- a/graphics/ruby-gdk_imlib/Makefile
+++ b/graphics/ruby-gdk_imlib/Makefile
@@ -7,15 +7,17 @@
PORTNAME= gdk_imlib
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
-PORTREVISION= 1
CATEGORIES= graphics ruby
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${RUBY_GNOME_DISTNAME}
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
+RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/gtk.so:${PORTSDIR}/x11-toolkits/ruby-gtk
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_XLIB= yes
diff --git a/graphics/ruby-gdk_pixbuf/Makefile b/graphics/ruby-gdk_pixbuf/Makefile
index 756fdd18d9b5..188743998897 100644
--- a/graphics/ruby-gdk_pixbuf/Makefile
+++ b/graphics/ruby-gdk_pixbuf/Makefile
@@ -7,9 +7,9 @@
PORTNAME= gdk_pixbuf
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
-PORTREVISION= 2
CATEGORIES= graphics ruby gnome
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${RUBY_GNOME_DISTNAME}
DIST_SUBDIR= ruby
@@ -27,6 +27,7 @@ USE_GLIB= yes
.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
+CONFIGURE_ARGS= --with-glib-config=${GLIB_CONFIG}
INSTALL_TARGET= site-install
DOCS_EN= ChangeLog README
diff --git a/graphics/ruby-gdk_pixbuf/files/patch-extconf.rb b/graphics/ruby-gdk_pixbuf/files/patch-extconf.rb
index 287f57d436e6..e2e658733ba7 100644
--- a/graphics/ruby-gdk_pixbuf/files/patch-extconf.rb
+++ b/graphics/ruby-gdk_pixbuf/files/patch-extconf.rb
@@ -1,5 +1,5 @@
---- extconf.rb.orig Fri Mar 31 06:21:47 2000
-+++ extconf.rb Wed Feb 28 21:18:34 2001
+--- extconf.rb.orig Sat Oct 6 07:46:27 2001
++++ extconf.rb Wed Nov 21 01:17:41 2001
@@ -1,26 +1,25 @@
require 'mkmf'
@@ -14,7 +14,7 @@
+
+rubygtk_dir = ARGV.shift || "../gtk"
unless FileTest.exist?(rubygtk_dir)
- raise "directry #{rubygtk_dir} not found. Please specify Ruby/Gtk source dir."
+ raise "Directory #{rubygtk_dir} not found. Please specify Ruby/Gtk source dir."
end
-gtklib_dir = []
-`gtk-config --libs`.split(' ').each do |e|
diff --git a/graphics/ruby-gdk_pixbuf2/Makefile b/graphics/ruby-gdk_pixbuf2/Makefile
index 756fdd18d9b5..188743998897 100644
--- a/graphics/ruby-gdk_pixbuf2/Makefile
+++ b/graphics/ruby-gdk_pixbuf2/Makefile
@@ -7,9 +7,9 @@
PORTNAME= gdk_pixbuf
PORTVERSION= ${RUBY_GNOME_PORTVERSION}
-PORTREVISION= 2
CATEGORIES= graphics ruby gnome
MASTER_SITES= ${RUBY_GNOME_MASTER_SITES}
+MASTER_SITE_SUBDIR= ${RUBY_GNOME_MASTER_SITE_SUBDIR}
PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
DISTNAME= ${RUBY_GNOME_DISTNAME}
DIST_SUBDIR= ruby
@@ -27,6 +27,7 @@ USE_GLIB= yes
.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
WRKSRC= ${RUBY_GNOME_WRKSRC}/${PORTNAME}
+CONFIGURE_ARGS= --with-glib-config=${GLIB_CONFIG}
INSTALL_TARGET= site-install
DOCS_EN= ChangeLog README
diff --git a/graphics/ruby-gdk_pixbuf2/files/patch-extconf.rb b/graphics/ruby-gdk_pixbuf2/files/patch-extconf.rb
index 287f57d436e6..e2e658733ba7 100644
--- a/graphics/ruby-gdk_pixbuf2/files/patch-extconf.rb
+++ b/graphics/ruby-gdk_pixbuf2/files/patch-extconf.rb
@@ -1,5 +1,5 @@
---- extconf.rb.orig Fri Mar 31 06:21:47 2000
-+++ extconf.rb Wed Feb 28 21:18:34 2001
+--- extconf.rb.orig Sat Oct 6 07:46:27 2001
++++ extconf.rb Wed Nov 21 01:17:41 2001
@@ -1,26 +1,25 @@
require 'mkmf'
@@ -14,7 +14,7 @@
+
+rubygtk_dir = ARGV.shift || "../gtk"
unless FileTest.exist?(rubygtk_dir)
- raise "directry #{rubygtk_dir} not found. Please specify Ruby/Gtk source dir."
+ raise "Directory #{rubygtk_dir} not found. Please specify Ruby/Gtk source dir."
end
-gtklib_dir = []
-`gtk-config --libs`.split(' ').each do |e|