aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/lensfun/Makefile43
-rw-r--r--graphics/lensfun/distinfo3
-rw-r--r--graphics/lensfun/pkg-descr4
-rw-r--r--graphics/lensfun/pkg-plist38
5 files changed, 89 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index cd4ae3755d9c..a8271fe770b5 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -388,6 +388,7 @@
SUBDIR += lcdtest
SUBDIR += lcms
SUBDIR += leafpak
+ SUBDIR += lensfun
SUBDIR += lfview
SUBDIR += lib3ds
SUBDIR += libGL
diff --git a/graphics/lensfun/Makefile b/graphics/lensfun/Makefile
new file mode 100644
index 000000000000..6ccd46489e3f
--- /dev/null
+++ b/graphics/lensfun/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: lensfun
+# Date created: Mon 25 May 2009 04:45:47 MSD
+# Whom: dindin@dindin.ru
+#
+# $FreeBSD$
+#
+
+PORTNAME= lensfun
+PORTVERSION= 0.2.3
+CATEGORIES= graphics
+MASTER_SITES= BERLIOS
+
+MAINTAINER= dindin@dindin.ru
+COMMENT= Library for fixing lens geometry distortion
+
+LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
+
+USE_GMAKE= yes
+USE_PYTHON= yes
+USE_BZIP2= yes
+USE_GNOME= glib20
+MAKEFILE= GNUmakefile
+
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CXXFLAGS+= -I${LOCALBASE}/include
+
+HAS_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="${LDFLAGS}" CPPFLAGS="${CPPFLAGS}"
+CONFIGURE_ARGS= --prefix=${PREFIX} --target=${TARGET}
+
+post-patch:
+ @${REINPLACE_CMD} -e '1s|#!/usr/bin/python|#!/usr/bin/env python|' \
+ -e 's|make --version|gmake --version|' \
+ -e '/add_config_mak.*DOXYGEN/ d' \
+ ${WRKSRC}/configure
+ @${REINPLACE_CMD} \
+ -e 's|cp -d|/bin/cp |' ${WRKSRC}/build/mak/host/posix.mak
+ @${REINPLACE_CMD} -e 's|lib64|lib|' ${WRKSRC}/ac.py
+ @${REINPLACE_CMD} \
+ -e 's|$$(CONF_LIBDIR)pkgconfig/|$$(CONF_PREFIX)libdata/pkgconfig/|g'\
+ ${WRKSRC}/build/mak/compiler/pkgconfig.mak
+
+.include <bsd.port.mk>
diff --git a/graphics/lensfun/distinfo b/graphics/lensfun/distinfo
new file mode 100644
index 000000000000..aa69b3edbb6b
--- /dev/null
+++ b/graphics/lensfun/distinfo
@@ -0,0 +1,3 @@
+MD5 (lensfun-0.2.3.tar.bz2) = c5c04be4f53e3eef450ff4948d8f65b3
+SHA256 (lensfun-0.2.3.tar.bz2) = 836ab5869c0e81a54100c389e7274ead183d8dd5ee1992669bad92f57c43484f
+SIZE (lensfun-0.2.3.tar.bz2) = 151189
diff --git a/graphics/lensfun/pkg-descr b/graphics/lensfun/pkg-descr
new file mode 100644
index 000000000000..71980f459fd1
--- /dev/null
+++ b/graphics/lensfun/pkg-descr
@@ -0,0 +1,4 @@
+lensfun is library for rectifying the defects introduced
+by your photographic equipment.
+
+WWW: http://lensfun.berlios.de/
diff --git a/graphics/lensfun/pkg-plist b/graphics/lensfun/pkg-plist
new file mode 100644
index 000000000000..fd5de4bd9efd
--- /dev/null
+++ b/graphics/lensfun/pkg-plist
@@ -0,0 +1,38 @@
+lib/liblensfun.so
+lib/liblensfun.so.0
+lib/liblensfun.so.0.2.3
+include/lensfun.h
+libdata/pkgconfig/lensfun.pc
+%%DATADIR%%/6x6.xml
+%%DATADIR%%/compact-canon.xml
+%%DATADIR%%/compact-casio.xml
+%%DATADIR%%/compact-fujifilm.xml
+%%DATADIR%%/compact-konica-minolta.xml
+%%DATADIR%%/compact-leica.xml
+%%DATADIR%%/compact-nikon.xml
+%%DATADIR%%/compact-olympus.xml
+%%DATADIR%%/compact-panasonic.xml
+%%DATADIR%%/compact-pentax.xml
+%%DATADIR%%/compact-ricoh.xml
+%%DATADIR%%/compact-sony.xml
+%%DATADIR%%/generic.xml
+%%DATADIR%%/rf-leica.xml
+%%DATADIR%%/slr-canon.xml
+%%DATADIR%%/slr-contax.xml
+%%DATADIR%%/slr-konica-minolta.xml
+%%DATADIR%%/slr-nikon.xml
+%%DATADIR%%/slr-olympus.xml
+%%DATADIR%%/slr-pentax.xml
+%%DATADIR%%/slr-samsung.xml
+%%DATADIR%%/slr-schneider.xml
+%%DATADIR%%/slr-sigma.xml
+%%DATADIR%%/slr-sony.xml
+%%DATADIR%%/slr-tamron.xml
+%%DATADIR%%/slr-tokina.xml
+%%DATADIR%%/slr-ussr.xml
+share/doc/lensfun-0.2.3/README
+share/doc/lensfun-0.2.3/lgpl-3.0.txt
+share/doc/lensfun-0.2.3/gpl-3.0.txt
+share/doc/lensfun-0.2.3/cc-by-sa-3.0.txt
+@dirrm share/doc/lensfun-0.2.3
+@dirrm %%DATADIR%%