aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/krita/Makefile5
-rw-r--r--graphics/okular/Makefile3
-rw-r--r--graphics/photoqt/Makefile4
-rw-r--r--graphics/qt5-3d/Makefile3
-rw-r--r--graphics/qt5-graphicaleffects/Makefile3
-rw-r--r--graphics/qt5-wayland/Makefile4
-rw-r--r--graphics/radiance/Makefile3
-rw-r--r--graphics/spectacle/Makefile3
8 files changed, 17 insertions, 11 deletions
diff --git a/graphics/krita/Makefile b/graphics/krita/Makefile
index c6be11df3727..db3a119a2a87 100644
--- a/graphics/krita/Makefile
+++ b/graphics/krita/Makefile
@@ -2,6 +2,7 @@
PORTNAME= krita
DISTVERSION= 4.1.5
+PORTREVISION= 1
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${DISTVERSION}
DIST_SUBDIR= KDE/${PORTNAME}
@@ -35,8 +36,8 @@ USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
shared-mime-info
USE_KDE= archive completion config coreaddons crash guiaddons i18n \
itemmodels itemviews kio service widgetsaddons windowsystem
-USE_QT= concurrent core dbus gui multimedia network printsupport \
- qml quick svg testlib widgets x11extras xml \
+USE_QT= concurrent core dbus declarative gui multimedia network printsupport \
+ svg testlib widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= ice sm xcb xext xi
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index f2e409694d30..d3577d650788 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -2,6 +2,7 @@
PORTNAME= okular
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -30,7 +31,7 @@ USE_KDE= activities archive auth bookmarks codecs completion config \
kdelibs4support khtml kio libkexiv2 parts pty \
service solid sonnet textwidgets threadweaver wallet \
widgetsaddons windowsystem xmlgui
-USE_QT= core dbus gui network phonon4 printsupport qml quick speech \
+USE_QT= core dbus declarative gui network phonon4 printsupport speech \
svg widgets xml \
buildtools_build qmake_build
diff --git a/graphics/photoqt/Makefile b/graphics/photoqt/Makefile
index da47a5896338..232813071585 100644
--- a/graphics/photoqt/Makefile
+++ b/graphics/photoqt/Makefile
@@ -3,7 +3,7 @@
PORTNAME= photoqt
DISTVERSIONPREFIX= v
DISTVERSION= 1.6
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MAINTAINER= melanhit@gmail.com
@@ -13,7 +13,7 @@ LICENSE= GPLv2
USES= cmake:outsource compiler:c++11-lib desktop-file-utils \
localbase:ldflags qt:5
-USE_QT= core graphicaleffects gui multimedia network qml quick \
+USE_QT= core declarative graphicaleffects gui multimedia network \
quickcontrols sql svg widgets xml \
buildtools_build linguisttools_build qmake_build
diff --git a/graphics/qt5-3d/Makefile b/graphics/qt5-3d/Makefile
index 9e470dd47ba7..68c3c5df150e 100644
--- a/graphics/qt5-3d/Makefile
+++ b/graphics/qt5-3d/Makefile
@@ -2,6 +2,7 @@
PORTNAME= 3d
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= qt5-
@@ -11,7 +12,7 @@ COMMENT= Qt3D module
LIB_DEPENDS= libassimp.so:multimedia/assimp
USES= compiler:c++11-lang pkgconfig qmake:norecursive qt-dist:5,3d
-USE_QT= concurrent core gui network qml quick buildtools_build
+USE_QT= concurrent core declarative gui network buildtools_build
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/graphics/qt5-graphicaleffects/Makefile b/graphics/qt5-graphicaleffects/Makefile
index ba3f358a4308..20fb2f83aa13 100644
--- a/graphics/qt5-graphicaleffects/Makefile
+++ b/graphics/qt5-graphicaleffects/Makefile
@@ -2,6 +2,7 @@
PORTNAME= graphicaleffects
DISTVERSION= ${QT5_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics
PKGNAMEPREFIX= qt5-
@@ -11,6 +12,6 @@ COMMENT= Qt Quick graphical effects
BROKEN_armv6= fails to install: pkg-static: Unable to access file DropShadowBase.qmlc: No such file or directory
USES= compiler:c++11-lang qmake qt-dist:5,graphicaleffects
-USE_QT= buildtools_build core gui quick qml
+USE_QT= buildtools_build core declarative gui
.include <bsd.port.mk>
diff --git a/graphics/qt5-wayland/Makefile b/graphics/qt5-wayland/Makefile
index cae43c277b33..1c7627db206d 100644
--- a/graphics/qt5-wayland/Makefile
+++ b/graphics/qt5-wayland/Makefile
@@ -2,7 +2,7 @@
PORTNAME= wayland
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
PKGNAMEPREFIX= qt5-
@@ -17,7 +17,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
USES= pkgconfig qmake:norecursive qt-dist:5,wayland
USE_GL= egl gl
USE_GNOME= glib20
-USE_QT= core dbus gui qml quick \
+USE_QT= core dbus gui declarative \
buildtools_build qmake_build
USE_XORG= x11 xcomposite
diff --git a/graphics/radiance/Makefile b/graphics/radiance/Makefile
index c786a31952e9..49bb2590f8da 100644
--- a/graphics/radiance/Makefile
+++ b/graphics/radiance/Makefile
@@ -22,7 +22,8 @@ USE_GITHUB= yes
GH_ACCOUNT= zbanks
GH_TAGNAME= 2b947cf
GH_TUPLE= zbanks:BTrack:1c5b72e:bt/BTrack
-USE_QT= core graphicaleffects gui network qml quick quickcontrols widgets buildtools_build qmake_build
+USE_QT= core declarative graphicaleffects gui network quickcontrols widgets \
+ buildtools_build qmake_build
USE_GL= gl glu
CMAKE_ARGS= -DRADIANCE_SYSTEM_RESOURCES:STRING=${DATADIR}/
diff --git a/graphics/spectacle/Makefile b/graphics/spectacle/Makefile
index b589b880b1cc..68b6f96cf6a1 100644
--- a/graphics/spectacle/Makefile
+++ b/graphics/spectacle/Makefile
@@ -2,6 +2,7 @@
PORTNAME= spectacle
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= graphics kde kde-applications
MAINTAINER= kde@FreeBSD.org
@@ -16,7 +17,7 @@ USE_KDE= attica auth codecs completion config configwidgets coreaddons \
dbusaddons doctools ecm i18n jobwidgets kdeclarative kio \
libkipi newstuff notifications package service widgetsaddons \
windowsystem xmlgui
-USE_QT= core concurrent dbus gui network printsupport qml quick \
+USE_QT= core concurrent dbus declarative gui network printsupport \
quickcontrols widgets x11extras xml \
buildtools_build qmake_build
USE_XORG= x11 xcb xext xfixes