aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gpaint/Makefile7
-rw-r--r--graphics/gpaint/files/patch-configure75
2 files changed, 80 insertions, 2 deletions
diff --git a/graphics/gpaint/Makefile b/graphics/gpaint/Makefile
index 6c17d450315f..6178962f3b30 100644
--- a/graphics/gpaint/Makefile
+++ b/graphics/gpaint/Makefile
@@ -4,15 +4,18 @@
PORTNAME= gpaint
PORTVERSION= 0.3.3
DISTVERSIONPREFIX= 2-
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= graphics gnome
MASTER_SITES= GNU_ALPHA
MAINTAINER= ports@FreeBSD.org
COMMENT= Small-scale painting program for GNOME
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
USES= gnome libtool pkgconfig
-USE_GNOME= libgnomeprint libgnomeprintui
+USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
LIBS+= -lm
diff --git a/graphics/gpaint/files/patch-configure b/graphics/gpaint/files/patch-configure
new file mode 100644
index 000000000000..90e8765f9781
--- /dev/null
+++ b/graphics/gpaint/files/patch-configure
@@ -0,0 +1,75 @@
+--- configure.orig 2007-09-10 09:52:55 UTC
++++ configure
+@@ -19584,72 +19584,6 @@ pkg_failed=no
+ echo "$as_me:$LINENO: checking for PRINT" >&5
+ echo $ECHO_N "checking for PRINT... $ECHO_C" >&6
+
+-if test -n "$PKG_CONFIG"; then
+- if test -n "$PRINT_CFLAGS"; then
+- pkg_cv_PRINT_CFLAGS="$PRINT_CFLAGS"
+- else
+- if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libgnomeprint-2.2 libgnomeprintui-2.2\"") >&5
+- ($PKG_CONFIG --exists --print-errors "libgnomeprint-2.2 libgnomeprintui-2.2") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- pkg_cv_PRINT_CFLAGS=`$PKG_CONFIG --cflags "libgnomeprint-2.2 libgnomeprintui-2.2" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- fi
+-else
+- pkg_failed=untried
+-fi
+-if test -n "$PKG_CONFIG"; then
+- if test -n "$PRINT_LIBS"; then
+- pkg_cv_PRINT_LIBS="$PRINT_LIBS"
+- else
+- if test -n "$PKG_CONFIG" && \
+- { (echo "$as_me:$LINENO: \$PKG_CONFIG --exists --print-errors \"libgnomeprint-2.2 libgnomeprintui-2.2\"") >&5
+- ($PKG_CONFIG --exists --print-errors "libgnomeprint-2.2 libgnomeprintui-2.2") 2>&5
+- ac_status=$?
+- echo "$as_me:$LINENO: \$? = $ac_status" >&5
+- (exit $ac_status); }; then
+- pkg_cv_PRINT_LIBS=`$PKG_CONFIG --libs "libgnomeprint-2.2 libgnomeprintui-2.2" 2>/dev/null`
+-else
+- pkg_failed=yes
+-fi
+- fi
+-else
+- pkg_failed=untried
+-fi
+-
+-
+-
+-if test $pkg_failed = yes; then
+-
+-if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
+- _pkg_short_errors_supported=yes
+-else
+- _pkg_short_errors_supported=no
+-fi
+- if test $_pkg_short_errors_supported = yes; then
+- PRINT_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "libgnomeprint-2.2 libgnomeprintui-2.2"`
+- else
+- PRINT_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "libgnomeprint-2.2 libgnomeprintui-2.2"`
+- fi
+- # Put the nasty error message in config.log where it belongs
+- echo "$PRINT_PKG_ERRORS" >&5
+-
+- echo "gnomeprint libraries are not available."
+-elif test $pkg_failed = untried; then
+- echo "gnomeprint libraries are not available."
+-else
+- PRINT_CFLAGS=$pkg_cv_PRINT_CFLAGS
+- PRINT_LIBS=$pkg_cv_PRINT_LIBS
+- echo "$as_me:$LINENO: result: yes" >&5
+-echo "${ECHO_T}yes" >&6
+- gpaint_have_gnome_print=1
+-fi
+-
+-
+ pkg_failed=no
+ echo "$as_me:$LINENO: checking for GTKPRINT" >&5
+ echo $ECHO_N "checking for GTKPRINT... $ECHO_C" >&6