aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/f-spot/Makefile21
-rw-r--r--graphics/f-spot/distinfo6
-rw-r--r--graphics/f-spot/files/patch-icon-theme-installer26
-rw-r--r--graphics/f-spot/files/patch-icons_Makefile.in14
-rw-r--r--graphics/f-spot/files/patch-src-MainWindow.cs15
-rw-r--r--graphics/f-spot/files/patch-src_f-spot.in14
-rw-r--r--graphics/f-spot/pkg-plist241
7 files changed, 283 insertions, 54 deletions
diff --git a/graphics/f-spot/Makefile b/graphics/f-spot/Makefile
index d3ac289ae810..70887d8eb72b 100644
--- a/graphics/f-spot/Makefile
+++ b/graphics/f-spot/Makefile
@@ -7,30 +7,32 @@
#
PORTNAME= f-spot
-PORTVERSION= 0.4.0
-PORTREVISION= 2
+PORTVERSION= 0.5.0.3
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= graphics gnome
-MASTER_SITES= GNOME
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
-MAINTAINER= bsd-sharp@googlegroups.com
+MAINTAINER= mono@FreeBSD.org
COMMENT= Personal photo management to the GNOME desktop
LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
exif.12:${PORTSDIR}/graphics/libexif \
gphoto2.2:${PORTSDIR}/graphics/libgphoto2
-RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus
-
-BROKEN= does not compile
+BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
+RUN_DEPENDS= dbus-daemon:${PORTSDIR}/devel/dbus \
+ ${LOCALBASE}/libdata/pkgconfig/ndesk-dbus-glib-1.0.pc:${PORTSDIR}/devel/ndesk-dbus-glib
USE_BZIP2= yes
USE_SQLITE= yes
-USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gnomesharp20
+USE_GNOME= gnomehack gnomeprefix gnometarget intlhack gnomedesktopsharp20
GNU_CONFIGURE= yes
USE_GETTEXT= yes
USE_GMAKE= yes
INSTALLS_ICONS= yes
INSTALLS_OMF= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -41,7 +43,8 @@ post-patch:
${WRKSRC}/src/f-spot.exe.config.in
@${REINPLACE_CMD} 's|target="libgphoto2.so.2"|target="libgphoto2.so"|g'\
${WRKSRC}/libgphoto2-sharp/libgphoto2-sharp.dll.config
- @${REINPLACE_CMD} 's|#!/bin/bash|#!/bin/sh|g' \
+ @${REINPLACE_CMD} 's|#!/bin/bash|#!/usr/bin/env bash|g' \
+ ${WRKSRC}/src/f-spot.in \
${WRKSRC}/tools/f-spot-import
@${REINPLACE_CMD} 's|G_GNUC_FUNCTION|G_STRLOC|g' \
${WRKSRC}/libfspot/f-jpeg-utils.c
diff --git a/graphics/f-spot/distinfo b/graphics/f-spot/distinfo
index bbb2636d4e52..23ca18a8c97c 100644
--- a/graphics/f-spot/distinfo
+++ b/graphics/f-spot/distinfo
@@ -1,3 +1,3 @@
-MD5 (f-spot-0.4.0.tar.bz2) = 0f21ff56d310329185cc17a2fadda5fe
-SHA256 (f-spot-0.4.0.tar.bz2) = c0288df6c83b63698a47ad70ec596d424f1bf40e567c294a677e01f82df5348e
-SIZE (f-spot-0.4.0.tar.bz2) = 2178174
+MD5 (f-spot-0.5.0.3.tar.bz2) = 52db86f1dc715a3958425aa3d006c900
+SHA256 (f-spot-0.5.0.3.tar.bz2) = 7f0f9229e0b832c2ce5c75fb49247f7227141b49a5bcfb2020d0a01e6972e0bd
+SIZE (f-spot-0.5.0.3.tar.bz2) = 2776582
diff --git a/graphics/f-spot/files/patch-icon-theme-installer b/graphics/f-spot/files/patch-icon-theme-installer
new file mode 100644
index 000000000000..ff3ded394217
--- /dev/null
+++ b/graphics/f-spot/files/patch-icon-theme-installer
@@ -0,0 +1,26 @@
+
+$FreeBSD$
+
+--- icon-theme-installer.orig
++++ icon-theme-installer
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/usr/bin/env bash
+
+ # icon-theme-installer
+ # Copyright (C) 2006 Novell, Inc.
+@@ -101,12 +101,12 @@
+ exit 1
+ fi
+
+-if test ! -x $(echo "$MKINSTALLDIRS_EXEC" | cut -f1 -d' '); then
++if ! which $(echo "$MKINSTALLDIRS_EXEC" | cut -f1 -d' '); then
+ echo "Cannot find '$MKINSTALLDIRS_EXEC'; You probably want to pass -m \$(mkinstalldirs)"
+ exit 1
+ fi
+
+-if test ! -x $(echo "$INSTALL_DATA_EXEC" | cut -f1 -d' '); then
++if ! which $(echo "$INSTALL_DATA_EXEC" | cut -f1 -d' '); then
+ echo "Cannot find '$INSTALL_DATA_EXEC'; You probably want to pass -x \$(INSTALL_DATA)"
+ exit 1
+ fi
diff --git a/graphics/f-spot/files/patch-icons_Makefile.in b/graphics/f-spot/files/patch-icons_Makefile.in
new file mode 100644
index 000000000000..11eca93d8d7e
--- /dev/null
+++ b/graphics/f-spot/files/patch-icons_Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- icons/Makefile.in.orig
++++ icons/Makefile.in
+@@ -38,7 +38,7 @@
+ $(top_srcdir)/configure.in
+ am__configure_deps = $(am__aclocal_m4_deps) $(CONFIGURE_DEPENDENCIES) \
+ $(ACLOCAL_M4)
+-mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
++mkinstalldirs = $(install_sh) -d
+ CONFIG_HEADER = $(top_builddir)/config.h
+ CONFIG_CLEAN_FILES =
+ SOURCES =
diff --git a/graphics/f-spot/files/patch-src-MainWindow.cs b/graphics/f-spot/files/patch-src-MainWindow.cs
new file mode 100644
index 000000000000..941036ecb76a
--- /dev/null
+++ b/graphics/f-spot/files/patch-src-MainWindow.cs
@@ -0,0 +1,15 @@
+--- src/MainWindow.cs.orig 2008-10-18 07:54:25.000000000 -0300
++++ src/MainWindow.cs 2008-11-17 18:05:48.000000000 -0300
+@@ -2700,8 +2700,10 @@
+
+ case Preferences.MAIN_WINDOW_WIDTH:
+ case Preferences.MAIN_WINDOW_HEIGHT:
+- main_window.Resize(Preferences.Get<int> (Preferences.MAIN_WINDOW_WIDTH),
+- Preferences.Get<int> (Preferences.MAIN_WINDOW_HEIGHT));
++ if (Preferences.Get<int> (Preferences.MAIN_WINDOW_WIDTH) > 0 &&
++ Preferences.Get<int> (Preferences.MAIN_WINDOW_HEIGHT) > 0)
++ main_window.Resize(Preferences.Get<int> (Preferences.MAIN_WINDOW_WIDTH),
++ Preferences.Get<int> (Preferences.MAIN_WINDOW_HEIGHT));
+
+ break;
+
diff --git a/graphics/f-spot/files/patch-src_f-spot.in b/graphics/f-spot/files/patch-src_f-spot.in
deleted file mode 100644
index e2345df6bb21..000000000000
--- a/graphics/f-spot/files/patch-src_f-spot.in
+++ /dev/null
@@ -1,14 +0,0 @@
---- src/f-spot.in.orig Mon Jan 15 04:53:32 2007
-+++ src/f-spot.in Thu Jan 18 13:27:50 2007
-@@ -1,4 +1,4 @@
--#!/bin/bash
-+#!/bin/sh
-
- prefix=@prefix@
- exec_prefix=@exec_prefix@
-@@ -44,4 +43,4 @@
- echo "** Running Mono with $MONO_OPTIONS **"
- fi
-
--exec -a @PACKAGE@ mono $MONO_OPTIONS $EXE_TO_RUN "$@"
-+exec mono $MONO_OPTIONS $EXE_TO_RUN "$@"
diff --git a/graphics/f-spot/pkg-plist b/graphics/f-spot/pkg-plist
index 67aaa01634e8..8b106794ecdd 100644
--- a/graphics/f-spot/pkg-plist
+++ b/graphics/f-spot/pkg-plist
@@ -1,15 +1,21 @@
bin/f-spot
bin/f-spot-import
bin/f-spot-sqlite-upgrade
+lib/f-spot/Cms.dll
+lib/f-spot/Cms.dll.config
+lib/f-spot/FSpot.Core.dll
+lib/f-spot/FSpot.JobScheduler.dll
+lib/f-spot/FSpot.Query.dll
+lib/f-spot/FSpot.Utils.dll
+lib/f-spot/FSpot.Utils.dll.config
+lib/f-spot/FSpot.Widgets.dll
lib/f-spot/FlickrNet.dll
-lib/f-spot/Mono.Google.dll
+lib/f-spot/Mono.Addins.Gui.dll
+lib/f-spot/Mono.Addins.Setup.dll
lib/f-spot/Mono.Addins.dll
lib/f-spot/Mono.Addins.dll.config
-lib/f-spot/Mono.Addins.Setup.dll
-lib/f-spot/Mono.Addins.Gui.dll
-lib/f-spot/NDesk.DBus.GLib.dll
-lib/f-spot/NDesk.DBus.GLib.dll.config
-lib/f-spot/NDesk.DBus.dll
+lib/f-spot/Mono.Google.dll
+lib/f-spot/Mono.Tabblo.dll
lib/f-spot/NDesk.Glitz.dll
lib/f-spot/SemWeb.dll
lib/f-spot/SmugMugNet.dll
@@ -19,9 +25,28 @@ lib/f-spot/Tao.OpenGl.Glu.dll
lib/f-spot/Tao.OpenGl.Glu.dll.config
lib/f-spot/Tao.OpenGl.dll
lib/f-spot/Tao.OpenGl.dll.config
+lib/f-spot/extensions/BeagleService.dll
+lib/f-spot/extensions/CDExport.dll
+lib/f-spot/extensions/ChangePhotoPath.dll
+lib/f-spot/extensions/DBusService.dll
+lib/f-spot/extensions/DefaultExporters.addin.xml
+lib/f-spot/extensions/DevelopInUFRaw.dll
+lib/f-spot/extensions/FacebookExport.dll
+lib/f-spot/extensions/FlickrExport.dll
+lib/f-spot/extensions/FolderExport.dll
+lib/f-spot/extensions/GalleryExport.dll
+lib/f-spot/extensions/HashJob.dll
+lib/f-spot/extensions/MergeDb.dll
+lib/f-spot/extensions/PicasaWebExport.dll
+lib/f-spot/extensions/RawPlusJpeg.dll
+lib/f-spot/extensions/SmugMugExport.dll
+lib/f-spot/extensions/TabbloExport.dll
+lib/f-spot/extensions/ZipExport.dll
lib/f-spot/f-spot.exe
lib/f-spot/f-spot.exe.config
lib/f-spot/f-spot.global.addins
+lib/f-spot/gio-sharp.dll
+lib/f-spot/gio-sharp.dll.config
lib/f-spot/gnome-keyring-sharp.dll
lib/f-spot/libfspot.a
lib/f-spot/libfspot.la
@@ -37,12 +62,110 @@ lib/f-spot/libfspotjpegtran.so
lib/f-spot/libfspotjpegtran.so.0
lib/f-spot/libgphoto2-sharp.dll
lib/f-spot/libgphoto2-sharp.dll.config
-lib/f-spot/extensions/DefaultExporters.addin.xml
+lib/gio-sharp-unstable/gio-sharp.dll
+lib/gio-sharp-unstable/gio-sharp.dll.config
libdata/pkgconfig/f-spot.pc
+libdata/pkgconfig/gio-sharp-unstable.pc
libexec/gnome-screensaver/f-spot-screensaver
-share/gnome-screensaver/themes/f-spot-screensaver.desktop
+share/applications/f-spot-import.desktop
share/applications/f-spot-view.desktop
share/applications/f-spot.desktop
+share/applications/screensavers/f-spot-screensaver.desktop
+%%DATADIR%%/icons/hicolor/16x16/actions/adjust-colors.png
+%%DATADIR%%/icons/hicolor/16x16/actions/align-horizon.png
+%%DATADIR%%/icons/hicolor/16x16/actions/autocolor.png
+%%DATADIR%%/icons/hicolor/16x16/actions/color-desaturate.png
+%%DATADIR%%/icons/hicolor/16x16/actions/color-sepia.png
+%%DATADIR%%/icons/hicolor/16x16/actions/crop.png
+%%DATADIR%%/icons/hicolor/16x16/actions/filter-soft-focus.png
+%%DATADIR%%/icons/hicolor/16x16/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/16x16/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/16x16/actions/rating-blank.png
+%%DATADIR%%/icons/hicolor/16x16/actions/rating-rated-gray.png
+%%DATADIR%%/icons/hicolor/16x16/actions/rating-rated.png
+%%DATADIR%%/icons/hicolor/16x16/actions/red-eye-remove.png
+%%DATADIR%%/icons/hicolor/16x16/actions/tag-new.png
+%%DATADIR%%/icons/hicolor/16x16/actions/tag.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-far.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-fullscreen.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-near.png
+%%DATADIR%%/icons/hicolor/16x16/actions/view-restore.png
+%%DATADIR%%/icons/hicolor/16x16/apps/f-spot.png
+%%DATADIR%%/icons/hicolor/16x16/devices/camera-photo.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-event.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-people.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-places.png
+%%DATADIR%%/icons/hicolor/16x16/emblems/emblem-readonly.png
+%%DATADIR%%/icons/hicolor/16x16/places/film-roll.png
+%%DATADIR%%/icons/hicolor/16x16/status/mode-browse.png
+%%DATADIR%%/icons/hicolor/16x16/status/mode-image-edit.png
+%%DATADIR%%/icons/hicolor/22x22/actions/adjust-colors.png
+%%DATADIR%%/icons/hicolor/22x22/actions/align-horizon.png
+%%DATADIR%%/icons/hicolor/22x22/actions/autocolor.png
+%%DATADIR%%/icons/hicolor/22x22/actions/color-desaturate.png
+%%DATADIR%%/icons/hicolor/22x22/actions/color-sepia.png
+%%DATADIR%%/icons/hicolor/22x22/actions/crop.png
+%%DATADIR%%/icons/hicolor/22x22/actions/filter-soft-focus.png
+%%DATADIR%%/icons/hicolor/22x22/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/22x22/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/22x22/actions/red-eye-remove.png
+%%DATADIR%%/icons/hicolor/22x22/actions/tag-new.png
+%%DATADIR%%/icons/hicolor/22x22/actions/tag.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-far.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-fullscreen.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-near.png
+%%DATADIR%%/icons/hicolor/22x22/actions/view-restore.png
+%%DATADIR%%/icons/hicolor/22x22/apps/f-spot.png
+%%DATADIR%%/icons/hicolor/22x22/devices/camera-photo.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/emblem-event.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/emblem-people.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/emblem-places.png
+%%DATADIR%%/icons/hicolor/22x22/emblems/emblem-readonly.png
+%%DATADIR%%/icons/hicolor/22x22/places/film-roll.png
+%%DATADIR%%/icons/hicolor/22x22/status/mode-browse.png
+%%DATADIR%%/icons/hicolor/22x22/status/mode-image-edit.png
+%%DATADIR%%/icons/hicolor/24x24/actions/adjust-colors.png
+%%DATADIR%%/icons/hicolor/24x24/actions/align-horizon.png
+%%DATADIR%%/icons/hicolor/24x24/actions/autocolor.png
+%%DATADIR%%/icons/hicolor/24x24/actions/color-desaturate.png
+%%DATADIR%%/icons/hicolor/24x24/actions/filter-soft-focus.png
+%%DATADIR%%/icons/hicolor/24x24/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/24x24/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/24x24/actions/red-eye-remove.png
+%%DATADIR%%/icons/hicolor/24x24/actions/tag-new.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-far.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-fullscreen.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-near.png
+%%DATADIR%%/icons/hicolor/24x24/actions/view-restore.png
+%%DATADIR%%/icons/hicolor/24x24/apps/f-spot.png
+%%DATADIR%%/icons/hicolor/24x24/devices/camera-photo.png
+%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-event.png
+%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-people.png
+%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-places.png
+%%DATADIR%%/icons/hicolor/24x24/emblems/emblem-readonly.png
+%%DATADIR%%/icons/hicolor/24x24/places/film-roll.png
+%%DATADIR%%/icons/hicolor/24x24/status/mode-browse.png
+%%DATADIR%%/icons/hicolor/24x24/status/mode-image-edit.png
+%%DATADIR%%/icons/hicolor/32x32/actions/object-rotate-left.png
+%%DATADIR%%/icons/hicolor/32x32/actions/object-rotate-right.png
+%%DATADIR%%/icons/hicolor/32x32/actions/view-fullscreen.png
+%%DATADIR%%/icons/hicolor/32x32/actions/view-restore.png
+%%DATADIR%%/icons/hicolor/32x32/apps/f-spot.png
+%%DATADIR%%/icons/hicolor/32x32/devices/camera-photo.png
+%%DATADIR%%/icons/hicolor/32x32/emblems/emblem-event.png
+%%DATADIR%%/icons/hicolor/32x32/emblems/emblem-people.png
+%%DATADIR%%/icons/hicolor/32x32/emblems/emblem-places.png
+%%DATADIR%%/icons/hicolor/32x32/emblems/emblem-readonly.png
+%%DATADIR%%/icons/hicolor/32x32/status/mode-browse.png
+%%DATADIR%%/icons/hicolor/icon-theme.cache
+%%DATADIR%%/icons/hicolor/scalable/actions/object-rotate-left.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/object-rotate-right.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/view-fullscreen.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/view-restore.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/f-spot.svg
+%%DATADIR%%/icons/hicolor/scalable/emblems/emblem-event.svg
+%%DATADIR%%/icons/hicolor/scalable/emblems/emblem-places.svg
+%%DATADIR%%/icons/hicolor/scalable/status/mode-browse.svg
share/gnome/help/f-spot/C/f-spot.xml
share/gnome/help/f-spot/C/figures/f-spot-adjust-colors.png
share/gnome/help/f-spot/C/figures/f-spot-autocolor.png
@@ -98,6 +221,17 @@ share/gnome/help/f-spot/it/figures/f-spot-sepia.png
share/gnome/help/f-spot/it/figures/f-spot-slideshow.png
share/gnome/help/f-spot/it/figures/f-spot-soft-focus.png
share/gnome/help/f-spot/it/figures/f-spot-straighten.png
+share/gnome/help/f-spot/oc/f-spot.xml
+share/gnome/help/f-spot/oc/figures/f-spot-adjust-colors.png
+share/gnome/help/f-spot/oc/figures/f-spot-autocolor.png
+share/gnome/help/f-spot/oc/figures/f-spot-crop.png
+share/gnome/help/f-spot/oc/figures/f-spot-desaturate.png
+share/gnome/help/f-spot/oc/figures/f-spot-fullscreen.png
+share/gnome/help/f-spot/oc/figures/f-spot-red-eye.png
+share/gnome/help/f-spot/oc/figures/f-spot-sepia.png
+share/gnome/help/f-spot/oc/figures/f-spot-slideshow.png
+share/gnome/help/f-spot/oc/figures/f-spot-soft-focus.png
+share/gnome/help/f-spot/oc/figures/f-spot-straighten.png
share/gnome/help/f-spot/pt_BR/f-spot.xml
share/gnome/help/f-spot/pt_BR/figures/f-spot-adjust-colors.png
share/gnome/help/f-spot/pt_BR/figures/f-spot-autocolor.png
@@ -109,6 +243,17 @@ share/gnome/help/f-spot/pt_BR/figures/f-spot-sepia.png
share/gnome/help/f-spot/pt_BR/figures/f-spot-slideshow.png
share/gnome/help/f-spot/pt_BR/figures/f-spot-soft-focus.png
share/gnome/help/f-spot/pt_BR/figures/f-spot-straighten.png
+share/gnome/help/f-spot/ru/f-spot.xml
+share/gnome/help/f-spot/ru/figures/f-spot-adjust-colors.png
+share/gnome/help/f-spot/ru/figures/f-spot-autocolor.png
+share/gnome/help/f-spot/ru/figures/f-spot-crop.png
+share/gnome/help/f-spot/ru/figures/f-spot-desaturate.png
+share/gnome/help/f-spot/ru/figures/f-spot-fullscreen.png
+share/gnome/help/f-spot/ru/figures/f-spot-red-eye.png
+share/gnome/help/f-spot/ru/figures/f-spot-sepia.png
+share/gnome/help/f-spot/ru/figures/f-spot-slideshow.png
+share/gnome/help/f-spot/ru/figures/f-spot-soft-focus.png
+share/gnome/help/f-spot/ru/figures/f-spot-straighten.png
share/gnome/help/f-spot/sv/f-spot.xml
share/gnome/help/f-spot/sv/figures/f-spot-adjust-colors.png
share/gnome/help/f-spot/sv/figures/f-spot-autocolor.png
@@ -120,23 +265,13 @@ share/gnome/help/f-spot/sv/figures/f-spot-sepia.png
share/gnome/help/f-spot/sv/figures/f-spot-slideshow.png
share/gnome/help/f-spot/sv/figures/f-spot-soft-focus.png
share/gnome/help/f-spot/sv/figures/f-spot-straighten.png
-share/omf/f-spot/f-spot-C.omf
-share/omf/f-spot/f-spot-da.omf
-share/omf/f-spot/f-spot-es.omf
-share/omf/f-spot/f-spot-fr.omf
-share/omf/f-spot/f-spot-it.omf
-share/omf/f-spot/f-spot-pt_BR.omf
-share/omf/f-spot/f-spot-sv.omf
share/icons/hicolor/16x16/apps/f-spot.png
-share/icons/hicolor/16x16/apps/f-spot.svg
share/icons/hicolor/22x22/apps/f-spot.png
-share/icons/hicolor/22x22/apps/f-spot.svg
share/icons/hicolor/24x24/apps/f-spot.png
share/icons/hicolor/32x32/apps/f-spot.png
-share/icons/hicolor/32x32/apps/f-spot.svg
-share/icons/hicolor/48x48/apps/f-spot.png
-share/icons/hicolor/48x48/apps/f-spot.svg
+share/icons/hicolor/scalable/apps/f-spot.svg
share/locale/ar/LC_MESSAGES/f-spot.mo
+share/locale/be@latin/LC_MESSAGES/f-spot.mo
share/locale/bg/LC_MESSAGES/f-spot.mo
share/locale/ca/LC_MESSAGES/f-spot.mo
share/locale/cs/LC_MESSAGES/f-spot.mo
@@ -153,37 +288,53 @@ share/locale/fa/LC_MESSAGES/f-spot.mo
share/locale/fi/LC_MESSAGES/f-spot.mo
share/locale/fr/LC_MESSAGES/f-spot.mo
share/locale/gl/LC_MESSAGES/f-spot.mo
+share/locale/he/LC_MESSAGES/f-spot.mo
share/locale/hi/LC_MESSAGES/f-spot.mo
share/locale/hu/LC_MESSAGES/f-spot.mo
share/locale/it/LC_MESSAGES/f-spot.mo
share/locale/ja/LC_MESSAGES/f-spot.mo
+share/locale/ka/LC_MESSAGES/f-spot.mo
+share/locale/ko/LC_MESSAGES/f-spot.mo
share/locale/lt/LC_MESSAGES/f-spot.mo
share/locale/lv/LC_MESSAGES/f-spot.mo
share/locale/mk/LC_MESSAGES/f-spot.mo
share/locale/nb/LC_MESSAGES/f-spot.mo
share/locale/nl/LC_MESSAGES/f-spot.mo
+share/locale/oc/LC_MESSAGES/f-spot.mo
share/locale/pa/LC_MESSAGES/f-spot.mo
share/locale/pl/LC_MESSAGES/f-spot.mo
share/locale/pt/LC_MESSAGES/f-spot.mo
share/locale/pt_BR/LC_MESSAGES/f-spot.mo
share/locale/ru/LC_MESSAGES/f-spot.mo
share/locale/rw/LC_MESSAGES/f-spot.mo
+share/locale/sk/LC_MESSAGES/f-spot.mo
share/locale/sr/LC_MESSAGES/f-spot.mo
-share/locale/sr@Latn/LC_MESSAGES/f-spot.mo
+share/locale/sr@latin/LC_MESSAGES/f-spot.mo
share/locale/sv/LC_MESSAGES/f-spot.mo
share/locale/th/LC_MESSAGES/f-spot.mo
+share/locale/uk/LC_MESSAGES/f-spot.mo
share/locale/vi/LC_MESSAGES/f-spot.mo
share/locale/zh_CN/LC_MESSAGES/f-spot.mo
+share/locale/zh_HK/LC_MESSAGES/f-spot.mo
share/locale/zh_TW/LC_MESSAGES/f-spot.mo
-@dirrmtry share/locale/rw/LC_MESSAGES
-@dirrmtry share/locale/rw
-@dirrmtry share/locale/dz/LC_MESSAGES
-@dirrmtry share/locale/dz
+share/omf/f-spot/f-spot-C.omf
+share/omf/f-spot/f-spot-da.omf
+share/omf/f-spot/f-spot-es.omf
+share/omf/f-spot/f-spot-fr.omf
+share/omf/f-spot/f-spot-it.omf
+share/omf/f-spot/f-spot-oc.omf
+share/omf/f-spot/f-spot-pt_BR.omf
+share/omf/f-spot/f-spot-ru.omf
+share/omf/f-spot/f-spot-sv.omf
@dirrm share/omf/f-spot
@dirrm share/gnome/help/f-spot/sv/figures
@dirrm share/gnome/help/f-spot/sv
+@dirrm share/gnome/help/f-spot/ru/figures
+@dirrm share/gnome/help/f-spot/ru
@dirrm share/gnome/help/f-spot/pt_BR/figures
@dirrm share/gnome/help/f-spot/pt_BR
+@dirrm share/gnome/help/f-spot/oc/figures
+@dirrm share/gnome/help/f-spot/oc
@dirrm share/gnome/help/f-spot/it/figures
@dirrm share/gnome/help/f-spot/it
@dirrm share/gnome/help/f-spot/fr/figures
@@ -195,9 +346,43 @@ share/locale/zh_TW/LC_MESSAGES/f-spot.mo
@dirrm share/gnome/help/f-spot/C/figures
@dirrm share/gnome/help/f-spot/C
@dirrm share/gnome/help/f-spot
-@dirrmtry share/gnome-screensaver/themes
-@dirrmtry share/gnome-screensaver
+@dirrm %%DATADIR%%/icons/hicolor/scalable/status
+@dirrm %%DATADIR%%/icons/hicolor/scalable/emblems
+@dirrm %%DATADIR%%/icons/hicolor/scalable/apps
+@dirrm %%DATADIR%%/icons/hicolor/scalable/actions
+@dirrm %%DATADIR%%/icons/hicolor/scalable
+@dirrm %%DATADIR%%/icons/hicolor/32x32/status
+@dirrm %%DATADIR%%/icons/hicolor/32x32/emblems
+@dirrm %%DATADIR%%/icons/hicolor/32x32/devices
+@dirrm %%DATADIR%%/icons/hicolor/32x32/apps
+@dirrm %%DATADIR%%/icons/hicolor/32x32/actions
+@dirrm %%DATADIR%%/icons/hicolor/32x32
+@dirrm %%DATADIR%%/icons/hicolor/24x24/status
+@dirrm %%DATADIR%%/icons/hicolor/24x24/places
+@dirrm %%DATADIR%%/icons/hicolor/24x24/emblems
+@dirrm %%DATADIR%%/icons/hicolor/24x24/devices
+@dirrm %%DATADIR%%/icons/hicolor/24x24/apps
+@dirrm %%DATADIR%%/icons/hicolor/24x24/actions
+@dirrm %%DATADIR%%/icons/hicolor/24x24
+@dirrm %%DATADIR%%/icons/hicolor/22x22/status
+@dirrm %%DATADIR%%/icons/hicolor/22x22/places
+@dirrm %%DATADIR%%/icons/hicolor/22x22/emblems
+@dirrm %%DATADIR%%/icons/hicolor/22x22/devices
+@dirrm %%DATADIR%%/icons/hicolor/22x22/apps
+@dirrm %%DATADIR%%/icons/hicolor/22x22/actions
+@dirrm %%DATADIR%%/icons/hicolor/22x22
+@dirrm %%DATADIR%%/icons/hicolor/16x16/status
+@dirrm %%DATADIR%%/icons/hicolor/16x16/places
+@dirrm %%DATADIR%%/icons/hicolor/16x16/emblems
+@dirrm %%DATADIR%%/icons/hicolor/16x16/devices
+@dirrm %%DATADIR%%/icons/hicolor/16x16/apps
+@dirrm %%DATADIR%%/icons/hicolor/16x16/actions
+@dirrm %%DATADIR%%/icons/hicolor/16x16
+@dirrm %%DATADIR%%/icons/hicolor
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+@dirrmtry share/applications/screensavers
@dirrmtry libexec/gnome-screensaver
+@dirrm lib/gio-sharp-unstable
@dirrm lib/f-spot/extensions
@dirrm lib/f-spot
-@dirrmtry share/applications