aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/k3d/Makefile4
-rw-r--r--graphics/openjpeg/Makefile4
-rw-r--r--graphics/py-opengl/Makefile3
-rw-r--r--graphics/tifmerge/Makefile3
4 files changed, 7 insertions, 7 deletions
diff --git a/graphics/k3d/Makefile b/graphics/k3d/Makefile
index 16e3b26c404b..70b910b2cfa6 100644
--- a/graphics/k3d/Makefile
+++ b/graphics/k3d/Makefile
@@ -36,10 +36,10 @@ OPENEXR_DESC= OpenEXR file format module
USE_BZIP2= yes
USE_GL= glu
USE_GNOME= gtksourceview2
-USE_DOS2UNIX= *.hpp
+DOS2UNIX_GLOB= *.hpp
USE_GCC= yes
USE_PYTHON= yes
-USES= cmake:outsource gettext
+USES= cmake:outsource gettext dos2unix
CMAKE_ARGS= -DK3D_INTL_INCLUDE_DIRS:STRING="-I${LOCALBASE}/include" \
-DK3D_INTL_LIBS:STRING="-L${LOCALBASE}/lib -lintl" \
-DK3D_BUILD_CARVE_MODULE:BOOL=OFF \
diff --git a/graphics/openjpeg/Makefile b/graphics/openjpeg/Makefile
index 874efb54546b..c058acd18791 100644
--- a/graphics/openjpeg/Makefile
+++ b/graphics/openjpeg/Makefile
@@ -17,9 +17,9 @@ LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff \
libpng15.so:${PORTSDIR}/graphics/png \
liblcms2.so:${PORTSDIR}/graphics/lcms2
-USE_DOS2UNIX= opj_malloc.h
+DOS2UNIX_FILES= opj_malloc.h
GNU_CONFIGURE= yes
-USES= cmake
+USES= cmake dos2unix
USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/graphics/py-opengl/Makefile b/graphics/py-opengl/Makefile
index 5d2c7141a2c5..024ab34aac5f 100644
--- a/graphics/py-opengl/Makefile
+++ b/graphics/py-opengl/Makefile
@@ -22,14 +22,13 @@ OPTIONS_DEFAULT= TKINTER
TKINTER_DESC= Build with tkinter for X support
OPTIONSFILE?= ${PORT_DBDIR}/${PORTNAME}/options
+USES= dos2unix
USE_GL= glut
USE_PYTHON= yes
USE_PYDISTUTILS= yes
PYDISTUTILS_PKGNAME= PyOpenGL
PYDISTUTILS_PKGVERSION= ${PORTVERSION:S/.b/b/}
-USE_DOS2UNIX= yes
-
NO_STAGE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/tifmerge/Makefile b/graphics/tifmerge/Makefile
index a668514e21e8..a59489ea0709 100644
--- a/graphics/tifmerge/Makefile
+++ b/graphics/tifmerge/Makefile
@@ -11,7 +11,8 @@ DISTNAME= tiff
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to merge TIFF files into multi-page TIFF files
-USE_DOS2UNIX= *.[ch]
+USES= dos2unix
+DOS2UNIX_GLOB= *.[ch]
USE_LDCONFIG= yes
USE_ZIP= yes
NO_WRKSUBDIR= yes