aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/photivo/Makefile4
-rw-r--r--graphics/photivo/files/patch-Sources_filemgmt_ptFileMgrWindow.h12
2 files changed, 14 insertions, 2 deletions
diff --git a/graphics/photivo/Makefile b/graphics/photivo/Makefile
index 0f695a0fac1a..c53871d44230 100644
--- a/graphics/photivo/Makefile
+++ b/graphics/photivo/Makefile
@@ -23,9 +23,9 @@ LIB_DEPENDS= liblcms2.so:graphics/lcms2 \
libfftw3.so:math/fftw3
USES= cmake compiler:c++11-lib desktop-file-utils dos2unix \
- gettext-runtime jpeg pkgconfig zip
+ gettext-runtime gnome jpeg pkgconfig zip
USE_GNOME= glib20
-DOS2UNIX_FILES= Sources/ptImage.cpp Sources/ptCheck.cpp
+DOS2UNIX_FILES= Sources/ptImage.cpp Sources/ptCheck.cpp Sources/filemgmt/ptFileMgrWindow.h
WRKSRC= ${WRKDIR}/${PORTNAME}
diff --git a/graphics/photivo/files/patch-Sources_filemgmt_ptFileMgrWindow.h b/graphics/photivo/files/patch-Sources_filemgmt_ptFileMgrWindow.h
new file mode 100644
index 000000000000..ee9d2ffe05da
--- /dev/null
+++ b/graphics/photivo/files/patch-Sources_filemgmt_ptFileMgrWindow.h
@@ -0,0 +1,12 @@
+Fix build with Qt 5.11
+
+--- Sources/filemgmt/ptFileMgrWindow.h.orig 2018-09-03 10:22:41 UTC
++++ Sources/filemgmt/ptFileMgrWindow.h
+@@ -36,6 +36,7 @@
+ #include "../ptConstants.h"
+ #include "../ptReportOverlay.h"
+ #include "../ptConstants.h"
++#include <QActionGroup>
+ #include <QWidget>
+ #include <QGraphicsScene>
+ #include <memory>