aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/peps/Makefile22
-rw-r--r--graphics/xpeps/Makefile28
-rw-r--r--graphics/xpeps/distinfo2
-rw-r--r--graphics/xpeps/pkg-descr10
5 files changed, 50 insertions, 13 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index e4f6cab11dab..2a23aa8a047c 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -1051,6 +1051,7 @@
SUBDIR += xoris
SUBDIR += xournal
SUBDIR += xpaint
+ SUBDIR += xpeps
SUBDIR += xpdf
SUBDIR += xpx
SUBDIR += xsane
diff --git a/graphics/peps/Makefile b/graphics/peps/Makefile
index 381ccf527308..fc0790b17e67 100644
--- a/graphics/peps/Makefile
+++ b/graphics/peps/Makefile
@@ -3,41 +3,37 @@
PORTNAME= peps
PORTVERSION= 2.0
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics
MASTER_SITES= http://peps.redprince.net/peps/ \
ftp://ftp.peps.redprince.net/unix/peps/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= doceng@FreeBSD.org
COMMENT= Converts EPS images to anti-aliased bitmaps
+LICENSE= BSD2CLAUSE
+
USES= ghostscript:run
MAKE_ENV= GSPATH="${LOCALBASE}/bin/gs" GZPATH="/usr/bin/gzip" \
ETC="${PREFIX}/etc"
+ALL_TARGET= peps
PLIST_FILES= bin/peps \
etc/peps.mime \
man/man1/peps.1.gz
PORTDOCS= peps.pdf
-OPTIONS_DEFINE= DOCS X11
-OPTIONS_DEFAULT= X11
-
-X11_PLIST_FILES= bin/xpeps
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
.include <bsd.port.options.mk>
-.if ! ${PORT_OPTIONS:MX11}
-ALL_TARGET= peps
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/peps ${STAGEDIR}${PREFIX}/bin
-.if ${PORT_OPTIONS:MX11}
- ${INSTALL_PROGRAM} ${WRKSRC}/xpeps ${STAGEDIR}${PREFIX}/bin
-.endif
${INSTALL_MAN} ${WRKSRC}/peps.1 ${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_DATA} ${WRKSRC}/peps.mime ${STAGEDIR}${PREFIX}/etc
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/peps.pdf ${STAGEDIR}${DOCSDIR}
diff --git a/graphics/xpeps/Makefile b/graphics/xpeps/Makefile
new file mode 100644
index 000000000000..ad12adc9c298
--- /dev/null
+++ b/graphics/xpeps/Makefile
@@ -0,0 +1,28 @@
+# Created by: petef@FreeBSD.org
+# $FreeBSD$
+
+PORTNAME= peps
+PORTVERSION= 2.0
+CATEGORIES= graphics
+MASTER_SITES= http://peps.redprince.net/peps/ \
+ ftp://ftp.peps.redprince.net/unix/peps/
+PKGNAMEPREFIX= x
+
+MAINTAINER= doceng@FreeBSD.org
+COMMENT= Converts EPS images to anti-aliased bitmaps with X11 support
+
+LICENSE= BSD2CLAUSE
+
+RUN_DEPENDS= peps>=2.0_6:${PORTSDIR}/graphics/peps
+
+USES= ghostscript:x11,run
+MAKE_ENV= GSPATH="${LOCALBASE}/bin/gs" GZPATH="/usr/bin/gzip" \
+ ETC="${PREFIX}/etc"
+ALL_TARGET= xpeps
+
+PLIST_FILES= bin/xpeps
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xpeps ${STAGEDIR}${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/graphics/xpeps/distinfo b/graphics/xpeps/distinfo
new file mode 100644
index 000000000000..6bcfa2bf9d3c
--- /dev/null
+++ b/graphics/xpeps/distinfo
@@ -0,0 +1,2 @@
+SHA256 (peps-2.0.tar.gz) = b514fed9412548cdcf43a95b6dcf01b2038f314bc9ef363498ebd2779c897a91
+SIZE (peps-2.0.tar.gz) = 55421
diff --git a/graphics/xpeps/pkg-descr b/graphics/xpeps/pkg-descr
new file mode 100644
index 000000000000..0acc46a1b65c
--- /dev/null
+++ b/graphics/xpeps/pkg-descr
@@ -0,0 +1,10 @@
+Peps will preprocess encapsulated Postscript files for conversion by
+Ghostscript into bitmaps. It provides variable levels of resolution and
+anti-aliasing. You can use it as a stand-alone Postscript-to-bitmap
+conversion program, or use it on-line to create bitmaps on the fly and send
+them out to a web browser, even compressing them if the browser supports
+gzip compression.
+
+Xpeps is peps with X11 support.
+
+WWW: http://peps.redprince.net/peps/