aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/synaesthesia/Makefile14
1 files changed, 4 insertions, 10 deletions
diff --git a/graphics/synaesthesia/Makefile b/graphics/synaesthesia/Makefile
index 9f47e2e6d218..8e35d0e01adc 100644
--- a/graphics/synaesthesia/Makefile
+++ b/graphics/synaesthesia/Makefile
@@ -12,7 +12,7 @@ COMMENT= Real-time graphical music representation program
LICENSE= GPLv2
-USE_GMAKE= yes
+USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-sdl-prefix=${LOCALBASE}
USE_SDL= sdl
@@ -22,19 +22,13 @@ PLIST_FILES= bin/${PORTNAME}
OPTIONS_DEFINE= DOCS
-NO_STAGE= yes
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's,stdint\.h,inttypes.h,' ${WRKSRC}/*.c?
@${REINPLACE_CMD} -e 's,int16_t,u_int16_t,' ${WRKSRC}/sound.cc
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
-
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>