aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/evolvotron/Makefile17
-rw-r--r--graphics/evolvotron/distinfo6
-rw-r--r--graphics/evolvotron/files/patch-common.pro12
-rw-r--r--graphics/evolvotron/pkg-plist1
4 files changed, 20 insertions, 16 deletions
diff --git a/graphics/evolvotron/Makefile b/graphics/evolvotron/Makefile
index dc19f6ef1063..5a276bc6c0fb 100644
--- a/graphics/evolvotron/Makefile
+++ b/graphics/evolvotron/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= evolvotron
-PORTVERSION= 0.3.1
+PORTVERSION= 0.4.0
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -22,19 +22,22 @@ USE_PYTHON= yes
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-MAKE_ENV= QTDIR="${QT_PREFIX}" \
- QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
-CONFIGURE_ENV= QTDIR="${QT_PREFIX}" \
- QMAKESPEC=${LOCALBASE}/share/qt/mkspecs/freebsd-g++
+MAKE_ENV= QTDIR=${X11BASE} MOC=${MOC}
.include <bsd.port.pre.mk>
post-patch:
- @${REINPLACE_CMD} -e 's/-pthread/${PTHREAD_LIBS}/' ${WRKSRC}/common.pro
- @${REINPLACE_CMD} -e 's,bin/bash,bin/sh,' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS} -g -static|' \
+ ${WRKSRC}/common.pro
+
+do-configure:
+ cd ${WRKSRC} && ./text_to_markup.py -html < USAGE > evolvotron.html
+ cd ${WRKSRC} && ./text_to_markup.py -qml -s < USAGE > libevolvotron/usage_text.h
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} qmake -spec ${LOCALBASE}/share/qt/mkspecs/freebsd-g++ VERSION_NUMBER=${PORTVERSION} main.pro
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron/evolvotron ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_match/evolvotron_match ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_mutate/evolvotron_mutate ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/evolvotron_render/evolvotron_render ${PREFIX}/bin
.if !defined(NOPORTDOCS)
diff --git a/graphics/evolvotron/distinfo b/graphics/evolvotron/distinfo
index 06e809502cb8..fdc5118e15ff 100644
--- a/graphics/evolvotron/distinfo
+++ b/graphics/evolvotron/distinfo
@@ -1,3 +1,3 @@
-MD5 (evolvotron-0.3.1.tar.gz) = e6c8404d7c454283fb5d8f00ec0c2761
-SHA256 (evolvotron-0.3.1.tar.gz) = 2cd56c25335d2875a52cb638294e1597cabfcf955f6828fbd0b67199556cf636
-SIZE (evolvotron-0.3.1.tar.gz) = 129201
+MD5 (evolvotron-0.4.0.tar.gz) = ab6f3a3247e36ca0024d3837f78bdf6b
+SHA256 (evolvotron-0.4.0.tar.gz) = f846aa85fe443a61afd64d28d491b9afc0f3fbb491f3e27da2d601048d40d1ed
+SIZE (evolvotron-0.4.0.tar.gz) = 131967
diff --git a/graphics/evolvotron/files/patch-common.pro b/graphics/evolvotron/files/patch-common.pro
index a906227347f0..3ea0e2718fce 100644
--- a/graphics/evolvotron/files/patch-common.pro
+++ b/graphics/evolvotron/files/patch-common.pro
@@ -1,6 +1,6 @@
---- common.pro.orig Mon Nov 3 09:40:15 2003
-+++ common.pro Mon Dec 1 03:16:47 2003
-@@ -29,32 +29,12 @@
+--- common.pro.orig Wed Nov 9 13:50:09 2005
++++ common.pro Wed Nov 9 13:51:25 2005
+@@ -20,8 +20,6 @@
# Now leaving these ON for general distribution as they DO have SOME effect
# (or at least they have in the past... see the README), and should be portable.
# NB Switching on -funroll-loops causes some versions of gcc to segv
@@ -9,10 +9,10 @@
##################
# Architecture specific optimisations
- # The following architecture options make the compiled executables less portable.
- # (On a different setup you may need to change what's subtracted out of the flags.)
+@@ -29,23 +27,6 @@
+ # (On a different setup you may need to change what is subtracted out of the flags.)
# NB -march=X implies -mcpu=X... no need to specify both the same
--
+
-contains(CONFIG_OPTS, p4 ){
- QMAKE_CXXFLAGS_RELEASE -= -march=i386 -mcpu=i686
- QMAKE_CXXFLAGS_RELEASE += -march=pentium4 -mfpmath=sse -msse2
diff --git a/graphics/evolvotron/pkg-plist b/graphics/evolvotron/pkg-plist
index 9e3e1d3967c7..0bba7c7dc5d6 100644
--- a/graphics/evolvotron/pkg-plist
+++ b/graphics/evolvotron/pkg-plist
@@ -1,4 +1,5 @@
bin/evolvotron
+bin/evolvotron_match
bin/evolvotron_mutate
bin/evolvotron_render
%%PORTDOCS%%%%DOCSDIR%%/evolvotron.html