aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/albumshaper/Makefile8
-rw-r--r--graphics/exif/Makefile10
-rw-r--r--graphics/gimp-focusblur-plugin/Makefile10
-rw-r--r--graphics/gpicview/Makefile4
-rw-r--r--graphics/gqview/Makefile18
-rw-r--r--graphics/gscan2pdf/Makefile10
-rw-r--r--graphics/gtkdps/Makefile4
-rw-r--r--graphics/libgphoto2/Makefile12
-rw-r--r--graphics/pornview/Makefile10
9 files changed, 47 insertions, 39 deletions
diff --git a/graphics/albumshaper/Makefile b/graphics/albumshaper/Makefile
index 5ba8e11ea348..9ddfbdbe0718 100644
--- a/graphics/albumshaper/Makefile
+++ b/graphics/albumshaper/Makefile
@@ -35,7 +35,9 @@ DESKTOP_ENTRIES= "AlbumShaper" \
"Qt;Graphics;" \
"false"
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
PLIST_SUB+= NLS=""
.else
PLIST_SUB+= NLS="@comment "
@@ -47,7 +49,7 @@ MYDISTDOCS= AlbumShaper.doc install packageHowTo.txt readme.txt \
post-patch:
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g' \
${WRKSRC}/AlbumShaper.pro
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/INSTALLS\ +=\ translations/d' \
${WRKSRC}/AlbumShaper.pro
.endif
@@ -57,7 +59,7 @@ pre-build:
qmake AlbumShaper.pro )
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${MYDISTDOCS}
@${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
diff --git a/graphics/exif/Makefile b/graphics/exif/Makefile
index 6cc1ef7d6b88..388302127f00 100644
--- a/graphics/exif/Makefile
+++ b/graphics/exif/Makefile
@@ -19,12 +19,14 @@ GNU_CONFIGURE= yes
MAKE_JOBS_SAFE= yes
CONFIGURE_ENV+= POPT_CFLAGS=-I${LOCALBASE}/include POPT_LIBS="-L${LOCALBASE}/lib -lpopt"
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls --without-libiconv-prefix
-PLIST_SUB+= NLS="@comment "
-.else
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext iconv
PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls --without-libiconv-prefix
+PLIST_SUB+= NLS="@comment "
.endif
MAN1= exif.1
diff --git a/graphics/gimp-focusblur-plugin/Makefile b/graphics/gimp-focusblur-plugin/Makefile
index f8453c6dfce5..b4560bad603b 100644
--- a/graphics/gimp-focusblur-plugin/Makefile
+++ b/graphics/gimp-focusblur-plugin/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gimp-focusblur
-# Date created: 03 Jun 2009
-# Whom: Denis Barov <dindin@dindin.ru>
-#
+# Created by: Denis Barov <dindin@dindin.ru>
# $FreeBSD$
-#
PORTNAME= focusblur
PORTVERSION= 3.2.6
@@ -34,7 +30,9 @@ PLIST_SUB= PLUGIN_DIR=${PLUGIN_DIR}
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/graphics/gpicview/Makefile b/graphics/gpicview/Makefile
index 1907c285906c..c2a6f2ee0dd3 100644
--- a/graphics/gpicview/Makefile
+++ b/graphics/gpicview/Makefile
@@ -16,7 +16,9 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/graphics/gqview/Makefile b/graphics/gqview/Makefile
index 6082c88e02de..c4b81df81eb7 100644
--- a/graphics/gqview/Makefile
+++ b/graphics/gqview/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gqview
-# Date Created: 27 Oct 1998
-# Whom: Vanilla Pooh Shu <vanilla@FreeBSD.org>
-#
+# Created by: Vanilla Pooh Shu <vanilla@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gqview
PORTVERSION= 2.0.4
@@ -30,12 +26,14 @@ CONFLICTS= gqview-devel-[0-9]*
# Restrict to stable (even) versions, indicated by the second component.
PORTSCOUT= limitw:1,even
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+=--disable-nls
PLIST_SUB+= NLS="@comment "
-.else
-USES= gettext
-PLIST_SUB+= NLS=""
.endif
post-patch:
@@ -52,7 +50,7 @@ post-patch:
post-install:
${INSTALL_DATA} ${WRKSRC}/gqview.png ${PREFIX}/share/pixmaps
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
diff --git a/graphics/gscan2pdf/Makefile b/graphics/gscan2pdf/Makefile
index 5f688ddfe691..d768a216b317 100644
--- a/graphics/gscan2pdf/Makefile
+++ b/graphics/gscan2pdf/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: gscan2pdf
-# Date created: 4 September 2006
-# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
-#
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= gscan2pdf
PORTVERSION= 1.0.4
@@ -72,7 +68,9 @@ PERL_CONFIGURE= yes
MAN1= ${PORTNAME}.1 scanadf-perl.1 scanimage-perl.1
PORT_VERBS= ${PORTNAME} Gscan2pdf
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/graphics/gtkdps/Makefile b/graphics/gtkdps/Makefile
index e7c70b8e88f9..8b1f04fd99d2 100644
--- a/graphics/gtkdps/Makefile
+++ b/graphics/gtkdps/Makefile
@@ -24,7 +24,9 @@ CONFIGURE_ARGS= --with-dps-includes=${LOCALBASE}/include \
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
USES+= gettext
PLIST_SUB+= NLS=""
.else
diff --git a/graphics/libgphoto2/Makefile b/graphics/libgphoto2/Makefile
index f4f5d0fb01c0..5f2f2a30e3b9 100644
--- a/graphics/libgphoto2/Makefile
+++ b/graphics/libgphoto2/Makefile
@@ -25,13 +25,15 @@ MAKE_JOBS_SAFE= yes
MAN3= libgphoto2.3 libgphoto2_port.3
-.if defined(WITHOUT_NLS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MNLS}
+USES+= gettext
+PLIST_SUB+= NLS=""
+.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
USES+= iconv
-.else
-USES+= gettext
-PLIST_SUB+= NLS=""
.endif
CONFIGURE_ENV+= LIBUSB_LIBS="-lusb" LIBUSB_CFLAGS="-I/usr/include"
@@ -43,7 +45,7 @@ post-patch:
s|-g -O2||g ; \
/grep -i linux/s|; fi ; then|; else false; fi ; then|' ${WRKSRC}/${file}
.endfor
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e 's|(LDFLAGS) -o|(LDFLAGS) -lintl -o|' ${WRKSRC}/libgphoto2_port/libgphoto2_port/Makefile.in
.endif
@${REINPLACE_CMD} -e '/test.*udevscriptdir/d ; s| "$$(DESTDIR)$$(udevscriptdir)"||' ${WRKSRC}/libgphoto2_port/usb/Makefile.in ${WRKSRC}/packaging/generic/Makefile.in
diff --git a/graphics/pornview/Makefile b/graphics/pornview/Makefile
index 90ff5296fab5..e05d10be2fa1 100644
--- a/graphics/pornview/Makefile
+++ b/graphics/pornview/Makefile
@@ -22,14 +22,18 @@ CONFIGURE_ARGS= --with-gtk2
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if defined(WITH_LIBXINE)
+OPTIONS_DEFINE= LIBXINE MPLAYER NLS
+OPTIONS_DEFAULT= LIBXINE
+
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MLIBXINE}
LIB_DEPENDS+= xine.2:${PORTSDIR}/multimedia/libxine
CONFIGURE_ARGS+= --enable-xine
-.elif defined(WITH_MPLAYER)
+.elif ${PORT_OPTIONS:MMPLAYER}
RUN_DEPENDS+= mplayer:${PORTSDIR}/multimedia/mplayer
CONFIGURE_ARGS+= --enable-mplayer
.endif
-.if defined(WITHOUT_NLS)
+.if ! ${PORT_OPTIONS:MNLS}
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= WITH_NLS="@comment "
.else