aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/kbarcode/Makefile22
-rw-r--r--graphics/kbarcode/distinfo6
-rw-r--r--graphics/kbarcode/files/patch-kbarcode::labeleditor.cpp11
-rw-r--r--graphics/kbarcode/files/patch-kbarcode::tokenprovider.h11
-rw-r--r--graphics/kbarcode/files/patch-kbarcode::zplutils.cpp18
-rw-r--r--graphics/kbarcode/pkg-plist30
6 files changed, 35 insertions, 63 deletions
diff --git a/graphics/kbarcode/Makefile b/graphics/kbarcode/Makefile
index 537618fcdcc8..108ff60a2fd8 100644
--- a/graphics/kbarcode/Makefile
+++ b/graphics/kbarcode/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kbarcode
-PORTVERSION= 1.8.1
-PORTREVISION= 3
+PORTVERSION= 2.0.0
CATEGORIES= graphics kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,18 +14,17 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A barcode and label printing application for KDE
-RUN_DEPENDS= barcode:${PORTSDIR}/graphics/barcode
-
-USE_KDELIBS_VER=3
-USE_REINPLACE= yes
+USE_KDELIBS_VER= 3
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+.include <bsd.port.pre.mk>
+
post-patch:
- @${REINPLACE_CMD} -e 's,-O2,,g ; \
- s,-lpthread,${PTHREAD_LIBS},g' ${WRKSRC}/${CONFIGURE_SCRIPT}
- @${REINPLACE_CMD} -e \
- 's,$$(LIB_KDEUI)$$,$$(LIB_KDEUI) $$(LIBPTHREAD),g' \
- ${WRKSRC}/kbarcode/Makefile.in
+.if ${OSVERSION} < 500000
+ @${REINPLACE_CMD} -e 's/ or / || /g ; \
+ s/ and / \&\& /g ; \
+ s/return false/return 0/g' ${WRKSRC}/kbarcode/tec.cpp
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/kbarcode/distinfo b/graphics/kbarcode/distinfo
index e05e869a3112..4e464b2c8e4e 100644
--- a/graphics/kbarcode/distinfo
+++ b/graphics/kbarcode/distinfo
@@ -1,3 +1,3 @@
-MD5 (kbarcode-1.8.1.tar.gz) = 5868383df659a1cf4ba696916c1f12b8
-SHA256 (kbarcode-1.8.1.tar.gz) = 6cbeec0639bda9ce163b4cc5466f739163abfcda23a3af7a50eb2160a366a517
-SIZE (kbarcode-1.8.1.tar.gz) = 969743
+MD5 (kbarcode-2.0.0.tar.gz) = 381e75baf0fb551538c8edc8cc40e525
+SHA256 (kbarcode-2.0.0.tar.gz) = f96afc9e65ca00af1a23b31e26ab667dc3d584c18d3b9fb054d6bccbfd5b7cb7
+SIZE (kbarcode-2.0.0.tar.gz) = 1158671
diff --git a/graphics/kbarcode/files/patch-kbarcode::labeleditor.cpp b/graphics/kbarcode/files/patch-kbarcode::labeleditor.cpp
deleted file mode 100644
index a5ee8ceaffd8..000000000000
--- a/graphics/kbarcode/files/patch-kbarcode::labeleditor.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kbarcode/labeleditor.cpp.orig Tue Jul 20 05:57:28 2004
-+++ kbarcode/labeleditor.cpp Mon Aug 23 17:25:56 2004
-@@ -552,7 +552,7 @@
- exportZPLAct = new KAction( i18n("...as &IPL or ZPL"), 0, 0, this, SLOT(exportZPL() ), actionCollection() );
- descriptionAct = new KAction( i18n("&Change description..."), 0, 0, this, SLOT(changeDes()), actionCollection() );
- deleteAct = new KAction( i18n("&Delete Object"), QIconSet( BarIcon("editdelete") ), Key_Delete, cv, SLOT( deleteCurrent() ), actionCollection() );
-- editPropAct = new KAction( i18n("&Properties..."), 0, 0, this, SLOT(), actionCollection() );
-+ editPropAct = new KAction( i18n("&Properties..."), 0, 0, this, SLOT( doubleClickedCurrent() ), actionCollection() );
- printAct = KStdAction::print( this, SLOT( print() ), actionCollection(), "print" );
- changeSizeAct = new KAction( i18n("&Change Label..."), 0, 0, this, SLOT( changeSize() ), actionCollection() );
- barcodeAct = new KAction( i18n("Insert &Barcode"), QIconSet( BarIcon("barcode") ), 0, this, SLOT( insertBarcode() ), actionCollection() );
diff --git a/graphics/kbarcode/files/patch-kbarcode::tokenprovider.h b/graphics/kbarcode/files/patch-kbarcode::tokenprovider.h
deleted file mode 100644
index 181966ad9c59..000000000000
--- a/graphics/kbarcode/files/patch-kbarcode::tokenprovider.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- kbarcode/tokenprovider.h.orig Wed Jun 30 17:18:40 2004
-+++ kbarcode/tokenprovider.h Mon Aug 23 16:23:32 2004
-@@ -18,6 +18,8 @@
- #ifndef TOKENPROVIDER_H
- #define TOKENPROVIDER_H
-
-+#include <time.h>
-+
- #include <qstring.h>
- #include <qregexp.h>
-
diff --git a/graphics/kbarcode/files/patch-kbarcode::zplutils.cpp b/graphics/kbarcode/files/patch-kbarcode::zplutils.cpp
index 4a2d682cfd40..f64e88437dde 100644
--- a/graphics/kbarcode/files/patch-kbarcode::zplutils.cpp
+++ b/graphics/kbarcode/files/patch-kbarcode::zplutils.cpp
@@ -1,11 +1,11 @@
---- kbarcode/zplutils.cpp.orig Wed Nov 5 20:26:46 2003
-+++ kbarcode/zplutils.cpp Fri Dec 26 10:22:53 2003
-@@ -307,7 +307,7 @@
- setField( "<ESC>E3<CAN>" ); // choose format number 3
+--- kbarcode/zplutils.cpp.orig Mon Mar 21 00:31:21 2005
++++ kbarcode/zplutils.cpp Thu Mar 16 12:27:36 2006
+@@ -256,7 +256,7 @@
+ ipl += field( "<ESC>E3<CAN>" ); // choose format number 3
+
+ for( unsigned int i = 0; i < m_values.count(); i++ )
+- ipl += field( m_values[i] + ( i != m_values.count() - 1 ? "<CR>" : QString::null ) );
++ ipl += field( m_values[i] + ( i != m_values.count() - 1 ? QString("<CR>") : QString::null ) );
- for( unsigned int i = 0; i < values.count(); i++ )
-- setField( values[i] + ( i != values.count() - 1 ? "<CR>" : QString::null ) );
-+ setField( values[i] + ( i != values.count() - 1 ? QString("<CR>") : QString::null ) );
-
// end actual data
- setField( "<ETB>" );
+ ipl += field( "<ETB>" );
diff --git a/graphics/kbarcode/pkg-plist b/graphics/kbarcode/pkg-plist
index a582af14c9c7..d6981266feea 100644
--- a/graphics/kbarcode/pkg-plist
+++ b/graphics/kbarcode/pkg-plist
@@ -2,11 +2,12 @@ bin/kbarcode
lib/kde3/kfile_kbarcode.a
lib/kde3/kfile_kbarcode.la
lib/kde3/kfile_kbarcode.so
-share/applnk/Applications/KBarcode/kbarcode-batch.desktop
-share/applnk/Applications/KBarcode/kbarcode-editor.desktop
-share/applnk/Applications/KBarcode/kbarcode-label.desktop
-share/applnk/Applications/KBarcode/kbarcode-single.desktop
-share/applnk/Applications/KBarcode/kbarcode.desktop
+share/applications/kde/kbarcode-batch.desktop
+share/applications/kde/kbarcode-editor.desktop
+share/applications/kde/kbarcode-label.desktop
+share/applications/kde/kbarcode-single.desktop
+share/applications/kde/kbarcode.desktop
+share/apps/kbarcode/barcode.ps
share/apps/kbarcode/barcodes.html
share/apps/kbarcode/exampledata.sql
share/apps/kbarcode/labeldefinitions.sql
@@ -32,16 +33,11 @@ share/locale/nl/LC_MESSAGES/kbarcode.mo
share/locale/pl/LC_MESSAGES/kbarcode.mo
share/locale/sv/LC_MESSAGES/kbarcode.mo
share/services/kfile_kbarcode.desktop
-@dirrmtry share/icons/hicolor/64x64/apps
-@dirrmtry share/icons/hicolor/32x32/apps
-@dirrmtry share/icons/hicolor/32x32/actions
-@dirrmtry share/icons/hicolor/22x22/actions
-@dirrmtry share/icons/hicolor/16x16/apps
-@dirrmtry share/icons/hicolor/16x16/actions
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
+@dirrmtry share/locale/pl/LC_MESSAGES
+@dirrmtry share/locale/pl
+@dirrmtry share/locale/fi/LC_MESSAGES
+@dirrmtry share/locale/fi
+@dirrmtry share/locale/el/LC_MESSAGES
+@dirrmtry share/locale/el
@dirrm share/apps/kbarcode
-@dirrmtry share/apps
-@dirrm share/applnk/Applications/KBarcode
-@dirrmtry share/applnk/Applications
-@dirrmtry share/applnk
+@dirrmtry share/applications/kde