aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/p5-GD-Thumbnail/Makefile25
-rw-r--r--graphics/p5-GD-Thumbnail/distinfo3
-rw-r--r--graphics/p5-GD-Thumbnail/pkg-descr18
-rw-r--r--graphics/p5-GD-Thumbnail/pkg-plist4
5 files changed, 51 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8afd1f52af22..beb9ff69c95e 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -423,6 +423,7 @@
SUBDIR += p5-Chart-Graph
SUBDIR += p5-Chart-PNGgraph
SUBDIR += p5-Color-Rgb
+ SUBDIR += p5-GD-Thumbnail
SUBDIR += p5-Geo-Proj4
SUBDIR += p5-GD
SUBDIR += p5-GD-Arrow
diff --git a/graphics/p5-GD-Thumbnail/Makefile b/graphics/p5-GD-Thumbnail/Makefile
new file mode 100644
index 000000000000..f347ea329ff3
--- /dev/null
+++ b/graphics/p5-GD-Thumbnail/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: GD::Thumbnail
+# Date created: 2006/08/15
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= GD-Thumbnail
+PORTVERSION= 1.01
+CATEGORIES= graphics perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= GD
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Thumbnail maker for GD
+
+BUILD_DEPENDS= p5-GD>=0:${PORTSDIR}/graphics/p5-GD
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= YES
+
+MAN3= GD::Thumbnail.3
+
+.include <bsd.port.mk>
diff --git a/graphics/p5-GD-Thumbnail/distinfo b/graphics/p5-GD-Thumbnail/distinfo
new file mode 100644
index 000000000000..ead05abdc8b4
--- /dev/null
+++ b/graphics/p5-GD-Thumbnail/distinfo
@@ -0,0 +1,3 @@
+MD5 (GD-Thumbnail-1.01.tar.gz) = bd55c266329ee0e39a98ab24f405d320
+SHA256 (GD-Thumbnail-1.01.tar.gz) = 50b1ae2d0deb2cc774c0c98b70c4d01c4362328e795363bb1f0d2730d20b05f1
+SIZE (GD-Thumbnail-1.01.tar.gz) = 25980
diff --git a/graphics/p5-GD-Thumbnail/pkg-descr b/graphics/p5-GD-Thumbnail/pkg-descr
new file mode 100644
index 000000000000..74312a5a73c0
--- /dev/null
+++ b/graphics/p5-GD-Thumbnail/pkg-descr
@@ -0,0 +1,18 @@
+This a thumbnail maker. Thumbnails are smaller versions of the original
+image/graphic/picture and are used for preview purposes, where bigger images
+can take a long time to load. They are also used in image galleries to
+preview a lot of images at a time.
+
+This module also has the capability to add information strips about the
+original image. Original image's size (in bytes) and resolution & mime type
+can be added to the thumbnail's upper and lower parts. This feature can be
+useful for web software (image galleries or forums).
+
+This is a Yet Another type of module. There are several other thumbnail
+modules on CPAN, but they simply don't have the features I need, so this
+module is written to increase the thumbnail population on CPAN.
+
+The module can raise an exception if something goes wrong. So, you may have
+to use an eval block to catch them.
+
+WWW: http://search.cpan.org/dist/GD-Thumbnail/
diff --git a/graphics/p5-GD-Thumbnail/pkg-plist b/graphics/p5-GD-Thumbnail/pkg-plist
new file mode 100644
index 000000000000..61569eb1ba2b
--- /dev/null
+++ b/graphics/p5-GD-Thumbnail/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/GD/Thumbnail.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/Thumbnail/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/GD/Thumbnail
+@dirrmtry %%SITE_PERL%%/GD