aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/linux-ac3d/Makefile19
-rw-r--r--graphics/linux-bmrt/Makefile7
-rw-r--r--graphics/linux-f10-gdk-pixbuf/Makefile3
-rw-r--r--graphics/linux-f10-imlib/Makefile2
-rw-r--r--graphics/linux-f10-jpeg/Makefile2
-rw-r--r--graphics/linux-f10-libmng/Makefile7
-rw-r--r--graphics/linux-f10-png/Makefile2
-rw-r--r--graphics/linux-f10-png10/Makefile2
-rw-r--r--graphics/linux-f10-sdl_image/Makefile3
-rw-r--r--graphics/linux-f10-tiff/Makefile12
-rw-r--r--graphics/linux-f10-ungif/Makefile2
-rw-r--r--graphics/linux-f8-gdk-pixbuf/Makefile3
-rw-r--r--graphics/linux-f8-imlib/Makefile2
-rw-r--r--graphics/linux-f8-jpeg/Makefile2
-rw-r--r--graphics/linux-f8-libmng/Makefile7
-rw-r--r--graphics/linux-f8-png/Makefile2
-rw-r--r--graphics/linux-f8-png10/Makefile2
-rw-r--r--graphics/linux-f8-sdl_image/Makefile3
-rw-r--r--graphics/linux-f8-tiff/Makefile12
-rw-r--r--graphics/linux-f8-ungif/Makefile2
-rw-r--r--graphics/linux-gdk-pixbuf/Makefile3
-rw-r--r--graphics/linux-imlib/Makefile2
-rw-r--r--graphics/linux-jpeg/Makefile2
-rw-r--r--graphics/linux-libmng/Makefile7
-rw-r--r--graphics/linux-panorama-tools/Makefile7
-rw-r--r--graphics/linux-png/Makefile2
-rw-r--r--graphics/linux-png10/Makefile2
-rw-r--r--graphics/linux-sdl_image/Makefile3
-rw-r--r--graphics/linux-tiff/Makefile12
-rw-r--r--graphics/linux-ungif/Makefile2
-rw-r--r--graphics/linux_dri/Makefile10
-rw-r--r--graphics/linux_glide/Makefile2
-rw-r--r--graphics/linux_glx/Makefile12
-rw-r--r--graphics/linux_mesa3/Makefile5
34 files changed, 72 insertions, 95 deletions
diff --git a/graphics/linux-ac3d/Makefile b/graphics/linux-ac3d/Makefile
index c16e8e0bdae0..859d18490de8 100644
--- a/graphics/linux-ac3d/Makefile
+++ b/graphics/linux-ac3d/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ac3d
PORTVERSION= 5.0.21
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://inivis.swmirror.com/
PKGNAMEPREFIX= linux-
@@ -16,19 +17,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ip@doom.homeunix.org
COMMENT= Easy to use and powerful 3D graphics modeller (trial version)
-.ifdef(INSTALL_DYNLINKED_VERSION)
-LIB_DEPENDS= ${LINUXBASE}/usr/libGLU.so.1:${PORTSDIR}/graphics/linux_mesa3
-.endif
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs \
+RUN_DEPENDS= \
${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg \
${LINUXBASE}/usr/lib/libpng.so.2:${PORTSDIR}/graphics/linux-png10 \
${LINUXBASE}/usr/lib/libtiff.so.3:${PORTSDIR}/graphics/linux-tiff
+.ifdef(INSTALL_DYNLINKED_VERSION)
+RUN_DEPENDS+= ${LINUXBASE}/usr/libGLU.so.1:${PORTSDIR}/graphics/linux_mesa3
+.endif
RESTRICTED= "no distribution permitted"
NO_CDROM= ${RESTRICTED}
-NO_BUILD= yes
ONLY_FOR_ARCHS= i386
+USE_LINUX= yes
+USE_X_PREFIX= yes
WRKSRC= ${WRKDIR}/${PORTNAME}lx
SUB_FILES= pkg-message
@@ -44,10 +46,6 @@ PLIST_SUB= DYNAMIC_VERSION="" \
PROGRAM= ${PORTNAME}
.endif
-# Linux binary should not be stripped by INSTALL_PROGRAM
-# because as a side effect it brands the binary as FreeBSD.
-STRIP=
-
.ifndef(INSTALL_DYNLINKED_VERSION)
pre-everything::
@${ECHO_MSG} 'Define INSTALL_DYNLINKED_VERSION=yes to install'
@@ -57,6 +55,9 @@ pre-everything::
@${ECHO_MSG} ''
.endif
+do-build:
+ ${BRANDELF} -t Linux ${WRKSRC}/${PROGRAM}
+
pre-install:
# Generate startup script
@${ECHO_CMD} "#!${SH}" > ${WRKDIR}/${PORTNAME}.sh
diff --git a/graphics/linux-bmrt/Makefile b/graphics/linux-bmrt/Makefile
index 356fd54e6962..b280b2566d6d 100644
--- a/graphics/linux-bmrt/Makefile
+++ b/graphics/linux-bmrt/Makefile
@@ -21,10 +21,7 @@ WRKSRC= ${WRKDIR}/BMRT2.6
NO_BUILD= yes
ONLY_FOR_ARCHS= i386
NO_CDROM= "See the License"
-
-# Linux binary should not be stripped by INSTALL_PROGRAM as it uses
-# /usr/bin/strip which then brands the binary as a FreeBSD ELF one.
-STRIP=
+USE_LINUX= yes
.include <bsd.port.pre.mk>
@@ -69,7 +66,7 @@ do-install:
.endfor
.for i in ${PROGRAM}
${INSTALL_PROGRAM} ${WRKSRC}/bin/${i} ${PREFIX}/bin
- /usr/bin/brandelf -t Linux ${PREFIX}/bin/${i}
+ ${BRANDELF} -t Linux ${PREFIX}/bin/${i}
.endfor
post-install:
diff --git a/graphics/linux-f10-gdk-pixbuf/Makefile b/graphics/linux-f10-gdk-pixbuf/Makefile
index c6226f70dda3..8b63ab7ec547 100644
--- a/graphics/linux-f10-gdk-pixbuf/Makefile
+++ b/graphics/linux-f10-gdk-pixbuf/Makefile
@@ -24,11 +24,10 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
CONFLICTS= linux-gtk2*
USE_LINUX_PREFIX=yes
-USE_LINUX?= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS=yes
PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
# Set the version of Fedora Core
diff --git a/graphics/linux-f10-imlib/Makefile b/graphics/linux-f10-imlib/Makefile
index 771be258d8dd..a76aee9e8f06 100644
--- a/graphics/linux-f10-imlib/Makefile
+++ b/graphics/linux-f10-imlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib
PORTVERSION= 1.9.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/linux-f10-jpeg/Makefile b/graphics/linux-f10-jpeg/Makefile
index a17828596f65..b62d2c2225a6 100644
--- a/graphics/linux-f10-jpeg/Makefile
+++ b/graphics/linux-f10-jpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jpeg
PORTVERSION= 6b.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/graphics/linux-f10-libmng/Makefile b/graphics/linux-f10-libmng/Makefile
index 7dc5f3cab911..8429247003be 100644
--- a/graphics/linux-f10-libmng/Makefile
+++ b/graphics/linux-f10-libmng/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmng
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
@@ -22,13 +22,12 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
BASEVERSION= 8.0
-USE_LINUX_RPM= yes
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
-NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
+NO_BUILD= yes
PLIST?= ${PKGDIR}/pkg-plist.${MACHINE_ARCH}
MD5_FILE?= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
diff --git a/graphics/linux-f10-png/Makefile b/graphics/linux-f10-png/Makefile
index a552d996bb96..caf7025935e4 100644
--- a/graphics/linux-f10-png/Makefile
+++ b/graphics/linux-f10-png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
diff --git a/graphics/linux-f10-png10/Makefile b/graphics/linux-f10-png10/Makefile
index 0172b415cec4..5307a31714f5 100644
--- a/graphics/linux-f10-png10/Makefile
+++ b/graphics/linux-f10-png10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.0.16
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
diff --git a/graphics/linux-f10-sdl_image/Makefile b/graphics/linux-f10-sdl_image/Makefile
index 6d7f53e16e9f..6b60f37c8e41 100644
--- a/graphics/linux-f10-sdl_image/Makefile
+++ b/graphics/linux-f10-sdl_image/Makefile
@@ -8,6 +8,7 @@
PORTNAME= sdl_image
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
PKGNAMEPREFIX= linux-
@@ -21,13 +22,13 @@ COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/graphics/linux-f10-tiff/Makefile b/graphics/linux-f10-tiff/Makefile
index 613aa8b6b490..b1514ecacddd 100644
--- a/graphics/linux-f10-tiff/Makefile
+++ b/graphics/linux-f10-tiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tiff
PORTVERSION= 3.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_SUSE}
MASTER_SITE_SUBDIR= i386/update/9.2/rpm/i586
@@ -23,15 +23,14 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
DIST_SUBDIR= rpm/i386/suse/9.2
DOCDIRS= usr/share/doc/libtiff-3.6.1
-NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= amd64 i386
PLIST= ${WRKDIR}/plist
PLIST_DIRS= usr/share/doc/packages/libtiff usr/share/doc/packages
PLIST_FILES= usr/lib/libtiff.so.3 usr/lib/libtiff.so.3.6.1 \
usr/share/doc/packages/libtiff/COPYRIGHT \
usr/share/doc/packages/libtiff/README
-PREFIX= ${LINUXBASE}
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_LINUX_PREFIX=yes
# dummy target so rpm can be in BUILD_DEPENDS
do-build:
@@ -40,13 +39,10 @@ do-build:
do-install:
${MKDIR} ${WRKSRC}
@rpm -U --ignorearch --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
- --nodeps --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ --nodeps --replacepkgs --noscripts ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
|| ${TRUE}
post-install:
- @${RM} -f ${LINUXBASE}/etc/ld.so.cache
- @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
- > ${LINUXBASE}/etc/ld.so.conf
@chroot ${LINUXBASE} sbin/ldconfig
.include <bsd.port.mk>
diff --git a/graphics/linux-f10-ungif/Makefile b/graphics/linux-f10-ungif/Makefile
index 479616796878..5e6c874ea956 100644
--- a/graphics/linux-f10-ungif/Makefile
+++ b/graphics/linux-f10-ungif/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= ungif
PORTVERSION= 4.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
MAINTAINTER= maho@FreeBSD.org
diff --git a/graphics/linux-f8-gdk-pixbuf/Makefile b/graphics/linux-f8-gdk-pixbuf/Makefile
index c6226f70dda3..8b63ab7ec547 100644
--- a/graphics/linux-f8-gdk-pixbuf/Makefile
+++ b/graphics/linux-f8-gdk-pixbuf/Makefile
@@ -24,11 +24,10 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
CONFLICTS= linux-gtk2*
USE_LINUX_PREFIX=yes
-USE_LINUX?= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS=yes
PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
# Set the version of Fedora Core
diff --git a/graphics/linux-f8-imlib/Makefile b/graphics/linux-f8-imlib/Makefile
index 771be258d8dd..a76aee9e8f06 100644
--- a/graphics/linux-f8-imlib/Makefile
+++ b/graphics/linux-f8-imlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib
PORTVERSION= 1.9.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/linux-f8-jpeg/Makefile b/graphics/linux-f8-jpeg/Makefile
index a17828596f65..b62d2c2225a6 100644
--- a/graphics/linux-f8-jpeg/Makefile
+++ b/graphics/linux-f8-jpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jpeg
PORTVERSION= 6b.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/graphics/linux-f8-libmng/Makefile b/graphics/linux-f8-libmng/Makefile
index 7dc5f3cab911..8429247003be 100644
--- a/graphics/linux-f8-libmng/Makefile
+++ b/graphics/linux-f8-libmng/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmng
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
@@ -22,13 +22,12 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
BASEVERSION= 8.0
-USE_LINUX_RPM= yes
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
-NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
+NO_BUILD= yes
PLIST?= ${PKGDIR}/pkg-plist.${MACHINE_ARCH}
MD5_FILE?= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
diff --git a/graphics/linux-f8-png/Makefile b/graphics/linux-f8-png/Makefile
index a552d996bb96..caf7025935e4 100644
--- a/graphics/linux-f8-png/Makefile
+++ b/graphics/linux-f8-png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
diff --git a/graphics/linux-f8-png10/Makefile b/graphics/linux-f8-png10/Makefile
index 0172b415cec4..5307a31714f5 100644
--- a/graphics/linux-f8-png10/Makefile
+++ b/graphics/linux-f8-png10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.0.16
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
diff --git a/graphics/linux-f8-sdl_image/Makefile b/graphics/linux-f8-sdl_image/Makefile
index 6d7f53e16e9f..6b60f37c8e41 100644
--- a/graphics/linux-f8-sdl_image/Makefile
+++ b/graphics/linux-f8-sdl_image/Makefile
@@ -8,6 +8,7 @@
PORTNAME= sdl_image
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
PKGNAMEPREFIX= linux-
@@ -21,13 +22,13 @@ COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/graphics/linux-f8-tiff/Makefile b/graphics/linux-f8-tiff/Makefile
index 613aa8b6b490..b1514ecacddd 100644
--- a/graphics/linux-f8-tiff/Makefile
+++ b/graphics/linux-f8-tiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tiff
PORTVERSION= 3.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_SUSE}
MASTER_SITE_SUBDIR= i386/update/9.2/rpm/i586
@@ -23,15 +23,14 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
DIST_SUBDIR= rpm/i386/suse/9.2
DOCDIRS= usr/share/doc/libtiff-3.6.1
-NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= amd64 i386
PLIST= ${WRKDIR}/plist
PLIST_DIRS= usr/share/doc/packages/libtiff usr/share/doc/packages
PLIST_FILES= usr/lib/libtiff.so.3 usr/lib/libtiff.so.3.6.1 \
usr/share/doc/packages/libtiff/COPYRIGHT \
usr/share/doc/packages/libtiff/README
-PREFIX= ${LINUXBASE}
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_LINUX_PREFIX=yes
# dummy target so rpm can be in BUILD_DEPENDS
do-build:
@@ -40,13 +39,10 @@ do-build:
do-install:
${MKDIR} ${WRKSRC}
@rpm -U --ignorearch --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
- --nodeps --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ --nodeps --replacepkgs --noscripts ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
|| ${TRUE}
post-install:
- @${RM} -f ${LINUXBASE}/etc/ld.so.cache
- @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
- > ${LINUXBASE}/etc/ld.so.conf
@chroot ${LINUXBASE} sbin/ldconfig
.include <bsd.port.mk>
diff --git a/graphics/linux-f8-ungif/Makefile b/graphics/linux-f8-ungif/Makefile
index 479616796878..5e6c874ea956 100644
--- a/graphics/linux-f8-ungif/Makefile
+++ b/graphics/linux-f8-ungif/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= ungif
PORTVERSION= 4.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
MAINTAINTER= maho@FreeBSD.org
diff --git a/graphics/linux-gdk-pixbuf/Makefile b/graphics/linux-gdk-pixbuf/Makefile
index c6226f70dda3..8b63ab7ec547 100644
--- a/graphics/linux-gdk-pixbuf/Makefile
+++ b/graphics/linux-gdk-pixbuf/Makefile
@@ -24,11 +24,10 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
CONFLICTS= linux-gtk2*
USE_LINUX_PREFIX=yes
-USE_LINUX?= yes
+USE_LINUX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS=yes
PLIST_SUB= VERSION=${PORTVERSION:C/^([^\.]+\.[^\.]+\.[^\.]+).+/\1/}
# Set the version of Fedora Core
diff --git a/graphics/linux-imlib/Makefile b/graphics/linux-imlib/Makefile
index 771be258d8dd..a76aee9e8f06 100644
--- a/graphics/linux-imlib/Makefile
+++ b/graphics/linux-imlib/Makefile
@@ -7,7 +7,7 @@
PORTNAME= imlib
PORTVERSION= 1.9.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MAINTAINER= ports@FreeBSD.org
diff --git a/graphics/linux-jpeg/Makefile b/graphics/linux-jpeg/Makefile
index a17828596f65..b62d2c2225a6 100644
--- a/graphics/linux-jpeg/Makefile
+++ b/graphics/linux-jpeg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jpeg
PORTVERSION= 6b.15
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics linux
MAINTAINER= freebsd-emulation@FreeBSD.org
diff --git a/graphics/linux-libmng/Makefile b/graphics/linux-libmng/Makefile
index 7dc5f3cab911..8429247003be 100644
--- a/graphics/linux-libmng/Makefile
+++ b/graphics/linux-libmng/Makefile
@@ -7,7 +7,7 @@
PORTNAME= libmng
PORTVERSION= 1.0.4
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES?= ${RPM_MIRRORS:S/__DIR__/${STDDIR}/g}
PKGNAMEPREFIX= linux-
@@ -22,13 +22,12 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libjpeg.so.62:${PORTSDIR}/graphics/linux-jpeg
BASEVERSION= 8.0
-USE_LINUX_RPM= yes
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
-NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
+NO_BUILD= yes
PLIST?= ${PKGDIR}/pkg-plist.${MACHINE_ARCH}
MD5_FILE?= ${MASTERDIR}/distinfo.${MACHINE_ARCH}
diff --git a/graphics/linux-panorama-tools/Makefile b/graphics/linux-panorama-tools/Makefile
index fe6f59735697..ec2a448a871a 100644
--- a/graphics/linux-panorama-tools/Makefile
+++ b/graphics/linux-panorama-tools/Makefile
@@ -14,7 +14,7 @@
PORTNAME= linux-panorama-tools
PORTVERSION= 2.6b1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= http://www.path.unimelb.edu.au/~dersch/
DISTNAME= PanoTools
@@ -23,12 +23,11 @@ MAINTAINER= cartola@openit.com.br
COMMENT= Software to View, Create, Edit and Remap Panoramic Images
RUN_DEPENDS= ${LINUXBASE}/usr/bin/jpegtran:${PORTSDIR}/graphics/linux-jpeg \
- ${LINUXBASE}/usr/bin/tiffcmp:${PORTSDIR}/graphics/linux-tiff \
+ ${LINUXBASE}/usr/lib/libtiff.so.3.6.1:${PORTSDIR}/graphics/linux-tiff \
${LINUXBASE}/usr/lib/libpng12.so.0.1.2.7:${PORTSDIR}/graphics/linux-png
-BROKEN= Broken dependency
-
NO_BUILD= yes
+USE_LINUX= yes
WRKSRC= ${WRKDIR}/PTLinux
PROGRAM= Helpers/PTStitcher
diff --git a/graphics/linux-png/Makefile b/graphics/linux-png/Makefile
index a552d996bb96..caf7025935e4 100644
--- a/graphics/linux-png/Makefile
+++ b/graphics/linux-png/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.2.7
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
diff --git a/graphics/linux-png10/Makefile b/graphics/linux-png10/Makefile
index 0172b415cec4..5307a31714f5 100644
--- a/graphics/linux-png10/Makefile
+++ b/graphics/linux-png10/Makefile
@@ -7,7 +7,7 @@
PORTNAME= png
PORTVERSION= 1.0.16
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= graphics linux
MASTER_SITES= http://mirrors.xmission.com/fedora/core/3/i386/os/Fedora/RPMS/ \
http://fedora.cat.pdx.edu/linux/core/3/i386/os/Fedora/RPMS/
diff --git a/graphics/linux-sdl_image/Makefile b/graphics/linux-sdl_image/Makefile
index 6d7f53e16e9f..6b60f37c8e41 100644
--- a/graphics/linux-sdl_image/Makefile
+++ b/graphics/linux-sdl_image/Makefile
@@ -8,6 +8,7 @@
PORTNAME= sdl_image
PORTVERSION= 1.2.3
+PORTREVISION= 1
CATEGORIES= graphics linux
MASTER_SITES= http://www.libsdl.org/projects/SDL_image/release/
PKGNAMEPREFIX= linux-
@@ -21,13 +22,13 @@ COMMENT= A simple library to load images as SDL interfaces (linux version)
RUN_DEPENDS= ${LINUXBASE}/usr/lib/libSDL-1.2.so.0:${PORTSDIR}/devel/linux-sdl12
BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
ONLY_FOR_ARCHS= i386
DIST_SUBDIR= rpm
NO_BUILD= yes
-NO_FILTER_SHLIBS= yes
DBPATH= /var/lib/rpm
RPMFLAGS= --ignoreos --root ${PREFIX} --dbpath ${DBPATH} \
diff --git a/graphics/linux-tiff/Makefile b/graphics/linux-tiff/Makefile
index 613aa8b6b490..b1514ecacddd 100644
--- a/graphics/linux-tiff/Makefile
+++ b/graphics/linux-tiff/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tiff
PORTVERSION= 3.6.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_SUSE}
MASTER_SITE_SUBDIR= i386/update/9.2/rpm/i586
@@ -23,15 +23,14 @@ BUILD_DEPENDS= rpm:${PORTSDIR}/archivers/rpm
DIST_SUBDIR= rpm/i386/suse/9.2
DOCDIRS= usr/share/doc/libtiff-3.6.1
-NO_FILTER_SHLIBS= yes
ONLY_FOR_ARCHS= amd64 i386
PLIST= ${WRKDIR}/plist
PLIST_DIRS= usr/share/doc/packages/libtiff usr/share/doc/packages
PLIST_FILES= usr/lib/libtiff.so.3 usr/lib/libtiff.so.3.6.1 \
usr/share/doc/packages/libtiff/COPYRIGHT \
usr/share/doc/packages/libtiff/README
-PREFIX= ${LINUXBASE}
-USE_LINUX?= yes
+USE_LINUX= yes
+USE_LINUX_PREFIX=yes
# dummy target so rpm can be in BUILD_DEPENDS
do-build:
@@ -40,13 +39,10 @@ do-build:
do-install:
${MKDIR} ${WRKSRC}
@rpm -U --ignorearch --ignoreos --root ${PREFIX} --dbpath /var/lib/rpm \
- --nodeps --replacepkgs ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
+ --nodeps --replacepkgs --noscripts ${DISTDIR}/${DIST_SUBDIR}/${DISTNAME} \
|| ${TRUE}
post-install:
- @${RM} -f ${LINUXBASE}/etc/ld.so.cache
- @${FIND} ${LINUXBASE} -name lib -type d | ${SED} 's:${LINUXBASE}::g' \
- > ${LINUXBASE}/etc/ld.so.conf
@chroot ${LINUXBASE} sbin/ldconfig
.include <bsd.port.mk>
diff --git a/graphics/linux-ungif/Makefile b/graphics/linux-ungif/Makefile
index 479616796878..5e6c874ea956 100644
--- a/graphics/linux-ungif/Makefile
+++ b/graphics/linux-ungif/Makefile
@@ -5,7 +5,7 @@
#
PORTNAME= ungif
PORTVERSION= 4.1.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
MAINTAINTER= maho@FreeBSD.org
diff --git a/graphics/linux_dri/Makefile b/graphics/linux_dri/Makefile
index 0b39b45f9efa..099b55ea9131 100644
--- a/graphics/linux_dri/Makefile
+++ b/graphics/linux_dri/Makefile
@@ -7,7 +7,7 @@
PORTNAME= linux_dri
PORTVERSION= 4.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics linux
MASTER_SITES= ftp://ftp.xfree86.org/pub/XFree86/${PORTVERSION}/binaries/Linux-ix86-glibc21/:x \
http://people.freebsd.org/~anholt/dri/files/:anholt
@@ -20,19 +20,17 @@ DIST_SUBDIR= linux_dri-${PORTVERSION}
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Binary Linux DRI libraries for 3D hardware acceleration of linux apps
-RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libX11.so.6:${PORTSDIR}/x11/linux-XFree86-libs
-
WRKSRC= ${WRKDIR}/lib
NO_BUILD= yes
+USE_LINUX= yes
USE_LINUX_PREFIX= yes
+USE_XLIB= yes
ONLY_FOR_ARCHS= i386
MODULELIST= gamma_dri.so i810_dri.so i830_dri.so mga_dri.so r128_dri.so \
r200_dri.so radeon_dri.so tdfx_dri.so
LDCONFIG_LINUX= ${LINUXBASE}/sbin/ldconfig
-NO_FILTER_SHLIBS= yes
-STRIP=
do-install:
${MKDIR} ${PREFIX}/usr/X11R6/lib/modules/dri
@@ -49,7 +47,9 @@ do-install:
${LN} -sf libglide3-v5.so.0 ${PREFIX}/usr/X11R6/lib/libglide3-v5.so
${INSTALL_PROGRAM} ${WRKDIR}/linux-dri-tools/libglut.so.3.7.0 ${PREFIX}/usr/X11R6/lib
${INSTALL_PROGRAM} ${WRKDIR}/linux-dri-tools/gears ${PREFIX}/usr/X11R6/bin
+ ${BRANDELF} -t Linux ${PREFIX}/usr/X11R6/bin/gears
${INSTALL_PROGRAM} ${WRKDIR}/linux-dri-tools/glxinfo ${PREFIX}/usr/X11R6/bin
+ ${BRANDELF} -t Linux ${PREFIX}/usr/X11R6/bin/glxinfo
post-install:
@${LDCONFIG_LINUX} ${PREFIX}/usr/X11R6/lib
diff --git a/graphics/linux_glide/Makefile b/graphics/linux_glide/Makefile
index 3dcfedc701a6..599f4fb62974 100644
--- a/graphics/linux_glide/Makefile
+++ b/graphics/linux_glide/Makefile
@@ -22,7 +22,7 @@ COMMENT= Linux library implementing the GLIDE interface to 3dfx video cards
ONLY_FOR_ARCHS= i386
USE_LINUX_PREFIX=yes
-USE_LINUX?= yes
+USE_LINUX= yes
NO_MTREE= yes
NO_BUILD= yes
WRKSRC= ${WRKDIR}/Glide2.4
diff --git a/graphics/linux_glx/Makefile b/graphics/linux_glx/Makefile
index 0a9c33a1abb5..8dc9521a2e28 100644
--- a/graphics/linux_glx/Makefile
+++ b/graphics/linux_glx/Makefile
@@ -7,7 +7,7 @@
PORTNAME= glx
PORTVERSION= 991127
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics linux
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= 3d/glx/linux
@@ -17,17 +17,15 @@ DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= Libraries to make use of glx-aware Linux apps
-BUILD_DEPENDS= ${LINUXBASE}/sbin/ldconfig:${PORTSDIR}/emulators/linux_base-8
+BUILD_DEPENDS= ${LINUX_BASE_PORT}
USE_BZIP2= yes
NO_BUILD= yes
+USE_LINUX= yes
USE_LINUX_PREFIX=yes
-NO_MTREE= yes
WRKSRC= ${WRKDIR}/linux_glx
-# switch off stripping during INSTALL_PROGRAM
-STRIP=
.include <bsd.port.pre.mk>
@@ -35,13 +33,11 @@ STRIP=
IGNORE= "Requires XFree86 3.3.* - will not work with XFree86 4.*"
.endif
-# NEVER EVER use plain INSTALL_PROGRAM on Linux binaries,
-# as they get stripped!
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/libGL.so ${PREFIX}/lib
${INSTALL_PROGRAM} ${WRKSRC}/libGLU.so ${PREFIX}/lib
${INSTALL_PROGRAM} ${WRKSRC}/libglut.so ${PREFIX}/lib
post-install:
- @ ${PREFIX}/sbin/ldconfig
+ @${LINUXBASE}/sbin/ldconfig
.include <bsd.port.post.mk>
diff --git a/graphics/linux_mesa3/Makefile b/graphics/linux_mesa3/Makefile
index f993e307793b..868f2b815316 100644
--- a/graphics/linux_mesa3/Makefile
+++ b/graphics/linux_mesa3/Makefile
@@ -7,7 +7,7 @@
PORTNAME= mesa
PORTVERSION= 3.4.2
-PORTREVISION= 5
+PORTREVISION= 6
MASTER_SITES= ftp://ftp.leo.org/pub/comp/os/unix/linux/redhat/redhat/updates/7.2/en/os/i386/ \
ftp://ftp.uni-kl.de/pub/linux/redhat/redhat/updates/7.2/en/os/i386/ \
ftp://ftp.icm.edu.pl/mirrors/ftp.redhat.com/pub/redhat/linux/updates/7.2/en/os/i386/ \
@@ -20,8 +20,7 @@ CATEGORIES= graphics linux
MAINTAINER= freebsd-emulation@FreeBSD.org
COMMENT= A graphics library similar to SGI's OpenGL, used from Linux programs
-RUN_DEPENDS+= ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
-
+USE_XLIB= yes
BASEVERSION=7.2
ONLY_FOR_ARCHS= i386
PLIST= ${PKGDIR}/pkg-plist