aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/autopano-sift-c/Makefile18
-rw-r--r--graphics/exifprobe/Makefile8
-rw-r--r--graphics/ftgl/Makefile8
-rw-r--r--graphics/ftgl/pkg-descr2
-rw-r--r--graphics/glosm/Makefile12
-rw-r--r--graphics/glosm/pkg-descr2
-rw-r--r--graphics/glpng/Makefile7
-rw-r--r--graphics/glpng/files/patch-glpng.c32
-rw-r--r--graphics/makehuman/Makefile18
-rw-r--r--graphics/nathive/Makefile11
-rw-r--r--graphics/py-pyglet/Makefile18
-rw-r--r--graphics/py-rabbyt/Makefile9
-rw-r--r--graphics/py-rabbyt/pkg-descr2
-rw-r--r--graphics/quesoglc/Makefile18
-rw-r--r--graphics/sk1libs/Makefile12
-rw-r--r--graphics/sk1libs/pkg-descr2
-rw-r--r--graphics/structuresynth/Makefile7
-rw-r--r--graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp16
-rw-r--r--graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h16
-rw-r--r--graphics/uniconvertor/Makefile6
-rw-r--r--graphics/uniconvw/Makefile6
-rw-r--r--graphics/wings-devel/Makefile8
-rw-r--r--graphics/wings/Makefile6
23 files changed, 94 insertions, 150 deletions
diff --git a/graphics/autopano-sift-c/Makefile b/graphics/autopano-sift-c/Makefile
index 711e9dbdef93..6e02e3a2b3a0 100644
--- a/graphics/autopano-sift-c/Makefile
+++ b/graphics/autopano-sift-c/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: autopano-sift-c
-# Date created: 10 Jul 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= autopano-sift-C
PORTVERSION= 2.5.1
@@ -14,13 +10,13 @@ MASTER_SITES= SF/hugin/${PORTNAME}/${PORTNAME}-${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Automatic panorama control point generation tool, C port
-RESTRICTED= May be covered by patents
-
-LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
- jpeg.11:${PORTSDIR}/graphics/jpeg \
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff \
+ jpeg:${PORTSDIR}/graphics/jpeg \
png15:${PORTSDIR}/graphics/png \
pano13:${PORTSDIR}/graphics/libpano13
+RESTRICTED= May be covered by patents
+
CONFLICTS= autopano-sift-[0-9]*
USE_GNOME= libxml2
@@ -35,10 +31,12 @@ PORTDOCS= *
MAN1= autopano-c-complete.1 autopano.1 generatekeys.1
MAN7= autopano-sift-c.7
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/README.1ST ${DOCSDIR}/
diff --git a/graphics/exifprobe/Makefile b/graphics/exifprobe/Makefile
index 209585fa4705..fc75bd5df0d8 100644
--- a/graphics/exifprobe/Makefile
+++ b/graphics/exifprobe/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: exifprobe
-# Date created: 2004-07-21
-# Whom: Michael Johnson <ahze@ahze.net>
-#
+# Created by: Michael Johnson <ahze@ahze.net>
# $FreeBSD$
-#
PORTNAME= exifprobe
DISTVERSION= 2.0.1
@@ -24,7 +20,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/exifgrep ${PREFIX}/bin
@${INSTALL_PROGRAM} ${WRKSRC}/exifprobe ${PREFIX}/bin
.for i in ${MAN1}
- @${INSTALL_MAN} ${WRKSRC}/${i} ${MANPREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/${i} ${MAN1PREFIX}/man/man1
.endfor
.include <bsd.port.mk>
diff --git a/graphics/ftgl/Makefile b/graphics/ftgl/Makefile
index d88cbf81c7bf..2db30c621b34 100644
--- a/graphics/ftgl/Makefile
+++ b/graphics/ftgl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ftgl
-# Date created: 16 Jan 2004
-# Whom: Igor Pokrovsky <tiamat@comset.net>
-#
+# Created by: Igor Pokrovsky <tiamat@comset.net>
# $FreeBSD$
-#
PORTNAME= ftgl
DISTVERSION= 2.1.3-rc5
@@ -14,7 +10,7 @@ MASTER_SITES= SF/${PORTNAME}/FTGL%20Source/2.1.3%7Erc5
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= An OpenGL FreeType fonts rendering library
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
USE_GMAKE= yes
USE_GL= gl glu
diff --git a/graphics/ftgl/pkg-descr b/graphics/ftgl/pkg-descr
index 5e4931994062..c12d9125ef81 100644
--- a/graphics/ftgl/pkg-descr
+++ b/graphics/ftgl/pkg-descr
@@ -6,4 +6,4 @@ format. FTGL uses the Freetype (www.freetype.org) font library to open and
'decode' the fonts. It then takes that output and stores it in a format
most efficient for OpenGL rendering.
-WWW: http://ftgl.wiki.sourceforge.net/
+WWW: http://ftgl.wiki.sourceforge.net/
diff --git a/graphics/glosm/Makefile b/graphics/glosm/Makefile
index f9b442459f0f..eb9b4c312ef7 100644
--- a/graphics/glosm/Makefile
+++ b/graphics/glosm/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: glosm
-# Date created: 15 Jan 2011
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= glosm
PORTVERSION= 0.0.2
@@ -16,7 +12,7 @@ MAINTAINER= amdmi3@FreeBSD.org
COMMENT= 3D OpenGL renderer for OpenStreetMap
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
- expat.6:${PORTSDIR}/textproc/expat2
+ expat:${PORTSDIR}/textproc/expat2
USE_BZIP2= yes
USES= cmake
@@ -26,11 +22,13 @@ MAKE_JOBS_SAFE= yes
PORTDOCS= README ChangeLog
+.include <bsd.port.options.mk>
+
regression-test:
cd ${BUILD_WRKSRC} && ctest
-.if !defined(NOPORTDOCS)
post-install:
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
diff --git a/graphics/glosm/pkg-descr b/graphics/glosm/pkg-descr
index 67b52d0f047c..d53b77f5d72f 100644
--- a/graphics/glosm/pkg-descr
+++ b/graphics/glosm/pkg-descr
@@ -2,4 +2,4 @@ glosm is a framework for developing high-performance geospatial
data visualization applications of both interactive and batch nature
featuring OpenGL-based 3D first-person and tile renderers.
-WWW: http://glosm.amdmi3.ru/about.html
+WWW: http://glosm.amdmi3.ru/about.html
diff --git a/graphics/glpng/Makefile b/graphics/glpng/Makefile
index 0cf952ac6980..8535f3801565 100644
--- a/graphics/glpng/Makefile
+++ b/graphics/glpng/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: glpng
-# Date created: 06 Mar 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= glpng
PORTVERSION= 1.45
@@ -21,6 +17,7 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
USE_GL= gl
USE_ZIP= yes
USE_LDCONFIG= yes
+USE_DOS2UNIX= glpng.c
AR?= /usr/bin/ar
diff --git a/graphics/glpng/files/patch-glpng.c b/graphics/glpng/files/patch-glpng.c
index 5a74cc264149..643e476a0e23 100644
--- a/graphics/glpng/files/patch-glpng.c
+++ b/graphics/glpng/files/patch-glpng.c
@@ -6,13 +6,13 @@
+#include "png.h"
#include <GL/glpng.h>
- #include <GL/gl.h>
+ #include <GL/gl.h>
#include <stdlib.h>
#include <math.h>
-#include "png/png.h"
-
- /* Used to decide if GL/gl.h supports the paletted extension */
- #ifdef GL_COLOR_INDEX1_EXT
+
+ /* Used to decide if GL/gl.h supports the paletted extension */
+ #ifdef GL_COLOR_INDEX1_EXT
@@ -269,14 +269,14 @@
if (pinfo == NULL) return 0;
@@ -24,12 +24,12 @@
info = png_create_info_struct(png);
endinfo = png_create_info_struct(png);
- // DH: added following lines
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- {
- png_destroy_read_struct(&png, &info, &endinfo);
- return 0;
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
@@ -373,14 +373,14 @@
png_uint_32 i;
@@ -41,9 +41,9 @@
info = png_create_info_struct(png);
endinfo = png_create_info_struct(png);
- // DH: added following lines
-- if (setjmp(png->jmpbuf))
-+ if (setjmp(png_jmpbuf(png)))
- {
- png_destroy_read_struct(&png, &info, &endinfo);
- return 0;
+ // DH: added following lines
+- if (setjmp(png->jmpbuf))
++ if (setjmp(png_jmpbuf(png)))
+ {
+ png_destroy_read_struct(&png, &info, &endinfo);
+ return 0;
diff --git a/graphics/makehuman/Makefile b/graphics/makehuman/Makefile
index b4a2edc23710..0269fefa002e 100644
--- a/graphics/makehuman/Makefile
+++ b/graphics/makehuman/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: makehuman
-# Date created: 06 Mar 2006
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= makehuman
DISTVERSION= 0.9.1-rc1a
@@ -14,20 +10,20 @@ MASTER_SITES= SF/${PORTNAME}/MakeHuman%20Source/MakeHuman_091
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Application for parametrical modeling of 3D humanoid characters
-LIB_DEPENDS= animorph.0:${PORTSDIR}/graphics/animorph \
- mhgui.0:${PORTSDIR}/graphics/mhgui
+LIB_DEPENDS= animorph:${PORTSDIR}/graphics/animorph \
+ mhgui:${PORTSDIR}/graphics/mhgui
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_GNOME= pkgconfig
+USE_PKGCONFIG= build
USE_GL= glut
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.if !defined(NOPORTDOCS)
PORTDOCS= *
-.endif
+
+.include <bsd.port.options.mk>
post-patch:
@${REINPLACE_CMD} -e 's,find . \(-name .*\) -exec cp --parents {} \(.*\) \\;,find -d . \1 | ${CPIO} -dumpl \2,g' \
@@ -36,7 +32,7 @@ post-patch:
@${REINPLACE_CMD} -e '/^makehuman_pixmapsdir =/ s|pixmaps/makehuman|makehuman/pixmaps|' ${WRKSRC}/pixmaps/Makefile.in
@${REINPLACE_CMD} -e '/^packagepixmapsdir=/ s|pixmaps/\$${PACKAGE}|$${PACKAGE}/pixmaps|' ${WRKSRC}/configure
@${REINPLACE_CMD} -e '/^makehumandocdir =/ s|doc/|share/doc/|' ${WRKSRC}/Makefile.in
-.if defined(NOPORTDOCS)
+.if ! ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-makehumandocDATA||' ${WRKSRC}/Makefile.in
.endif
diff --git a/graphics/nathive/Makefile b/graphics/nathive/Makefile
index 97e3ad7e986f..ae1b391b1692 100644
--- a/graphics/nathive/Makefile
+++ b/graphics/nathive/Makefile
@@ -1,13 +1,9 @@
-# New ports collection makefile for: nathive
-# Date created: 24 Nov 2008
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= nathive
PORTVERSION= 0.813
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
MASTER_SITES= http://www.nathive.org/packages/ \
http://mirror.amdmi3.ru/distfiles/
@@ -16,7 +12,8 @@ DISTNAME= ${PORTNAME}_${PORTVERSION}_source
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Lightweight image editor
-USE_GNOME= pkgconfig glib20 gtk20
+USE_GNOME= glib20 gtk20
+USE_PKGCONFIG= build
ALL_TARGET= default
post-patch:
diff --git a/graphics/py-pyglet/Makefile b/graphics/py-pyglet/Makefile
index 6bf37d3a579e..f04a795361ee 100644
--- a/graphics/py-pyglet/Makefile
+++ b/graphics/py-pyglet/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: pyglet
-# Date created: 12 Aug 2008
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= pyglet
PORTVERSION= 1.1.4
@@ -14,8 +10,8 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Cross-platform windowing and multimedia library for Python
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_PYTHON= yes
USE_PYDISTUTILS= yes
@@ -25,20 +21,20 @@ USE_OPENAL= al
PORTDOCS= *
PORTEXAMPLES= *
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if ${ARCH} != "i386"
IGNORE= crashes or doesn't work on !i386
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}
cd ${WRKSRC}/doc && ${COPYTREE_SHARE} \* ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} \* ${EXAMPLESDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/py-rabbyt/Makefile b/graphics/py-rabbyt/Makefile
index c0b979d6d36e..2ec39685a055 100644
--- a/graphics/py-rabbyt/Makefile
+++ b/graphics/py-rabbyt/Makefile
@@ -1,16 +1,11 @@
-# New ports collection makefile for: py-rabbyt
-# Date created: 12 Oct 2007
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= rabbyt
PORTVERSION= 0.8.2
CATEGORIES= graphics python
-MASTER_SITES= ${MASTER_SITE_CHEESESHOP} \
+MASTER_SITES= CHEESESHOP/source/R/Rabbyt \
http://mirror.amdmi3.ru/distfiles/
-MASTER_SITE_SUBDIR=source/R/Rabbyt
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= Rabbyt-${PORTVERSION}
diff --git a/graphics/py-rabbyt/pkg-descr b/graphics/py-rabbyt/pkg-descr
index 36e948621ff1..086aeceb3a0d 100644
--- a/graphics/py-rabbyt/pkg-descr
+++ b/graphics/py-rabbyt/pkg-descr
@@ -4,4 +4,4 @@ It has two goals:
1. Be fast, without sacrificing ease of use.
2. Be easy to use, without sacrificing speed
-WWW: http://matthewmarshall.org/projects/rabbyt/
+WWW: http://matthewmarshall.org/projects/rabbyt/
diff --git a/graphics/quesoglc/Makefile b/graphics/quesoglc/Makefile
index 0ab2c7c86e08..39114767ec31 100644
--- a/graphics/quesoglc/Makefile
+++ b/graphics/quesoglc/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: quesoglc
-# Date created: 04 Jun 2009
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= quesoglc
PORTVERSION= 0.7.2
@@ -14,14 +10,14 @@ MASTER_SITES= SF/${PORTNAME}/QuesoGLC/${PORTVERSION}
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= Free implementation of the OpenGL Character Renderer
-LIB_DEPENDS= fribidi.3:${PORTSDIR}/converters/fribidi \
- freetype.9:${PORTSDIR}/print/freetype2 \
- fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
+LIB_DEPENDS= fribidi:${PORTSDIR}/converters/fribidi \
+ freetype:${PORTSDIR}/print/freetype2 \
+ fontconfig:${PORTSDIR}/x11-fonts/fontconfig
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USES= pathfix
+USES= pathfix
USE_GL= gl glu glut
USE_LDCONFIG= yes
@@ -32,7 +28,9 @@ CONFIGURE_ARGS= --without-glew --with-fribidi
PORTDOCS= README
-.if !defined(NOPORTDOCS)
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
post-install:
${MKDIR} ${DOCSDIR}
.for f in ${PORTDOCS}
diff --git a/graphics/sk1libs/Makefile b/graphics/sk1libs/Makefile
index 085703f9898b..4c22ab7b0b94 100644
--- a/graphics/sk1libs/Makefile
+++ b/graphics/sk1libs/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: sk1libs
-# Date created: 30 Jun 2010
-# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
-#
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= sk1libs
PORTVERSION= 0.9.1
@@ -14,9 +10,9 @@ MASTER_SITES= GOOGLE_CODE \
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A set of python libraries for sK1 Project
-LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms \
- freetype.9:${PORTSDIR}/print/freetype2 \
- jpeg.11:${PORTSDIR}/graphics/jpeg
+LIB_DEPENDS= lcms:${PORTSDIR}/graphics/lcms \
+ freetype:${PORTSDIR}/print/freetype2 \
+ jpeg:${PORTSDIR}/graphics/jpeg
PROJECTHOST= uniconvertor
diff --git a/graphics/sk1libs/pkg-descr b/graphics/sk1libs/pkg-descr
index 6c0cc19ec1eb..8beec8941622 100644
--- a/graphics/sk1libs/pkg-descr
+++ b/graphics/sk1libs/pkg-descr
@@ -1,4 +1,4 @@
sk1libs is a set of python libs for sK1 Project. The package includes
multiplatform non-GUI extensions which are usually native extensions.
-WWW: http://sk1project.org/
+WWW: http://sk1project.org/
diff --git a/graphics/structuresynth/Makefile b/graphics/structuresynth/Makefile
index 6f78916e2a80..dc99128db5cf 100644
--- a/graphics/structuresynth/Makefile
+++ b/graphics/structuresynth/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: structuresynth
-# Date created: 06 Apr 2008
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= structuresynth
PORTVERSION= 1.5.0
@@ -20,6 +16,7 @@ USE_ZIP= yes
USE_QT4= qmake_build corelib gui opengl moc_build rcc_build xml script
MAKE_JOBS_SAFE= yes
WRKSRC= ${WRKDIR}/structure-synth
+USE_DOS2UNIX= *.cpp *.h
post-extract:
@${MV} "${WRKDIR}/Structure Synth Source Code" ${WRKSRC}
diff --git a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp
index 73940063bde5..501304daeef3 100644
--- a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp
+++ b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Raytracer__RayTracer.cpp
@@ -1,11 +1,11 @@
--- ./SyntopiaCore/GLEngine/Raytracer/RayTracer.cpp~ 2012-05-20 01:28:31.000000000 -0300
+++ ./SyntopiaCore/GLEngine/Raytracer/RayTracer.cpp 2012-05-20 01:28:47.000000000 -0300
@@ -7,6 +7,8 @@
- #include "SyntopiaCore/Logging/Logging.h"
- #include "SyntopiaCore/Misc/MiniParser.h"
-
-+#include <GL/glu.h>
-+
- using namespace SyntopiaCore::Math;
- using namespace SyntopiaCore::Misc;
-
+ #include "SyntopiaCore/Logging/Logging.h"
+ #include "SyntopiaCore/Misc/MiniParser.h"
+
++#include <GL/glu.h>
++
+ using namespace SyntopiaCore::Math;
+ using namespace SyntopiaCore::Misc;
+
diff --git a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h
index 671be4a09ccb..fca363622d8d 100644
--- a/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h
+++ b/graphics/structuresynth/files/patch-SyntopiaCore__GLEngine__Sphere.h
@@ -1,11 +1,11 @@
--- ./SyntopiaCore/GLEngine/Sphere.h~ 2012-05-20 01:25:41.000000000 -0300
+++ ./SyntopiaCore/GLEngine/Sphere.h 2012-05-20 01:25:59.000000000 -0300
@@ -3,6 +3,8 @@
- #include "SyntopiaCore/Math/Vector3.h"
- #include "Object3D.h"
-
-+#include <GL/glu.h>
-+
- namespace SyntopiaCore {
- namespace GLEngine {
-
+ #include "SyntopiaCore/Math/Vector3.h"
+ #include "Object3D.h"
+
++#include <GL/glu.h>
++
+ namespace SyntopiaCore {
+ namespace GLEngine {
+
diff --git a/graphics/uniconvertor/Makefile b/graphics/uniconvertor/Makefile
index c9ce536c2d31..afca8f5c8345 100644
--- a/graphics/uniconvertor/Makefile
+++ b/graphics/uniconvertor/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: uniconvertor
-# Date created: 15 Nov 2007
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= uniconvertor
PORTVERSION= 1.1.5
diff --git a/graphics/uniconvw/Makefile b/graphics/uniconvw/Makefile
index 4bee8d7f294c..72c6c232c948 100644
--- a/graphics/uniconvw/Makefile
+++ b/graphics/uniconvw/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: uniconvw
-# Date created: 28 Oct 2010
-# Whom: Dmitry Marakasov <amdmi3@amdmi3.ru>
-#
+# Created by: Dmitry Marakasov <amdmi3@amdmi3.ru>
# $FreeBSD$
-#
PORTNAME= uniconvw
PORTVERSION= 1.1.5
diff --git a/graphics/wings-devel/Makefile b/graphics/wings-devel/Makefile
index cd44cf45831d..fa98b6c7d6aa 100644
--- a/graphics/wings-devel/Makefile
+++ b/graphics/wings-devel/Makefile
@@ -1,17 +1,13 @@
-# New ports collection makefile for: wings
-# Date Created: 5 March 2003
-# Whom: olgeni@FreeBSD.org
-#
+# Created by: olgeni@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= wings
PORTVERSION= 1.3.1
PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= SF
-DIST_SUBDIR= erlang
PKGNAMESUFFIX= -devel
+DIST_SUBDIR= erlang
MAINTAINER= amdmi3@FreeBSD.org
COMMENT= A polygon mesh modeler written in Erlang
diff --git a/graphics/wings/Makefile b/graphics/wings/Makefile
index c3841cbd97a8..f040be6b1608 100644
--- a/graphics/wings/Makefile
+++ b/graphics/wings/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: wings
-# Date Created: 5 March 2003
-# Whom: olgeni@FreeBSD.org
-#
+# Created by: olgeni@FreeBSD.org
# $FreeBSD$
-#
PORTNAME= wings
PORTVERSION= 1.4.1