aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/fraqtive/Makefile9
-rw-r--r--graphics/povray-meta/Makefile30
-rw-r--r--graphics/xaos/Makefile12
3 files changed, 24 insertions, 27 deletions
diff --git a/graphics/fraqtive/Makefile b/graphics/fraqtive/Makefile
index a555677bbd74..30f54a673c59 100644
--- a/graphics/fraqtive/Makefile
+++ b/graphics/fraqtive/Makefile
@@ -24,13 +24,14 @@ CONFIGURE_ENV= QMAKESPEC="${QMAKESPEC}" \
CONFIGURE_ARGS= -prefix ${PREFIX} -qmake ${QMAKE}
MAKE_JOBS_SAFE= yes
-OPTIONS= SSE2 "Enable SSE2 optimization" off
+OPTIONS_DEFINE= SSE2
+SSE2_DESC= Enable SSE2 optimization
STRIP_FILES= bin/fraqtive
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if !defined(WITH_SSE2)
+.if !${PORT_OPTIONS:MSSE2}
CONFIGURE_ARGS+=-no-sse2
.endif
@@ -44,4 +45,4 @@ post-configure:
post-install:
${STRIP_CMD} ${STRIP_FILES:S,^,${PREFIX}/,}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/povray-meta/Makefile b/graphics/povray-meta/Makefile
index 9890f20d96d9..89fae748d4d4 100644
--- a/graphics/povray-meta/Makefile
+++ b/graphics/povray-meta/Makefile
@@ -25,38 +25,34 @@ DEFAULT_VER?= 36
#To change version linked by default define WITH_DEFAULT${ver}.
#Please, note that only one of WITH_DEFAULT* can be set at once.
-OPT_POVRAY${DEFAULT_VER}= on
-OPT_DEFAULT${DEFAULT_VER}= on
+OPTIONS_MULTI= POVRAY
+OPTIONS_SINGLE= DEFAULT
+
+OPTIONS_DEFAULT= POVRAY${DEFAULT_VER} DEFAULT${DEFAULT_VER}
.for ver in ${POV_VERSIONS_ALL}
POVRAY${ver}_BIN= ${LOCALBASE}/bin/povray${ver}
POVRAY${ver}_PORT= graphics/povray${ver}
-OPT_POVRAY${ver}?= off
-OPT_DEFAULT${ver}?= off
-OPTIONS+= POVRAY${ver} "Install graphics/povray${ver}" ${OPT_POVRAY${ver}}
-OPTIONS+= DEFAULT${ver} "Create link bin/povray -> bin/povray${ver}" ${OPT_DEFAULT${ver}}
+
+OPTIONS_MULTI_POVRAY+= POVRAY${ver}
+OPTIONS_SINGLE_DEFAULT+= DEFAULT${ver}
+
+POVRAY${ver}_DESC= Install graphics/povray${ver}
+DEFAULT${ver}_DESC= Create link bin/povray -> bin/povray${ver}
.endfor
.include <bsd.port.options.mk>
.for ver in ${POV_VERSIONS_ALL}
-. if defined(WITH_DEFAULT${ver})
-WITH_POVRAY${ver}= yes
-. if defined(POV_VERSION)
-IGNORE= can't be build: only one default povray can be chosen
-. else
+. if ${PORT_OPTIONS:MDEFAULT${ver}}
+PORT_OPTIONS+= POVRAY${ver}
POV_VERSION= ${ver}
-. endif
. endif
-. if defined(WITH_POVRAY${ver})
+. if ${PORT_OPTIONS:MPOVRAY${ver}}
RUN_DEPENDS+= ${POVRAY${ver}_BIN}:${PORTSDIR}/${POVRAY${ver}_PORT}
. endif
.endfor
-.if !defined(POV_VERSION)
-IGNORE= can't be build: one default povray must be chosen
-.endif
-
do-install:
${LN} -s ${POVRAY${POV_VERSION}_BIN} ${PREFIX}/bin/povray
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 19f2907c331c..600bca4170ee 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -20,9 +20,9 @@ USE_XORG= x11 xext
GNU_CONFIGURE= yes
USE_GMAKE= yes
-OPTIONS= PTHREAD "Enable SMP support (experimental)" off \
- GTK2 "GTK+ User Interface (experimental)" off \
- NLS "Native Language Support" on
+OPTIONS_DEFINE= GTK2 PTHREAD
+GTK2_DESC= GTK+ User Interface (experimental)
+PTHREAD_DESC= Enable SMP support (experimental)
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/libpng15
LDFLAGS+= -L${LOCALBASE}/lib
@@ -39,7 +39,7 @@ DESKTOP_ENTRIES= "XaoS" "Fractal zoomer" "" "xaos" "" false
.include <bsd.port.options.mk>
-.if defined(WITH_PTHREAD)
+.if ${PORT_OPTIONS:MPTHREAD}
CONFIGURE_ARGS+= --with-pthread=yes
CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}"
CFLAGS+= ${PTHREAD_CFLAGS}
@@ -47,12 +47,12 @@ CFLAGS+= ${PTHREAD_CFLAGS}
CONFIGURE_ARGS+= --with-pthread=no
.endif
-.if defined(WITH_GTK2)
+.if ${PORT_OPTIONS:MGTK2}
USE_GNOME= gtk20
CONFIGURE_ARGS+= --with-gtk-driver=yes --with-x11-driver=no
.endif
-.if !defined(WITHOUT_NLS)
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else