aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/povray/Makefile8
-rw-r--r--graphics/povray36/Makefile8
-rw-r--r--graphics/povray37/Makefile8
3 files changed, 21 insertions, 3 deletions
diff --git a/graphics/povray/Makefile b/graphics/povray/Makefile
index 07ced417573b..09eac08c1526 100644
--- a/graphics/povray/Makefile
+++ b/graphics/povray/Makefile
@@ -63,6 +63,12 @@ CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib -I${LOCALBASE}/include"
MAN1= povray.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BROKEN= "Does not compile on i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's+@PREFIX@+${PREFIX}+g;' ${WRKSRC}/povray.ini
@${REINPLACE_CMD} -e 's+%INSTALLDIR%+${PREFIX}/share/${PORTNAME}-${PORTVERSION}+g;' ${WRKSRC}/povray.conf
@@ -83,4 +89,4 @@ do-install:
post-install:
@${SED} -e 's,/usr/local,${PREFIX},g' ${DESCR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/povray36/Makefile b/graphics/povray36/Makefile
index 07ced417573b..09eac08c1526 100644
--- a/graphics/povray36/Makefile
+++ b/graphics/povray36/Makefile
@@ -63,6 +63,12 @@ CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib -I${LOCALBASE}/include"
MAN1= povray.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BROKEN= "Does not compile on i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's+@PREFIX@+${PREFIX}+g;' ${WRKSRC}/povray.ini
@${REINPLACE_CMD} -e 's+%INSTALLDIR%+${PREFIX}/share/${PORTNAME}-${PORTVERSION}+g;' ${WRKSRC}/povray.conf
@@ -83,4 +89,4 @@ do-install:
post-install:
@${SED} -e 's,/usr/local,${PREFIX},g' ${DESCR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/povray37/Makefile b/graphics/povray37/Makefile
index 07ced417573b..09eac08c1526 100644
--- a/graphics/povray37/Makefile
+++ b/graphics/povray37/Makefile
@@ -63,6 +63,12 @@ CONFIGURE_ENV= CXXFLAGS="${CXXFLAGS} -L${LOCALBASE}/lib -I${LOCALBASE}/include"
MAN1= povray.1
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "i386"
+BROKEN= "Does not compile on i386"
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's+@PREFIX@+${PREFIX}+g;' ${WRKSRC}/povray.ini
@${REINPLACE_CMD} -e 's+%INSTALLDIR%+${PREFIX}/share/${PORTNAME}-${PORTVERSION}+g;' ${WRKSRC}/povray.conf
@@ -83,4 +89,4 @@ do-install:
post-install:
@${SED} -e 's,/usr/local,${PREFIX},g' ${DESCR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>