aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/gwenview-kde4/Makefile3
-rw-r--r--graphics/kamera-kde4/Makefile2
-rw-r--r--graphics/kcolorchooser/Makefile2
-rw-r--r--graphics/kdegraphics4-mobipocket/Makefile2
-rw-r--r--graphics/kdegraphics4-strigi-analyzer/Makefile2
-rw-r--r--graphics/kdegraphics4-svgpart/Makefile2
-rw-r--r--graphics/kdegraphics4-thumbnailers/Makefile2
-rw-r--r--graphics/kolourpaint/Makefile3
-rw-r--r--graphics/ksaneplugin/Makefile2
-rw-r--r--graphics/ksnapshot/Makefile2
-rw-r--r--graphics/libkdcraw-kde4/Makefile3
-rw-r--r--graphics/libkexiv2-kde4/Makefile3
-rw-r--r--graphics/libkipi-kde4/Makefile3
-rw-r--r--graphics/libksane/Makefile3
-rw-r--r--graphics/okular/Makefile3
15 files changed, 22 insertions, 15 deletions
diff --git a/graphics/gwenview-kde4/Makefile b/graphics/gwenview-kde4/Makefile
index ab683f443157..0f0371455011 100644
--- a/graphics/gwenview-kde4/Makefile
+++ b/graphics/gwenview-kde4/Makefile
@@ -19,9 +19,10 @@ CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix libkipi libkonq \
automoc4 soprano
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus qmake_build moc_build uic_build rcc_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/kamera-kde4/Makefile b/graphics/kamera-kde4/Makefile
index 2e1d79d242f1..568a8a0e6de1 100644
--- a/graphics/kamera-kde4/Makefile
+++ b/graphics/kamera-kde4/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= gphoto2.2:${PORTSDIR}/graphics/libgphoto2
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus qt3support qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kcolorchooser/Makefile b/graphics/kcolorchooser/Makefile
index 7c2bbdf5a971..b6336ddd203f 100644
--- a/graphics/kcolorchooser/Makefile
+++ b/graphics/kcolorchooser/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE 4 application to select colors from the screen or from a palette
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kdegraphics4-mobipocket/Makefile b/graphics/kdegraphics4-mobipocket/Makefile
index 914242600cd9..da8f180e0a7c 100644
--- a/graphics/kdegraphics4-mobipocket/Makefile
+++ b/graphics/kdegraphics4-mobipocket/Makefile
@@ -13,7 +13,7 @@ COMMENT= Mobipocket plugins for Strigi indexing, Okular and thumbnails
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix okular automoc4 strigi
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= gui qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kdegraphics4-strigi-analyzer/Makefile b/graphics/kdegraphics4-strigi-analyzer/Makefile
index 06bf2b27a432..dad1d2daa37a 100644
--- a/graphics/kdegraphics4-strigi-analyzer/Makefile
+++ b/graphics/kdegraphics4-strigi-analyzer/Makefile
@@ -15,7 +15,7 @@ LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4 strigi
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= corelib qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kdegraphics4-svgpart/Makefile b/graphics/kdegraphics4-svgpart/Makefile
index f3560e6c19d5..6a07bb275cdb 100644
--- a/graphics/kdegraphics4-svgpart/Makefile
+++ b/graphics/kdegraphics4-svgpart/Makefile
@@ -14,7 +14,7 @@ COMMENT= SVG KPart
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kdegraphics4-thumbnailers/Makefile b/graphics/kdegraphics4-thumbnailers/Makefile
index 255f39710982..bd51bcd8ce84 100644
--- a/graphics/kdegraphics4-thumbnailers/Makefile
+++ b/graphics/kdegraphics4-thumbnailers/Makefile
@@ -13,7 +13,7 @@ COMMENT= Thumbnailers for various graphics file formats
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix libkdcraw libkexiv2 automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= gui qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/kolourpaint/Makefile b/graphics/kolourpaint/Makefile
index b21cc06630b3..7bebfc78b85c 100644
--- a/graphics/kolourpaint/Makefile
+++ b/graphics/kolourpaint/Makefile
@@ -13,9 +13,10 @@ COMMENT= KDE 4 paint program
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4 qimageblitz
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= corelib qmake_build moc_build uic_build rcc_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
.include <bsd.port.mk>
diff --git a/graphics/ksaneplugin/Makefile b/graphics/ksaneplugin/Makefile
index a9ae52ccd4f9..82c53b1557a1 100644
--- a/graphics/ksaneplugin/Makefile
+++ b/graphics/ksaneplugin/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE 4 plugin for scanning through libksane
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix libksane automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus qmake_build moc_build uic_build rcc_build
USE_XZ= yes
MAKE_JOBS_SAFE= yes
diff --git a/graphics/ksnapshot/Makefile b/graphics/ksnapshot/Makefile
index 2d4b575adac3..eefe3b0cc5dc 100644
--- a/graphics/ksnapshot/Makefile
+++ b/graphics/ksnapshot/Makefile
@@ -13,7 +13,7 @@ COMMENT= KDE 4 screen capture program
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix libkipi automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus qmake_build moc_build uic_build rcc_build
USE_XORG= x11 xext xfixes
USE_XZ= yes
diff --git a/graphics/libkdcraw-kde4/Makefile b/graphics/libkdcraw-kde4/Makefile
index e26af7a13910..561ce6ce82f3 100644
--- a/graphics/libkdcraw-kde4/Makefile
+++ b/graphics/libkdcraw-kde4/Makefile
@@ -19,9 +19,10 @@ CONFLICTS= kdegraphics-4.[0-6].*
USE_XZ= yes
USE_KDE4= automoc4 kdehier kdeprefix kdelibs
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus gui xml \
moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
pre-configure:
diff --git a/graphics/libkexiv2-kde4/Makefile b/graphics/libkexiv2-kde4/Makefile
index f10ccff234b0..4d3430f63de7 100644
--- a/graphics/libkexiv2-kde4/Makefile
+++ b/graphics/libkexiv2-kde4/Makefile
@@ -18,9 +18,10 @@ CONFLICTS= kdegraphics-4.[0-6].*
USE_XZ= yes
USE_KDE4= automoc4 kdehier kdeprefix kdelibs
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus gui xml \
moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
pre-configure:
diff --git a/graphics/libkipi-kde4/Makefile b/graphics/libkipi-kde4/Makefile
index 88d2ffe97c64..e308514e89a4 100644
--- a/graphics/libkipi-kde4/Makefile
+++ b/graphics/libkipi-kde4/Makefile
@@ -17,9 +17,10 @@ CONFLICTS= kdegraphics-4.[0-6].*
USE_XZ= yes
USE_KDE4= automoc4 kdehier kdeprefix kdelibs
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= dbus gui xml \
moc_build qmake_build rcc_build uic_build
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
pre-configure:
diff --git a/graphics/libksane/Makefile b/graphics/libksane/Makefile
index c8812fc2709f..52e443f79882 100644
--- a/graphics/libksane/Makefile
+++ b/graphics/libksane/Makefile
@@ -15,9 +15,10 @@ LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= corelib moc_build qmake_build rcc_build uic_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
pre-configure:
diff --git a/graphics/okular/Makefile b/graphics/okular/Makefile
index a0ca339b7771..bfe059266c77 100644
--- a/graphics/okular/Makefile
+++ b/graphics/okular/Makefile
@@ -24,9 +24,10 @@ LIB_DEPENDS= djvulibre:${PORTSDIR}/graphics/djvulibre \
CONFLICTS= kdegraphics-4.[0-6].*
USE_KDE4= kdehier kdelibs kdeprefix automoc4 qimageblitz
-KDE4_BUILDENV= yes
+USES= cmake:outsource
USE_QT4= gui xml qmake_build moc_build uic_build rcc_build
USE_XZ= yes
+USE_LDCONFIG= yes
MAKE_JOBS_SAFE= yes
OPTIONS_DEFINE= DVI