aboutsummaryrefslogtreecommitdiff
path: root/graphics
diff options
context:
space:
mode:
Diffstat (limited to 'graphics')
-rw-r--r--graphics/p5-Imager/Makefile1
-rw-r--r--graphics/p5-Imager/files/patch-Imager.xs11
2 files changed, 12 insertions, 0 deletions
diff --git a/graphics/p5-Imager/Makefile b/graphics/p5-Imager/Makefile
index bc0ac51ab9ef..e44a616d5192 100644
--- a/graphics/p5-Imager/Makefile
+++ b/graphics/p5-Imager/Makefile
@@ -8,6 +8,7 @@
PORTNAME= Imager
PORTVERSION= 0.52
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/p5-Imager/files/patch-Imager.xs b/graphics/p5-Imager/files/patch-Imager.xs
new file mode 100644
index 000000000000..e7abc3cfc698
--- /dev/null
+++ b/graphics/p5-Imager/files/patch-Imager.xs
@@ -0,0 +1,11 @@
+--- Imager.xs.orig Wed Jul 26 16:47:45 2006
++++ Imager.xs Wed Jul 26 16:48:43 2006
+@@ -387,7 +387,7 @@
+ if (cbd->reading && cbd->where < cbd->used) {
+ /* we read past the place where the caller expected us to be
+ so adjust our position a bit */
+- *(char *)0 = 0;
++ /* *(char *)0 = 0; debug */
+ if (io_seeker(p, cbd->where - cbd->used, SEEK_CUR) < 0) {
+ return -1;
+ }