aboutsummaryrefslogtreecommitdiff
path: root/irc/bip/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/bip/Makefile')
-rw-r--r--irc/bip/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/irc/bip/Makefile b/irc/bip/Makefile
new file mode 100644
index 000000000000..de0593a7ad4b
--- /dev/null
+++ b/irc/bip/Makefile
@@ -0,0 +1,47 @@
+# New ports collection makefile for: bip
+# Date created: 23 October 2007
+# Whom: Chess Griffin <chess@chessgriffin.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bip
+PORTVERSION= 0.6.1
+CATEGORIES= irc
+MASTER_SITES= http://bip.t1r.net/downloads/
+
+MAINTAINER= chess@chessgriffin.com
+COMMENT= A simple IRC proxy with SSL support
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+INSTALL_TARGET= SUBDIR=src install-exec
+
+USE_OPENSSL= yes
+
+PLIST_FILES= bin/bip bin/bipmkpw
+SUB_FILES= pkg-message
+SUB_LIST= EXAMPLESDIR=${EXAMPLESDIR}
+MAN1= bip.1 bip.conf.1 bipmkpw.1
+MANCOMPRESSED= no
+
+PORTDOCS= AUTHORS ChangeLog NEWS README README.floodcontrol TODO
+PORTEXAMPLES= bip.conf bip.vim
+
+.include <bsd.port.pre.mk>
+
+post-install:
+ @cd ${WRKSRC} && ${INSTALL_MAN} ${MAN1} ${MANPREFIX}/man/man1
+
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d ${DOCSDIR}
+ @cd ${WRKSRC} && ${INSTALL_DATA} ${PORTDOCS} ${DOCSDIR}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${INSTALL} -d ${EXAMPLESDIR}
+ @cd ${WRKSRC}/samples && ${INSTALL_DATA} ${PORTEXAMPLES} ${EXAMPLESDIR}
+.endif
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>