aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee-otr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/bitlbee-otr/Makefile')
-rw-r--r--irc/bitlbee-otr/Makefile18
1 files changed, 12 insertions, 6 deletions
diff --git a/irc/bitlbee-otr/Makefile b/irc/bitlbee-otr/Makefile
index 31e0df0a49b7..43c76c9b6ad0 100644
--- a/irc/bitlbee-otr/Makefile
+++ b/irc/bitlbee-otr/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= bitlbee
-PORTVERSION= 0.85a
-PORTREVISION= 1
+PORTVERSION= 0.90
CATEGORIES= irc
MASTER_SITES= http://get.bitlbee.org/src/
@@ -21,17 +20,24 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --mandir=${PREFIX}/man --config=${PREFIX}/etc/bitlbee
USE_GMAKE= yes
USE_GNOME= glib20
+USE_GETOPT_LONG= yes
PKGMESSAGE= ${WRKDIR}/pkg-message
.if defined(WITH_MSN)
-LIB_DEPENDS= gnutls.12:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+=--msn=1
+LIB_DEPENDS+= gnutls.12:${PORTSDIR}/security/gnutls
+CONFIGURE_ARGS+= --msn=1
pre-configure:
@${ECHO_CMD} "MSN support will be enabled."
.else
-CONFIGURE_ARGS+=--msn=0
+CONFIGURE_ARGS+= --msn=0
pre-configure:
- @${ECHO_CMD} "Type \"make -DWITH_MSN\" if you want enable MSN support."
+ @${ECHO_CMD} "Type \"make -DWITH_MSN\" if you want to enable MSN support."
+.endif
+
+.if defined(WITH_FLOOD)
+CONFIGURE_ARGS+= --flood=1
+.else
+ @${ECHO_CMD} "Type \"make -DWITH_FLOOD\" if you want to enable flood protection."
.endif
post-build: