aboutsummaryrefslogtreecommitdiff
path: root/irc/bitlbee-otr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/bitlbee-otr/Makefile')
-rw-r--r--irc/bitlbee-otr/Makefile48
1 files changed, 0 insertions, 48 deletions
diff --git a/irc/bitlbee-otr/Makefile b/irc/bitlbee-otr/Makefile
deleted file mode 100644
index c860c4f9210a..000000000000
--- a/irc/bitlbee-otr/Makefile
+++ /dev/null
@@ -1,48 +0,0 @@
-# New ports collection makefile for: bitlbee
-# Date created: 10 June 2003
-# Whom: Peter van Dijk <peter@dataloss.nl>
-#
-# $FreeBSD$
-#
-
-PORTNAME= bitlbee
-PORTVERSION= 0.85a
-PORTREVISION= 1
-CATEGORIES= irc
-MASTER_SITES= http://get.bitlbee.org/src/
-
-MAINTAINER= peter@dataloss.nl
-COMMENT= An IRC to other chat networks gateway
-
-MAN5= bitlbee.conf.5
-MAN8= bitlbee.8
-
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --mandir=${PREFIX}/man --config=${PREFIX}/etc/bitlbee
-USE_GMAKE= yes
-USE_GNOME= glib20
-PKGMESSAGE= ${WRKDIR}/pkg-message
-
-.if defined(WITH_MSN)
-LIB_DEPENDS= gnutls.13:${PORTSDIR}/security/gnutls
-CONFIGURE_ARGS+=--msn=1
-pre-configure:
- @${ECHO_CMD} "MSN support will be enabled."
-.else
-CONFIGURE_ARGS+=--msn=0
-pre-configure:
- @${ECHO_CMD} "Type \"make -DWITH_MSN\" if you want enable MSN support."
-.endif
-
-post-build:
- @${CAT} pkg-message | ${SED} -e 's|%%PREFIX%%|${PREFIX}|' > ${PKGMESSAGE}
-
-pre-install:
- @${MKDIR} -m 700 ${PREFIX}/etc/bitlbee
-
-post-install:
- @${CP} ${WRKSRC}/bitlbee.conf ${PREFIX}/etc/bitlbee/bitlbee.conf.orig
- @${CP} ${WRKSRC}/motd.txt ${PREFIX}/etc/bitlbee/motd.txt.orig
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>