aboutsummaryrefslogtreecommitdiff
path: root/irc/hexchat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/hexchat/Makefile')
-rw-r--r--irc/hexchat/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/irc/hexchat/Makefile b/irc/hexchat/Makefile
index e671683095f3..91d2cf9cd2a4 100644
--- a/irc/hexchat/Makefile
+++ b/irc/hexchat/Makefile
@@ -25,7 +25,7 @@ USES= meson ninja desktop-file-utils libtool pkgconfig ssl shebangfix \
USE_GNOME= cairo gtk20 intltool libxml2
USE_XORG= x11
USE_GITHUB= yes
-MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true -Dwith-sysinfo=false
+MESON_ARGS= -Dwith-ssl=true -Dwith-gtk=true
INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
@@ -37,7 +37,7 @@ SUB_FILES= pkg-message
PORTDOCS= *
OPTIONS_DEFINE= CA_BUNDLE CANBERRA DBUS DOCS FISHLIM LUA NOTIFY \
- PERL PYTHON TEXTFE
+ PERL PYTHON TEXTFE SYSINFO
OPTIONS_DEFAULT= CA_BUNDLE CANBERRA DBUS NOTIFY PERL PYTHON
@@ -47,6 +47,7 @@ CA_BUNDLE_DESC= Include CA bundle for SSL verification
CANBERRA_DESC= Audio support via Libcanberra
FISHLIM_DESC= FiSHLiM plugin
TEXTFE_DESC= Text frontend
+SYSINFO_DESC= Sysinfo plugin
CA_BUNDLE_RUN_DEPENDS= ${LOCALBASE}/share/certs/ca-root-nss.crt:security/ca_root_nss
CA_BUNDLE_VARS= CA_BUNDLE="${LOCALBASE}/share/certs/ca-root-nss.crt"
@@ -72,6 +73,7 @@ PYTHON_VARS= SHEBANG_FILES=meson_post_install.py
PYTHON_VARS+= SHEBANG_FILES=plugins/perl/generate_header.py
PYTHON_VARS+= SHEBANG_FILES=src/common/make-te.py
TEXTFE_MESON_TRUE= with-text
+SYSINFO_MESON_TRUE= with-sysinfo
post-patch:
@${REINPLACE_CMD} -e 's|%%CA_BUNDLE%%|${CA_BUNDLE}|' \