aboutsummaryrefslogtreecommitdiff
path: root/irc/ii/files/patch-config.mk
diff options
context:
space:
mode:
Diffstat (limited to 'irc/ii/files/patch-config.mk')
-rw-r--r--irc/ii/files/patch-config.mk24
1 files changed, 24 insertions, 0 deletions
diff --git a/irc/ii/files/patch-config.mk b/irc/ii/files/patch-config.mk
new file mode 100644
index 000000000000..997d0fcaa937
--- /dev/null
+++ b/irc/ii/files/patch-config.mk
@@ -0,0 +1,24 @@
+--- config.mk.orig 2007-07-14 20:39:41.000000000 +0200
++++ config.mk 2008-07-13 15:38:45.000000000 +0200
+@@ -1,9 +1,9 @@
+ # Customize to fit your system
+
+ # paths
+-PREFIX = /usr/local
++PREFIX ?= /usr/local
+ BINDIR = ${PREFIX}/bin
+-MANDIR = ${PREFIX}/share/man
++MANDIR = ${PREFIX}/man
+ MAN1DIR = ${MANDIR}/man1
+ DOCDIR = ${PREFIX}/share/doc/ii
+
+@@ -22,6 +22,6 @@
+ #CFLAGS = -g ${INCLUDES} -DVERSION=\"${VERSION}\"
+
+ # compiler
+-CC = cc
+-CFLAGS = -g -O0 -W -Wall ${INCLUDES} -DVERSION=\"${VERSION}\"
+-LDFLAGS = ${LIBS}
++CC ?= cc
++CFLAGS += -g -O0 -W -Wall ${INCLUDES} -DVERSION=\"${VERSION}\"
++LDFLAGS += ${LIBS}