aboutsummaryrefslogtreecommitdiff
path: root/irc/ircproxy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/ircproxy/Makefile')
-rw-r--r--irc/ircproxy/Makefile28
1 files changed, 12 insertions, 16 deletions
diff --git a/irc/ircproxy/Makefile b/irc/ircproxy/Makefile
index a78b96fafdea..cd919dbeb507 100644
--- a/irc/ircproxy/Makefile
+++ b/irc/ircproxy/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: ircproxy
-# Date created: 10 July 2003
-# Whom: Jonas Kvinge <jonas@night-light.net>
-#
+# Created by: Jonas Kvinge <jonas@night-light.net>
# $FreeBSD$
-#
PORTNAME= ircproxy
PORTVERSION= 1.3.6
@@ -28,30 +24,30 @@ GROUPS= ircproxyd
SUB_LIST= IRC_USR=${USERS} IRC_GRP=${GROUPS}
SUB_FILES= pkg-deinstall
-OPTIONS= SSL "Enable SSL support" on \
- IPV6 "Enable IPv6 support" on \
- MEMDEBUG "Enable memory debugging" on \
- FDDEBUG "Enable file descriptor debugging" on
+OPTIONS_DEFINE= SSL IPV6 MEMDEBUG FDDEBUG
+OPTIONS_DEFAULT= SSL MEMDEBUG FDDEBUG
+MEMDEBUG_DESC= Enable memory debugging
+FDDEBUG_DESC= Enable file descriptor debugging
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_SSL)
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.if ${PORT_OPTIONS:MSSL}
+USE_OPENSSL= yes
.else
CONFIGURE_ARGS+= --disable-ssl
.endif
-.if !defined(WITH_IPV6)
+.if ! ${PORT_OPTIONS:MIPV6}
CONFIGURE_ARGS+= --disable-ipv6
.endif
-.if defined(WITH_MEMDEBUG)
+.if ${PORT_OPTIONS:MMEMDEBUG}
CONFIGURE_ARGS+= --enable-memdebug
.else
CONFIGURE_ARGS+= --disable-memdebug
.endif
-.if defined(WITH_FDDEBUG)
+.if ${PORT_OPTIONS:MFDDEBUG}
CONFIGURE_ARGS+= --enable-fddebug
.else
CONFIGURE_ARGS+= --disable-fddebug
@@ -61,4 +57,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|EUSER="ircproxy"|EUSER="ircproxyd"|g; \
s|EGROUP="users"|EGROUP="ircproxyd"|g' ${WRKSRC}/data/${PORTNAME}d.conf
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>