aboutsummaryrefslogtreecommitdiff
path: root/irc/irssi-otr/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'irc/irssi-otr/Makefile')
-rw-r--r--irc/irssi-otr/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/irc/irssi-otr/Makefile b/irc/irssi-otr/Makefile
new file mode 100644
index 000000000000..99a805467df5
--- /dev/null
+++ b/irc/irssi-otr/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: irssi-otr
+# Date created: 2008-08-16
+# Whom: Ashish Shukla <wahjava@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= irssi-otr
+PORTVERSION= 0.2
+CATEGORIES= irc
+MASTER_SITES= ftp://download.tuxfamily.org/${MASTER_SITE_SUBDIR}/
+MASTER_SITE_SUBDIR= irssiotr
+
+MAINTAINER= wahjava@gmail.com
+COMMENT= A plugin for irssi for Off-the-Record (OTR) messaging
+
+BUILD_DEPENDS= ${LOCALBASE}/include/irssi/src/common.h:${PORTSDIR}/irc/irssi
+LIB_DEPENDS= otr.4:${PORTSDIR}/security/libotr
+RUN_DEPENDS= irssi:${PORTSDIR}/irc/irssi
+
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+USE_GNOME= glib20
+
+.include <bsd.port.mk>